aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-04-19 02:30:02 +0000
committerWill Andrews <will@FreeBSD.org>2002-04-19 02:30:02 +0000
commite05ed36727813c752300995435b0dc1aee51ecc3 (patch)
treed926f0f9b039ccf866d06988fbb956f5373cb5b9 /astro
parenta9115fa27e6e7ffe5911b46d8498cdc5eff851fc (diff)
downloadports-e05ed36727813c752300995435b0dc1aee51ecc3.tar.gz
ports-e05ed36727813c752300995435b0dc1aee51ecc3.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/xglobe/Makefile25
-rw-r--r--astro/xglobe/distinfo1
-rw-r--r--astro/xglobe/files/patch-aa42
-rw-r--r--astro/xglobe/files/patch-random47
-rw-r--r--astro/xglobe/pkg-comment1
-rw-r--r--astro/xglobe/pkg-descr5
-rw-r--r--astro/xglobe/pkg-plist4
8 files changed, 0 insertions, 126 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 0ed5b69bfb41..0f7ecf76e9ce 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -45,7 +45,6 @@
SUBDIR += x3arth
SUBDIR += xearth
SUBDIR += xephem
- SUBDIR += xglobe
SUBDIR += xphoon
SUBDIR += xplanet
SUBDIR += xtide
diff --git a/astro/xglobe/Makefile b/astro/xglobe/Makefile
deleted file mode 100644
index f29b49a4ec41..000000000000
--- a/astro/xglobe/Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
-# New ports collection makefile for: xglobe
-# Date created: 20 January 1998
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= xglobe
-PORTVERSION= 0.5
-CATEGORIES= astro
-MASTER_SITES= http://www.uni-karlsruhe.de/~uddn/xglobe/
-
-MAINTAINER= kris@FreeBSD.org
-
-USE_QT_VER= 1
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-
-do-install:
- @${MKDIR} ${PREFIX}/share/xglobe/
- @${INSTALL_PROGRAM} ${WRKSRC}/xglobe ${PREFIX}/bin/
- @${INSTALL_DATA} ${WRKSRC}/map.bmp ${PREFIX}/share/xglobe/
- @${INSTALL_DATA} ${WRKSRC}/xglobe-markers ${PREFIX}/share/xglobe/
-
-.include <bsd.port.mk>
diff --git a/astro/xglobe/distinfo b/astro/xglobe/distinfo
deleted file mode 100644
index fdb8623afb24..000000000000
--- a/astro/xglobe/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (xglobe-0.5.tar.gz) = 87caf7803f1d71a0b024188e3a2c759c
diff --git a/astro/xglobe/files/patch-aa b/astro/xglobe/files/patch-aa
deleted file mode 100644
index 6ed7ce48b2f5..000000000000
--- a/astro/xglobe/files/patch-aa
+++ /dev/null
@@ -1,42 +0,0 @@
---- Makefile.orig Mon Jul 19 05:56:27 1999
-+++ Makefile Fri Aug 27 16:06:08 1999
-@@ -4,29 +4,30 @@
-
- ####### Installation directory
-
--XGLOBE_DIR = /usr/local
--XGLOBE_LIB_DIR = $(XGLOBE_DIR)/lib/xglobe
-+XGLOBE_DIR = $(PREFIX)
-+XGLOBE_LIB_DIR = $(XGLOBE_DIR)/share/xglobe
- XGLOBE_BIN_DIR = $(XGLOBE_DIR)/bin
-
- ####### Library directories - you may need to modify these
-
--X11_INCLUDE_DIR = /usr/X11R6/include
--QT_INCLUDE_DIR = $(QTDIR)/include
-+X11_INCLUDE_DIR = $(X11BASE)/include
-+QT_INCLUDE_DIR = $(X11BASE)/include/X11/qt
-
--QT_LIB_DIR = $(QTDIR)/lib
--X11_LIB_DIR = /usr/X11R6/lib
-+QT_LIB_DIR = $(X11BASE)/lib
-+X11_LIB_DIR = $(X11BASE)/lib
-
-
- ####### Compiler and tools
-
--CPP = g++
--LINK = g++
-+CXX ?= c++
-+CPP = ${CXX}
-+LINK = ${CXX}
- MOC = moc
- INSTALL = install
-
- ####### compile and link options
-
--CFLAGS = $(INCLUDE_DIRS) -DXGLOBE_LIB_DIR=\"$(XGLOBE_LIB_DIR)\" $(WITH_QIMGIO) -O2 -Wall
-+CFLAGS += $(INCLUDE_DIRS) -DXGLOBE_LIB_DIR=\"$(XGLOBE_LIB_DIR)\" $(WITH_QIMGIO)
-
- LFLAGS =
-
diff --git a/astro/xglobe/files/patch-random b/astro/xglobe/files/patch-random
deleted file mode 100644
index ba9f41cf8b9e..000000000000
--- a/astro/xglobe/files/patch-random
+++ /dev/null
@@ -1,47 +0,0 @@
---- earthapp.cpp.orig Sat Feb 24 10:13:10 2001
-+++ earthapp.cpp Sat Feb 24 10:13:29 2001
-@@ -937,8 +937,8 @@
-
- void EarthApplication::randomPosition()
- {
-- view_lat = ((rand()%30001)/30000.)*180. - 90.;
-- view_long = ((rand()%30001)/30000.)*360. - 180.;
-+ view_lat = ((random()%30001)/30000.)*180. - 90.;
-+ view_long = ((random()%30001)/30000.)*360. - 180.;
- }
-
- /* ------------------------------------------------------------------------*/
---- renderer.cpp.orig Sat Feb 24 10:12:53 2001
-+++ renderer.cpp Sat Feb 24 10:13:04 2001
-@@ -1562,9 +1562,9 @@
-
- for(int i=0; i<numstars; i++)
- {
-- x = rand() % renderedImage->width();
-- y = rand() % renderedImage->height();
-- brightness = 150+ (rand() % 106);
-+ x = random() % renderedImage->width();
-+ y = random() % renderedImage->height();
-+ brightness = 150+ (random() % 106);
- p = (unsigned int *)renderedImage->scanLine(y);
- p += x;
- *p = qRgb(brightness, brightness, brightness);
---- main.cpp.orig Tue Jul 13 10:32:55 1999
-+++ main.cpp Sat Feb 24 10:14:56 2001
-@@ -24,6 +24,7 @@
- */
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <qstring.h>
- #include "config.h"
-@@ -36,6 +37,8 @@
- int main(int argc, char **argv)
- {
- EarthApplication myApp(argc, argv);
-+
-+ srandomdev();
-
- #ifdef WITH_QIMAGEIO
- qInitImageIO();
diff --git a/astro/xglobe/pkg-comment b/astro/xglobe/pkg-comment
deleted file mode 100644
index 9fb7fa1689c3..000000000000
--- a/astro/xglobe/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Displays a view of the Earth (like xearth) with a rendered photo map
diff --git a/astro/xglobe/pkg-descr b/astro/xglobe/pkg-descr
deleted file mode 100644
index b7481b6f56a6..000000000000
--- a/astro/xglobe/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Displays a rendered view of the earth in your root window, similar to
-xearth, but instead uses a satellite image map of the earth. You can also
-substitute surface maps of other planets if you're feeling cosmic.
-
-WWW: http://www.stud.uni-karlsruhe.de/~uddn/xglobe/
diff --git a/astro/xglobe/pkg-plist b/astro/xglobe/pkg-plist
deleted file mode 100644
index e705ced823b4..000000000000
--- a/astro/xglobe/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/xglobe
-share/xglobe/map.bmp
-share/xglobe/xglobe-markers
-@dirrm share/xglobe