aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-06-17 11:37:38 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-06-17 11:37:38 +0000
commit8a90df78b38cf81a17b21e61167c4e6ecd169b08 (patch)
tree396152371698142c3e22583f273bbf3bcf178fa7 /astro
parenta26ec65849368f24287b1e38c52004c81f35ff00 (diff)
downloadports-8a90df78b38cf81a17b21e61167c4e6ecd169b08.tar.gz
ports-8a90df78b38cf81a17b21e61167c4e6ecd169b08.zip
Add compiler:c++11-lang to USES to fix the following on GCC-based systems:
configure: error: *** A compiler with support for C++11 language features is required. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=504411
Diffstat (limited to 'astro')
-rw-r--r--astro/siril/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/astro/siril/Makefile b/astro/siril/Makefile
index 0e4a22f89013..899e3887420c 100644
--- a/astro/siril/Makefile
+++ b/astro/siril/Makefile
@@ -28,7 +28,8 @@ LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libtiff.so:graphics/tiff
LIB_DEPENDS+= libopencv_photo.so:graphics/opencv # for some reason, configure fails without opencv, but executable only links to opencv-core
-USES= autoreconf desktop-file-utils gettext gmake gnome localbase pkgconfig jpeg shared-mime-info tar:bz2
+USES= autoreconf compiler:c++11-lang desktop-file-utils gettext \
+ gmake gnome localbase pkgconfig jpeg shared-mime-info tar:bz2
GNU_CONFIGURE= yes
USE_GNOME= atk cairo gdkpixbuf2 gtk30 intltool pango
INSTALLS_ICONS= yes