aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-05-17 13:16:42 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-05-17 13:16:42 +0000
commit2a20b67bb89a3d06342c320ed4eca19970244df1 (patch)
treec90e6412bd0123b04985beccb9fab1a3f7082aa6 /astro
parent7025930de5e8080304b7450be20f557ebdd857d4 (diff)
downloadports-2a20b67bb89a3d06342c320ed4eca19970244df1.tar.gz
ports-2a20b67bb89a3d06342c320ed4eca19970244df1.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/weatherspect/Makefile28
-rw-r--r--astro/weatherspect/distinfo3
-rw-r--r--astro/weatherspect/pkg-descr9
4 files changed, 41 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 941f162520d0..903589cd3c98 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -61,6 +61,7 @@
SUBDIR += stars
SUBDIR += stellarium
SUBDIR += sunclock
+ SUBDIR += weatherspect
SUBDIR += wmglobe
SUBDIR += wmjupiter
SUBDIR += wmmoonclock
diff --git a/astro/weatherspect/Makefile b/astro/weatherspect/Makefile
new file mode 100644
index 000000000000..b4241266454f
--- /dev/null
+++ b/astro/weatherspect/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: weatherspect
+# Date created: 2006-05-16
+# Whom: Simon Olofsson <simon@olofsson.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weatherspect
+PORTVERSION= 1.6
+CATEGORIES= astro
+MASTER_SITES= http://www.robobunny.com/projects/weatherspect/ \
+ http://olofsson.de/mirror/distfiles/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Weather simulation in ASCII art
+
+RUN_DEPENDS= \
+${SITE_PERL}/Term/Animation.pm:${PORTSDIR}/devel/p5-Term-Animation \
+${SITE_PERL}/Weather/Underground.pm:${PORTSDIR}/astro/p5-Weather-Underground
+
+NO_BUILD= yes
+PLIST_FILES= bin/weatherspect
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/astro/weatherspect/distinfo b/astro/weatherspect/distinfo
new file mode 100644
index 000000000000..bb1ff43804d3
--- /dev/null
+++ b/astro/weatherspect/distinfo
@@ -0,0 +1,3 @@
+MD5 (weatherspect_v1.6.tar.gz) = bb875643d57dd59fcc0c6ef50b58195f
+SHA256 (weatherspect_v1.6.tar.gz) = 3e24ed011f527ac11c06db1b5b63fe2a762cda982136b4a3a28b4470fa1cf6d0
+SIZE (weatherspect_v1.6.tar.gz) = 24856
diff --git a/astro/weatherspect/pkg-descr b/astro/weatherspect/pkg-descr
new file mode 100644
index 000000000000..d93664d50cad
--- /dev/null
+++ b/astro/weatherspect/pkg-descr
@@ -0,0 +1,9 @@
+WeatherSpect provides a reasonably accurate simulation of what the
+weather looks like outside, in ASCII art. It includes rain, snow,
+lightning, sleet, and hail. The windspeed and cloudiness are reflected
+in the velocity and quantity of clouds. There are trees that age,
+reproduce and die over the course of an hour, and a sun and moon that
+follow the actual sun and moonrise. There's also a dancing turtle.
+
+Author: Kirk Baucom <kbaucom@schizoid.com>
+WWW: http://www.robobunny.com/projects/weatherspect/html/