aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-31 00:00:24 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-31 00:00:24 +0000
commitab4bff65b82a8958a10e57f3756744acb702c6cc (patch)
tree5e1930effebb3a15311fb2257f0bc0b3e4be2b94 /astro
parent73f1b697678bd8065c8966680fe624b0e8d6a1e6 (diff)
downloadports-ab4bff65b82a8958a10e57f3756744acb702c6cc.tar.gz
ports-ab4bff65b82a8958a10e57f3756744acb702c6cc.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/weatherget/Makefile36
-rw-r--r--astro/weatherget/distinfo3
-rw-r--r--astro/weatherget/pkg-descr7
4 files changed, 47 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 08b5baa5cb8c..2c4170bce875 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -67,6 +67,7 @@
SUBDIR += sunclock
SUBDIR += tclgeomap
SUBDIR += tkgeomap
+ SUBDIR += weatherget
SUBDIR += weatherspect
SUBDIR += wmglobe
SUBDIR += wmjupiter
diff --git a/astro/weatherget/Makefile b/astro/weatherget/Makefile
new file mode 100644
index 000000000000..8252e43c7b08
--- /dev/null
+++ b/astro/weatherget/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: weatherget
+# Date created: 31 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weatherget
+PORTVERSION= 0.3
+CATEGORIES= astro
+MASTER_SITES= BERLIOS
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Command-line weather reporting tool
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+#USE_PYDISTUTILS=yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PORTDOCS= AUTHORS CHANGELOG README
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^#!/s|!.*|!${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/weatherget/distinfo b/astro/weatherget/distinfo
new file mode 100644
index 000000000000..6660b095d99f
--- /dev/null
+++ b/astro/weatherget/distinfo
@@ -0,0 +1,3 @@
+MD5 (weatherget-0.3.tar.bz2) = 2296d6dc9eeae92972a37063f0be0305
+SHA256 (weatherget-0.3.tar.bz2) = 1444193b9c8cc09779c7b86ed2d2871fbb7dec823ce8f3324179b23c6ec75d3f
+SIZE (weatherget-0.3.tar.bz2) = 13363
diff --git a/astro/weatherget/pkg-descr b/astro/weatherget/pkg-descr
new file mode 100644
index 000000000000..72828ef24412
--- /dev/null
+++ b/astro/weatherget/pkg-descr
@@ -0,0 +1,7 @@
+A command line based weather reporting tool written in python. View
+current weather conditions, extended day forecasts, and station id
+lookups as reported from weather.com. Customize output via weathergetrc
+configuration file. Platform independent.
+
+WWW: http://developer.berlios.de/projects/weatherget/
+Author: Tyler Gates <TGates81@gmail.com>