aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorCrist J. Clark <cjc@FreeBSD.org>2003-04-12 17:07:42 +0000
committerCrist J. Clark <cjc@FreeBSD.org>2003-04-12 17:07:42 +0000
commitb61982d0c0c043bdbac6c9c3b4be2c3c49b928b8 (patch)
tree33a044f5f064dee158351503128af17c65e2ee9e /astro
parentc64b3d609f266e0bb0b37dba45246594f49ed30a (diff)
downloadports-b61982d0c0c043bdbac6c9c3b4be2c3c49b928b8.tar.gz
ports-b61982d0c0c043bdbac6c9c3b4be2c3c49b928b8.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/setiathome/Makefile2
-rw-r--r--astro/setiathome/files/setiathome.sh20
2 files changed, 12 insertions, 10 deletions
diff --git a/astro/setiathome/Makefile b/astro/setiathome/Makefile
index e5eaec458bf3..171bf0498158 100644
--- a/astro/setiathome/Makefile
+++ b/astro/setiathome/Makefile
@@ -6,7 +6,7 @@
PORTNAME= setiathome
PORTVERSION?= 3.03
-PORTREVISION?= 6
+PORTREVISION?= 7
CATEGORIES?= astro
MASTER_SITES= ftp://ftp.cdrom.com/pub/setiathome/ \
ftp://alien.ssl.berkeley.edu/pub/
diff --git a/astro/setiathome/files/setiathome.sh b/astro/setiathome/files/setiathome.sh
index 5ef7c315747f..57b4a55d22aa 100644
--- a/astro/setiathome/files/setiathome.sh
+++ b/astro/setiathome/files/setiathome.sh
@@ -74,17 +74,19 @@ start)
fi
done
for i in ${seti_wrksuff}; do
- su -fm ${seti_user} -c "\
- cd ${seti_wrkdir}/${i} || exit; \
- echo \$\$ > shpid.sah; \
- trap 'kill \$pid;exit' 15; \
- while :; do \
+ su -fm ${seti_user} -c "exec /bin/sh -T" << EOF > /dev/null &
+ cd ${seti_wrkdir}/${i} || exit
+ echo \$\$ > shpid.sah
+ trap 'kill \$pid;exit' 15
+ while :; do
${program_path} \
${seti_std_args} ${seti_proxy_args} \
- ${seti_nice:+-nice} ${seti_nice} & \
- pid=\$!; wait \$pid; \
- sleep ${seti_sleep}; \
- done > /dev/null" &
+ ${seti_nice:+-nice} ${seti_nice} &
+ pid=\$!; wait \$pid
+ sleep ${seti_sleep} &
+ pid=\$!; wait \$pid
+ done
+EOF
done
echo -n " SETI@home"
;;