aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-10-16 15:29:32 +0000
committerRene Ladan <rene@FreeBSD.org>2019-10-16 15:29:32 +0000
commit13d4527a34237c3848445140a659128518ca196f (patch)
treea59de3287464c291f091b739fe407ba6df10c951 /astro
parenta12065703469e10f4f34b1e43555af92cfceaa6c (diff)
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile2
-rw-r--r--astro/gpsdrive/Makefile49
-rw-r--r--astro/gpsdrive/distinfo2
-rw-r--r--astro/gpsdrive/files/patch-src_gpsserial.c13
-rw-r--r--astro/gpsdrive/files/patch-src_splash.c60
-rw-r--r--astro/gpsdrive/pkg-descr8
-rw-r--r--astro/gpsdrive/pkg-message10
-rw-r--r--astro/gpsdrive/pkg-plist66
-rw-r--r--astro/planets/Makefile39
-rw-r--r--astro/planets/distinfo2
-rw-r--r--astro/planets/files/patch-options.ml106
-rw-r--r--astro/planets/pkg-descr4
-rw-r--r--astro/planets/pkg-plist4
13 files changed, 0 insertions, 365 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 3cf1f1233003..982a02ba0412 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -22,7 +22,6 @@
SUBDIR += gpsbabel14
SUBDIR += gpscorrelate
SUBDIR += gpsd
- SUBDIR += gpsdrive
SUBDIR += gpsman
SUBDIR += gpsprune
SUBDIR += gpstk
@@ -78,7 +77,6 @@
SUBDIR += p5-Starlink-AST
SUBDIR += p5-Weather-Underground
SUBDIR += phoon
- SUBDIR += planets
SUBDIR += pp3
SUBDIR += ptiger
SUBDIR += py-RO
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
deleted file mode 100644
index acc63594d151..000000000000
--- a/astro/gpsdrive/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# Created by: Marco Molteni <molter@gufi.org>
-# $FreeBSD$
-
-PORTNAME= gpsdrive
-PORTVERSION= 2.09
-PORTREVISION= 16
-CATEGORIES= astro geography
-MASTER_SITES= http://www.gpsdrive.de/packages/ \
- LOCAL/beech
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GPS navigation system
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BROKEN= unfetchable
-DEPRECATED= Unfetchable, unmaintained
-EXPIRATION_DATE= 2019-10-16
-
-LIB_DEPENDS= libpcre.so:devel/pcre
-RUN_DEPENDS= bash:shells/bash
-
-USES= gmake libtool perl5 pkgconfig shebangfix
-SHEBANG_FILES= src/gpsfetchmap.pl src/geocache2way src/gpssmswatch \
- src/gpspoint2gpsdrive.pl src/gpsreplay src/wpcvt
-USE_GNOME= gtk20
-USE_LDCONFIG= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-garmin
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lgmodule-2.0 -lm
-INSTALL_TARGET= install-strip
-MAKE_JOBS_UNSAFE= yes
-
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
-NLS_USES= gettext
-NLS_USES_OFF= gettext-tools
-
-post-patch:
- @${REINPLACE_CMD} 's/test "$$CC" = "gcc"/false/' ${WRKSRC}/configure
-post-patch-NLS-off:
- @${REINPLACE_CMD} 's|SUBDIRS = src po man|SUBDIRS = src man|' \
- ${WRKSRC}/Makefile.in
-
-.include <bsd.port.mk>
diff --git a/astro/gpsdrive/distinfo b/astro/gpsdrive/distinfo
deleted file mode 100644
index 412741666e68..000000000000
--- a/astro/gpsdrive/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gpsdrive-2.09.tar.gz) = fe8ef35c86df9ab7c8dfb1a8b8155fbeeacd8693ae867f0f10f79f14b7dc6f98
-SIZE (gpsdrive-2.09.tar.gz) = 1745509
diff --git a/astro/gpsdrive/files/patch-src_gpsserial.c b/astro/gpsdrive/files/patch-src_gpsserial.c
deleted file mode 100644
index 208613e2d91c..000000000000
--- a/astro/gpsdrive/files/patch-src_gpsserial.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/gpsserial.c.orig 2004-02-12 17:42:53 UTC
-+++ src/gpsserial.c
-@@ -178,7 +178,9 @@ readinput_init (void)
- CLOCAL : local connection, no modem contol
- CREAD : enable receiving characters
- */
-- newtio.c_cflag = (11 + serialspeed) | CS8 | CLOCAL | CREAD;
-+ { int t[] = { 2400, 4800, 9600, 19200, 38400 };
-+ newtio.c_ispeed = newtio.c_ospeed = t[serialspeed]; }
-+ newtio.c_cflag = CS8 | CLOCAL | CREAD;
- newtio.c_cflag &= ~(PARENB | CRTSCTS);
- /*
- IGNPAR : ignore bytes with parity errors
diff --git a/astro/gpsdrive/files/patch-src_splash.c b/astro/gpsdrive/files/patch-src_splash.c
deleted file mode 100644
index 5f12a99db103..000000000000
--- a/astro/gpsdrive/files/patch-src_splash.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- src/splash.c.orig 2004-03-02 03:07:17 UTC
-+++ src/splash.c
-@@ -529,6 +529,24 @@ insert_text (GtkTextBuffer * buffer)
- {
- GtkTextIter iter;
- GtkTextIter start, end;
-+ gchar *t1 =
-+ _
-+ ("Left mouse button : Set position (usefull in simulation mode)\n"
-+ "Right mouse button : Set target directly on the map\n"
-+ "Middle mouse button : Display position again\n"
-+ "Shift left mouse button : smaller map\n"
-+ "Shift right mouse button : larger map\n"
-+ "Control left mouse button : Set a waypoint (mouse position) on the map\n"
-+ "Control right mouse button: Set a waypoint at current position on the map\n\n");
-+ gchar *t2 = _("j : switch to next waypoint in route mode\n"
-+ "x : add waypoint at current position\n"
-+ "y : add waypoint at mouse cursor position\n");
-+ gchar *t3 =
-+ _("Press the underlined key together with the ALT-key.\n\n"
-+ "You can move on the map by selecting the Position-Mode"
-+ " in the menu. A blue rectangle shows this mode, you can set this cursor by clicking on the map."
-+ " If you click on the border of the map (the outer 20%) then the map switches to the next area.\n\n"
-+ "Suggestions welcome.\n\n");
-
- /* demo_find_file() looks in the the current directory first,
- * so you can run gtk-demo without installing GTK, then looks
-@@ -564,19 +582,7 @@ insert_text (GtkTextBuffer * buffer)
- -1, "blue_foreground", NULL);
-
- gtk_text_buffer_insert (buffer, &iter, "\n", -1);
-- gchar *t1 =
-- _
-- ("Left mouse button : Set position (usefull in simulation mode)\n"
-- "Right mouse button : Set target directly on the map\n"
-- "Middle mouse button : Display position again\n"
-- "Shift left mouse button : smaller map\n"
-- "Shift right mouse button : larger map\n"
-- "Control left mouse button : Set a waypoint (mouse position) on the map\n"
-- "Control right mouse button: Set a waypoint at current position on the map\n\n");
-
-- gchar *t2 = _("j : switch to next waypoint in route mode\n"
-- "x : add waypoint at current position\n"
-- "y : add waypoint at mouse cursor position\n");
- gtk_text_buffer_insert (buffer, &iter, t1, -1);
-
- gtk_text_buffer_insert_with_tags_by_name (buffer, &iter,
-@@ -592,12 +598,6 @@ insert_text (GtkTextBuffer * buffer)
- -1, "underline", NULL);
- gtk_text_buffer_insert (buffer, &iter, _(" letters in the button text.\n"),
- -1);
-- gchar *t3 =
-- _("Press the underlined key together with the ALT-key.\n\n"
-- "You can move on the map by selecting the Position-Mode"
-- " in the menu. A blue rectangle shows this mode, you can set this cursor by clicking on the map."
-- " If you click on the border of the map (the outer 20%) then the map switches to the next area.\n\n"
-- "Suggestions welcome.\n\n");
- gtk_text_buffer_insert (buffer, &iter, t3, -1);
- gtk_text_buffer_insert_with_tags_by_name (buffer, &iter,
- _("Have a lot of fun!"), -1,
diff --git a/astro/gpsdrive/pkg-descr b/astro/gpsdrive/pkg-descr
deleted file mode 100644
index 3df8b5a1443e..000000000000
--- a/astro/gpsdrive/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-GpsDrive is a car (bike, ship, plane) GPS navigation system.
-
-GpsDrive displays the position provided from a NMEA-capable GPS receiver on
-a zoomable map. The map file is autoselected depending on the position and
-preferred scale. Speech output is supported if the "festival" software is
-running. Waypoint database is supported via MySQL (optional).
-
-WWW: http://www.gpsdrive.de/
diff --git a/astro/gpsdrive/pkg-message b/astro/gpsdrive/pkg-message
deleted file mode 100644
index 0be1c04dfc7e..000000000000
--- a/astro/gpsdrive/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-[
-{ type: install
- message: <<EOM
-FreeBSD NOTES:
-
-Support for Garmin format input is disabled because buggy.
-Set your GPS device to NMEA mode and start gpsd before gpsdrive.
-EOM
-}
-]
diff --git a/astro/gpsdrive/pkg-plist b/astro/gpsdrive/pkg-plist
deleted file mode 100644
index 102a58695044..000000000000
--- a/astro/gpsdrive/pkg-plist
+++ /dev/null
@@ -1,66 +0,0 @@
-bin/friendsd2
-bin/geo-code
-bin/geo-nearest
-bin/geocache2way
-bin/gpsd
-bin/gpsdrive
-bin/gpsfetchmap.pl
-bin/gpspoint2gpsdrive.pl
-bin/gpsreplay
-bin/gpssmswatch
-bin/gpssql_backup.sh
-bin/gpssql_restore.sh
-bin/wpcvt
-bin/wpget
-lib/libfly.a
-lib/libfly.so
-lib/libfly.so.2
-lib/libfly.so.2.0.0
-lib/libnautic.a
-lib/libnautic.so
-lib/libnautic.so.2
-lib/libnautic.so.2.0.0
-man/de/man1/gpsdrive.1.gz
-man/es/man1/gpsdrive.1.gz
-man/man1/gpsdrive.1.gz
-share/applications/gpsdrive.desktop
-%%DATADIR%%/AUTHORS
-%%DATADIR%%/CREDITS
-%%DATADIR%%/FAQ.gpsdrive
-%%DATADIR%%/FAQ.gpsdrive.fr
-%%DATADIR%%/GPS-receivers
-%%DATADIR%%/LEEME
-%%DATADIR%%/LISEZMOI
-%%DATADIR%%/NMEA.txt
-%%DATADIR%%/README
-%%DATADIR%%/README.FreeBSD
-%%DATADIR%%/README.SQL
-%%DATADIR%%/README.gpspoint2gspdrive
-%%DATADIR%%/README.kismet
-%%DATADIR%%/README.nasamaps
-%%DATADIR%%/TODO
-%%DATADIR%%/create.sql
-%%DATADIR%%/friendsicon.png
-%%DATADIR%%/gpsdriveanim.gif
-%%DATADIR%%/gpsdrivemini.png
-%%DATADIR%%/gpsdrivesplash.png
-%%DATADIR%%/gpsicon.png
-%%DATADIR%%/gpsiconbt.png
-%%DATADIR%%/top_GPSWORLD.jpg
-%%DATADIR%%/wp2sql
-%%NLS%%share/locale/da/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/de/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/de_AT/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/es/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/gr/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/it/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/no/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/gpsdrive.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/gpsdrive.mo
-share/pixmaps/gpsicon.png
diff --git a/astro/planets/Makefile b/astro/planets/Makefile
deleted file mode 100644
index 44b55d378c46..000000000000
--- a/astro/planets/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= planets
-PORTVERSION= 0.1.13
-PORTREVISION= 1
-CATEGORIES= astro
-MASTER_SITES= GENTOO \
- http://planets.homedns.org/dist/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Orbital simulator
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BROKEN= unfetchable
-DEPRECATED= Unfetchable, unmaintained
-EXPIRATION_DATE= 2019-10-16
-
-USES= gmake tar:tgz
-USE_OCAML= yes
-USE_OCAML_CAMLP4=yes
-USE_OCAML_TK= yes
-USE_XORG= x11
-ALL_TARGET= ${PORTNAME}
-
-OPTIONS_DEFINE= DOCS
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/planets.1 ${STAGEDIR}${MANPREFIX}/man/man1
-
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/KEYBINDINGS.txt ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/getting_started.html ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/astro/planets/distinfo b/astro/planets/distinfo
deleted file mode 100644
index 449d87b3afc7..000000000000
--- a/astro/planets/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (planets-0.1.13.tgz) = cd4be19dc1e16cc3d5bb20fdfa2af025b50cd21dbce5d1e8b3041c4e786c3624
-SIZE (planets-0.1.13.tgz) = 49732
diff --git a/astro/planets/files/patch-options.ml b/astro/planets/files/patch-options.ml
deleted file mode 100644
index 51cdf4657bb1..000000000000
--- a/astro/planets/files/patch-options.ml
+++ /dev/null
@@ -1,106 +0,0 @@
---- options.ml
-+++ options.ml
-@@ -93,7 +93,7 @@ end
- (*********************************************************************)
- (* 'a is the data type, 'b is the widget type *)
-
--class virtual ['a,'b] option ?name ~text ~set:(set:'a->unit) ~get () =
-+class virtual ['a,'b,'c] option ?name ~text ~set:(set:'a->unit) ~get () =
- let name = (match name with
- None -> random_name 10
- | Some name -> name ) in
-@@ -104,7 +104,7 @@ object (self)
- val name = name
- val text = (text : string)
-
-- method virtual build_widget : live:bool -> 'b
-+ method virtual build_widget : live:bool -> 'b
- method display ~live parent =
- ignore (self#build_widget ~live parent);
- match widget with
-@@ -126,9 +126,9 @@ end
-
- (*********************)
-
--class ['b] toggle_option ?name ~text ~set ~get () =
-+class ['b,'c] toggle_option ?name ~text ~set ~get () =
- object (self)
-- inherit [bool,'b] option ?name ~text ~set ~get ()
-+ inherit [bool,'b,'c] option ?name ~text ~set ~get ()
-
- method set_tk bool =
- Textvariable.set tk_var (if bool then "true" else "false")
-@@ -153,9 +153,9 @@ end
-
- (*********************)
-
--class ['b] int_scale_option ?name ~min ~max ~text ~set ~get () =
-+class ['b,'c] int_scale_option ?name ~min ~max ~text ~set ~get () =
- object (self)
-- inherit [int,'b] option ?name ~text ~set ~get ()
-+ inherit [int,'b,'c] option ?name ~text ~set ~get ()
- val min = min
- val max = max
-
-@@ -192,10 +192,10 @@ end
-
- (*******************************************************)
-
--class ['b] float_scale_option ?name ~min ~max ?(resolution=1.0)
-+class ['b, 'c] float_scale_option ?name ~min ~max ?(resolution=1.0)
- ~text ~set ~get () =
- object (self)
-- inherit [float, 'b] option ?name ~text ~set ~get ()
-+ inherit [float, 'b, 'c] option ?name ~text ~set ~get ()
- val min = min
- val max = max
-
-@@ -236,10 +236,10 @@ let string_of_float x =
- then string ^ "0"
- else string
-
--class ['b] float_entry_option ?name ?(mult=1.1)
-+class ['b, 'c] float_entry_option ?name ?(mult=1.1)
- ~text ~set ~get () =
- object (self)
-- inherit [float, 'b] option ?name ~text ~set ~get ()
-+ inherit [float, 'b, 'c] option ?name ~text ~set ~get ()
-
- val mutable entry = None
-
-@@ -303,9 +303,9 @@ end
-
- (*******************************************************)
-
--class ['b] float_entry_display ?name ~text ~set ~get () =
-+class ['b, 'c] float_entry_display ?name ~text ~set ~get () =
- object (self)
-- inherit [float, 'b] option ?name ~text ~set ~get ()
-+ inherit [float, 'b, 'c] option ?name ~text ~set ~get ()
-
- val mutable display = None
-
-@@ -337,9 +337,9 @@ end
-
- (*******************************************************)
-
--class ['b] int_entry_display ?name ~text ~set ~get () =
-+class ['b, 'c] int_entry_display ?name ~text ~set ~get () =
- object (self)
-- inherit [int, 'b] option ?name ~text ~set ~get ()
-+ inherit [int, 'b, 'c] option ?name ~text ~set ~get ()
-
- val mutable display = None
-
-@@ -371,9 +371,9 @@ end
-
- (*******************************************************)
-
--class ['b] void_entry_display ?name ~text () =
-+class ['b, 'c] void_entry_display ?name ~text () =
- object (self)
-- inherit [unit, 'b] option ?name ~text
-+ inherit [unit, 'b, 'c] option ?name ~text
- ~set:(fun x -> ()) ~get:(fun () -> ())
- ()
-
diff --git a/astro/planets/pkg-descr b/astro/planets/pkg-descr
deleted file mode 100644
index 1c4f6a7474e8..000000000000
--- a/astro/planets/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Planets is a simple interactive program for playing with simulations of
-planetary systems.
-
-WWW: http://planets.homedns.org/
diff --git a/astro/planets/pkg-plist b/astro/planets/pkg-plist
deleted file mode 100644
index 4421172c3041..000000000000
--- a/astro/planets/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/planets
-man/man1/planets.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/KEYBINDINGS.txt
-%%PORTDOCS%%%%DOCSDIR%%/getting_started.html