aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-19 15:47:05 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-19 15:47:05 +0000
commit6e1a003d2b844a253baa89d4a17f09aa7ecee310 (patch)
tree3d3d7fe64a832f72cf631605d6273617fde4b369 /astro
parentd2b2b00e2eaeae41daa2e6d1d888b977a33732a8 (diff)
downloadports-6e1a003d2b844a253baa89d4a17f09aa7ecee310.tar.gz
ports-6e1a003d2b844a253baa89d4a17f09aa7ecee310.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/ptiger/Makefile12
-rw-r--r--astro/tclgeomap/Makefile10
-rw-r--r--astro/tkgeomap/Makefile19
3 files changed, 14 insertions, 27 deletions
diff --git a/astro/ptiger/Makefile b/astro/ptiger/Makefile
index ca7d8475ccfe..3cba010003f1 100644
--- a/astro/ptiger/Makefile
+++ b/astro/ptiger/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ptiger
-# Date created: 26 August 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ptiger
PORTVERSION= 2.2
@@ -11,12 +7,12 @@ PORTREVISION= 3
CATEGORIES= astro tk
MASTER_SITES= SF/tkgeomap/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tcltk@FreeBSD.org
COMMENT= Displays U.S. Census Bureau populated places on a map
-LIB_DEPENDS= tkgeomap.0:${PORTSDIR}/astro/tkgeomap
+LIB_DEPENDS= libtkgeomap.so:${PORTSDIR}/astro/tkgeomap
-USE_TK_RUN= yes
+USES+= tk:run
NO_BUILD= yes
post-patch:
diff --git a/astro/tclgeomap/Makefile b/astro/tclgeomap/Makefile
index 6cdb5e6c0cfe..7cdec1275de0 100644
--- a/astro/tclgeomap/Makefile
+++ b/astro/tclgeomap/Makefile
@@ -1,19 +1,15 @@
-# New ports collection makefile for: tclgeomap
-# Date created: 25 August 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tclgeomap
PORTVERSION= 2.11.6
CATEGORIES= astro tcl
MASTER_SITES= SF/tkgeomap/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tcltk@FreeBSD.org
COMMENT= Read, manipulate, and display geo data
-USE_TCL= 84+
+USES+= tcl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR}
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
diff --git a/astro/tkgeomap/Makefile b/astro/tkgeomap/Makefile
index 8f8b4e995699..c61bbd9adffa 100644
--- a/astro/tkgeomap/Makefile
+++ b/astro/tkgeomap/Makefile
@@ -1,36 +1,31 @@
-# New ports collection makefile for: tkgeomap
-# Date created: 25 August 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tkgeomap
PORTVERSION= 2.11.6
CATEGORIES= astro tk
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tcltk@FreeBSD.org
COMMENT= Read, manipulate, and display geo data
-LIB_DEPENDS= tclgeomap.0:${PORTSDIR}/astro/tclgeomap
+LIB_DEPENDS= libtclgeomap.so:${PORTSDIR}/astro/tclgeomap
CONFIGURE_ARGS= --with-tclgeomap-include=${LOCALBASE}/include/tclgeomap --with-x \
--with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
--with-tk=${TK_LIBDIR} --with-tkinclude=${TK_INCLUDEDIR} \
--x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include
-CONFIGURE_ENV= TCLGEOMAP_LIB=${LOCALBASE}/lib/tclgeomap
-USE_TK= 84+
+MAKE_ENV+= TCLGEOMAP_LIB="-L ${LOCALBASE}/lib -ltclgeomap"
+USES+= tk
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-TKPKG= ${PORTNAME}
-PLIST_SUB= INC=include/${TKPKG} LIB=lib/${TKPKG}
+PLIST_SUB= INC=include/${PORTNAME} LIB=lib/${PORTNAME}
USE_LDCONFIG= yes
MANN= igeomap.n tkgeomap.n tkgeomap_procs.n wdgeomap.n
post-install:
- @${LN} -sf ${PREFIX}/lib/lib${TKPKG}.so ${PREFIX}/lib/lib${PORTNAME}.so.0
+ @${LN} -sf ${PREFIX}/lib/lib${PORTNAME}.so ${PREFIX}/lib/lib${PORTNAME}.so.0
post-patch:
@${REINPLACE_CMD} -e '/=.*PACKAGE_VERSION/s|$${PACKAGE_VERSION}||g' ${WRKSRC}/configure