aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-18 07:49:17 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-18 07:49:17 +0000
commitba08f95fa0b148154bcaae46225b9f193128b7c0 (patch)
treeaa620be369f59fba5519c752c5b05c57dbbffd60 /astro
parentcac42264aff6171d257db873d2fdd63fc653c704 (diff)
downloadports-ba08f95fa0b148154bcaae46225b9f193128b7c0.tar.gz
ports-ba08f95fa0b148154bcaae46225b9f193128b7c0.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/astrometry/Makefile3
-rw-r--r--astro/py-aipy/Makefile5
-rw-r--r--astro/pyephem/Makefile5
-rw-r--r--astro/pyweather/Makefile2
4 files changed, 6 insertions, 9 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 7eaf91e8b6b4..16b39b7291aa 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libnetpbm.so:${PORTSDIR}/graphics/netpbm
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gmake pkgconfig tar:bzip2
-USE_PYTHON= yes
+USES= gmake pkgconfig python tar:bzip2
ALL_TARGET= all extra
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
diff --git a/astro/py-aipy/Makefile b/astro/py-aipy/Makefile
index ae51ffd1e672..d63e2d0b02f6 100644
--- a/astro/py-aipy/Makefile
+++ b/astro/py-aipy/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/astro/pyephem/Makefile b/astro/pyephem/Makefile
index 5f56990264e2..a8597dac0d9b 100644
--- a/astro/pyephem/Makefile
+++ b/astro/pyephem/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= CHEESESHOP
MAINTAINER= wen@FreeBSD.org
COMMENT= Scientific-grade astronomical computations for Python
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/astro/pyweather/Makefile b/astro/pyweather/Makefile
index eef19bd45080..2d2997585767 100644
--- a/astro/pyweather/Makefile
+++ b/astro/pyweather/Makefile
@@ -10,7 +10,7 @@ DISTNAME= pyWeather
MAINTAINER= ports@FreeBSD.org
COMMENT= Python script that downloads weather data and can be cronned
-USE_PYTHON= yes
+USES= python
NO_BUILD= yes
PLIST_FILES= bin/pyWeather