aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-25 13:43:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-25 13:43:32 +0000
commit36adcf8c6b041841eadcd6a1cefa32754180331f (patch)
treec0aaa71fbb753d56d12e8726a0b28f21653f5f3a /astro
parentee6434acd4e786bf90ea2fa649c677c98dd7905e (diff)
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/prune/Makefile36
-rw-r--r--astro/prune/distinfo3
-rw-r--r--astro/prune/files/prune.sh.in9
-rw-r--r--astro/prune/pkg-descr14
5 files changed, 63 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 9d858636dff7..29435d1238ce 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -60,6 +60,7 @@
SUBDIR += planets
SUBDIR += position
SUBDIR += pp3
+ SUBDIR += prune
SUBDIR += ptiger
SUBDIR += py-aipy
SUBDIR += py-astLib
diff --git a/astro/prune/Makefile b/astro/prune/Makefile
new file mode 100644
index 000000000000..d5625ea12754
--- /dev/null
+++ b/astro/prune/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: prune
+# Date created: 25 Jun 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prune
+PORTVERSION= 7
+CATEGORIES= astro java
+MASTER_SITES= http://activityworkshop.net/software/prune/ \
+ http://mirror.amdmi3.ru/distfiles/
+DISTNAME= ${PORTNAME}_0${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY= # empty
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Application for viewing, editing and converting GPS coordinate data
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+
+SUB_FILES= prune.sh
+SUB_LIST= JARNAME=${DISTNAME}
+
+PLIST_FILES= bin/prune ${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME}
+
+do-install:
+ ${MKDIR} ${JAVAJARDIR}/
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${JAVAJARDIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/prune.sh ${PREFIX}/bin/prune
+
+.include <bsd.port.mk>
diff --git a/astro/prune/distinfo b/astro/prune/distinfo
new file mode 100644
index 000000000000..e62f947456c3
--- /dev/null
+++ b/astro/prune/distinfo
@@ -0,0 +1,3 @@
+MD5 (prune_07.jar) = 4e49ec5854946de73a7045fadafadd88
+SHA256 (prune_07.jar) = 064d93369c2a512eda7674358f384a56b676da6b856e19eb92367b5cd31ab633
+SIZE (prune_07.jar) = 403911
diff --git a/astro/prune/files/prune.sh.in b/astro/prune/files/prune.sh.in
new file mode 100644
index 000000000000..5a91e4813542
--- /dev/null
+++ b/astro/prune/files/prune.sh.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA="%%LOCALBASE%%/bin/java"
+JARPATH="%%JAVALIBDIR%%"
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+exec "${JAVA}" -jar "${JARPATH}/%%JARNAME%%" "$@"
diff --git a/astro/prune/pkg-descr b/astro/prune/pkg-descr
new file mode 100644
index 000000000000..5c9f74be2bf6
--- /dev/null
+++ b/astro/prune/pkg-descr
@@ -0,0 +1,14 @@
+Prune is an application for viewing, editing and converting coordinate
+data from GPS systems. Basically it's a tool to let you play with
+your GPS data after you get home from your trip.
+
+It can load data from arbitrary text-based formats (for example,
+any tab-separated or comma-separated file) or Xml, or directly from
+a GPS receiver. It can display the data (as map view using openstreetmap
+images and as altitude profile), edit this data (for example delete
+points and ranges, sort waypoints, compress tracks), and save the
+data (in various text-based formats). It can also export data as a
+Gpx file, or as Kml/Kmz for import into Google Earth, or send it
+to a GPS receiver.
+
+WWW: http://activityworkshop.net/software/prune/