aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-28 06:20:50 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-28 06:20:50 +0000
commit993c0fba3bc3c68aae99a02e758c98dc81222a87 (patch)
tree1252cec02ab111a827354dbef2015465d7c6299e /astro
parent6b73a9dcea130dc81f8315d54b94ceff0e3ea882 (diff)
downloadports-993c0fba3bc3c68aae99a02e758c98dc81222a87.tar.gz
ports-993c0fba3bc3c68aae99a02e758c98dc81222a87.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/sunclock/Makefile7
-rw-r--r--astro/sunclock/distinfo6
-rw-r--r--astro/sunclock/files/patch-Imakefile (renamed from astro/sunclock/files/patch-aa)23
-rw-r--r--astro/sunclock/files/patch-editkit__Imakefile45
-rw-r--r--astro/sunclock/pkg-plist19
5 files changed, 38 insertions, 62 deletions
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index debda32f1f52..3cd8a36a6557 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -7,9 +7,10 @@
#
PORTNAME= sunclock
-PORTVERSION= 3.54.1
+PORTVERSION= 3.55
CATEGORIES= astro x11-clocks
-MASTER_SITES= http://mbsd.msk.ru/dist/
+MASTER_SITES= ftp://ftp.ac-grenoble.fr/ge/geosciences/sunclock/ \
+ http://mbsd.msk.ru/dist/
MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= Shows which portion of the Earth's surface is illuminated by the Sun
@@ -22,6 +23,6 @@ USE_XPM= yes
USE_IMAKE= yes
CFLAGS+= -I${LOCALBASE}/include
-MAN1= sunclock.1 emx.1
+MAN1= sunclock.1
.include <bsd.port.mk>
diff --git a/astro/sunclock/distinfo b/astro/sunclock/distinfo
index 5c2a89e3a041..bd4772d05a24 100644
--- a/astro/sunclock/distinfo
+++ b/astro/sunclock/distinfo
@@ -1,3 +1,3 @@
-MD5 (sunclock-3.54.1.tar.bz2) = 2ac6e715a048d848ff67baf2af1cd9d0
-SHA256 (sunclock-3.54.1.tar.bz2) = 5267312cd146e9aeeada81866f0584511b893e1697154a9296834e7b9a5af4eb
-SIZE (sunclock-3.54.1.tar.bz2) = 602245
+MD5 (sunclock-3.55.tar.bz2) = a6433a4d0103ade513cc1ea5ff9332e7
+SHA256 (sunclock-3.55.tar.bz2) = f2ed08f7f9e693c7639d001154e72523e840a2d56c96974cec77bbd3130f415d
+SIZE (sunclock-3.55.tar.bz2) = 1313010
diff --git a/astro/sunclock/files/patch-aa b/astro/sunclock/files/patch-Imakefile
index cbe7021bf6ca..16d095369c03 100644
--- a/astro/sunclock/files/patch-aa
+++ b/astro/sunclock/files/patch-Imakefile
@@ -1,5 +1,5 @@
---- Imakefile.orig Tue Aug 2 00:13:59 2005
-+++ Imakefile Fri Nov 25 18:21:34 2005
+--- Imakefile.orig Sun Jun 18 23:58:50 2006
++++ Imakefile Wed Jul 26 14:47:03 2006
@@ -1,18 +1,18 @@
XCOMM Should install to /usr or /usr/local ??
-DESTDIR=/usr
@@ -53,3 +53,22 @@
DEPLIBS= # I don't know what I'm doing, and I hate imake!
ComplexProgramTarget(sunclock)
+@@ -64,7 +64,7 @@
+ all::
+ cd editkit ; xmkmf ; make emx \
+ DESTDIR=$(DESTDIR) \
+- BINDIR=$(SHAREDIR)/bin \
++ BINDIR=/bin \
+ MANDIR=$(SHAREDIR)/editkit \
+ SHAREDIR=$(DESTDIR)$(SHAREDIR)/editkit
+
+@@ -78,8 +78,7 @@
+ cd i18n ; rm -f *~ ; cp -f Sunclock.* $(DESTDIR)$(SHAREDIR)/i18n
+ $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
+ cd vmf ; rm -f *~ ; cp -f * $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
+- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/bin
+- install -c -s editkit/emx $(DESTDIR)$(SHAREDIR)/bin
++ install -c -s editkit/emx $(DESTDIR)/bin
+ $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/editkit
+ cd editkit ; install -c -m 444 rc.example README MANUAL.emacs \
+ $(DESTDIR)$(SHAREDIR)/editkit
diff --git a/astro/sunclock/files/patch-editkit__Imakefile b/astro/sunclock/files/patch-editkit__Imakefile
deleted file mode 100644
index 886288766336..000000000000
--- a/astro/sunclock/files/patch-editkit__Imakefile
+++ /dev/null
@@ -1,45 +0,0 @@
---- editkit/Imakefile.orig Tue Aug 2 00:14:15 2005
-+++ editkit/Imakefile Fri Nov 25 22:47:48 2005
-@@ -1,20 +1,20 @@
- XCOMM Should install to /usr or /usr/local ??
- #ifndef DESTDIR
--DESTDIR=/usr
-+DESTDIR=${PREFIX}
- #endif
-
- XCOMM Name of man subdirectory of DESTDIR:
--MANDIR=/X11R6/man/man1
-+MANDIR=/man/man1
-
- XCOMM Name of bin subdirectory of DESTDIR: /X11R6/bin or maybe just /bin
--BINDIR=/X11R6/bin
-+BINDIR=/bin
-
- XCOMM Name of share subdirectory of DESTDIR_XRMAP:
- SHAREDIR=$(DESTDIR)/share/editkit
-
- XCOMM Name of DOCDIR's subdirectories of DESTDIR:
- DOCDIR=/X11R6/lib/X11/doc
--DOCHTMLDIR=/X11R6/lib/X11/doc/html
-+DOCHTMLDIR=/lib/X11/doc/html
-
- XCOMM
- XCOMM Normally -- except for new architectures -- you should be done there.
-@@ -23,7 +23,7 @@
- XCOMM Compile options:
- XCOMM
-
--CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\""
-+CFLAGS += -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\""
-
- LOCAL_LIBRARIES=$(XLIB)
- DEPLIBS= # I don't know what I'm doing, and I hate imake!
-@@ -38,8 +38,6 @@
- $(CC) $(CFLAGS) -DEMACS -o x11.o -c x11.c
-
- install.man::
-- if [ -r $(DESTDIR)$(MANDIR)/emx.1.gz ] ; \
-- then gzip -f $(DESTDIR)$(MANDIR)/emx.1 ; fi
- if [ -r $(DESTDIR)$(MANDIR)/emx.1x.gz ] ; \
- then gzip -f $(DESTDIR)$(MANDIR)/emx.1x ; fi
-
diff --git a/astro/sunclock/pkg-plist b/astro/sunclock/pkg-plist
index cc68a61ed59e..af584884fdfd 100644
--- a/astro/sunclock/pkg-plist
+++ b/astro/sunclock/pkg-plist
@@ -1,8 +1,12 @@
-bin/sunclock
bin/emx
+bin/sunclock
%%DATADIR%%/Sunclockrc
+%%DATADIR%%/earthmaps/vmf/countries.vmf
%%DATADIR%%/earthmaps/vmf/landwater.vmf
%%DATADIR%%/earthmaps/vmf/timezones.vmf
+%%DATADIR%%/editkit/MANUAL.emacs
+%%DATADIR%%/editkit/README
+%%DATADIR%%/editkit/emxrc
%%DATADIR%%/i18n/Sunclock.de
%%DATADIR%%/i18n/Sunclock.en
%%DATADIR%%/i18n/Sunclock.es
@@ -12,11 +16,8 @@ bin/emx
%%DATADIR%%/i18n/Sunclock.no
%%DATADIR%%/i18n/Sunclock.pl
%%DATADIR%%/i18n/Sunclock.se
-share/editkit/rc.common
-share/editkit/emxrc
-share/editkit/README
-@dirrm %%DATADIR%%/i18n
-@dirrm %%DATADIR%%/earthmaps/vmf
-@dirrm %%DATADIR%%/earthmaps
-@dirrm %%DATADIR%%
-@dirrm share/editkit
+@dirrmtry %%DATADIR%%/i18n
+@dirrmtry %%DATADIR%%/editkit
+@dirrmtry %%DATADIR%%/earthmaps/vmf
+@dirrmtry %%DATADIR%%/earthmaps
+@dirrmtry %%DATADIR%%