aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /astro
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/cfitsio/Makefile2
-rw-r--r--astro/openuniverse/Makefile3
-rw-r--r--astro/roadmap/Makefile3
-rw-r--r--astro/xplanet/Makefile2
4 files changed, 6 insertions, 4 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index a14921a55095..1a08cf6ba5d2 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -23,8 +23,8 @@ OPTIONS_DEFINE= DOCS
ALL_TARGET= libcfitsio.a shared
CFLAGS+= -I${INCLUDEDIR}
+LIBS+= -L${LIBDIR} -lz
CONFIGURE_ARGS= ac_cv_prog_FC=f2c
-CONFIGURE_ENV= LIBS="-L${LIBDIR} -lz"
GNU_CONFIGURE= yes
MAKE_ARGS= ZLIB_SOURCES="zlib/zcompress.c zlib/zuncompress.c"
USE_LDCONFIG= yes
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index 2c60c3b87eba..a56edee8094e 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -21,8 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
-CONFIGURE_ENV= LIBS="-lcompat"
CPPFLAGS+= -I${LOCALBASE}/include/GL -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lm
+LIBS+= -L${LOCALBASE}/lib -lm -lcompat
.include <bsd.port.mk>
diff --git a/astro/roadmap/Makefile b/astro/roadmap/Makefile
index 7415be6b49c0..4adfe6dfc580 100644
--- a/astro/roadmap/Makefile
+++ b/astro/roadmap/Makefile
@@ -52,6 +52,9 @@ post-patch:
s|/usr/include|${LOCALBASE}/include|g ; \
s|/usr/local/include|${LOCALBASE}/include|g ; \
s|/usr/local/lib|${LOCALBASE}/lib|g' ${WRKSRC}/src/options.mk
+ @${ECHO_CMD} 'CFLAGS=${CFLAGS}' > ${WRKSRC}/src/overrides.mk
+ @${ECHO_CMD} 'LDFLAGS=${LDFLAGS}' >> ${WRKSRC}/src/overrides.mk
+ @${ECHO_CMD} 'LIBS=${LIBS}' >> ${WRKSRC}/src/overrides.mk
do-install:
.for _BIN in ${BINS}
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index d9cf1135a763..d231b64cc898 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -14,8 +14,8 @@ GNU_CONFIGURE= yes
USES= iconv
USE_XORG= xt xscrnsaver
CONFIGURE_ARGS= --with-map-extension=jpg
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lm"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lm
OPTIONS_DEFINE= FREETYPE PANGO GIF JPEG PNG PNM TIFF
OPTIONS_DEFAULT= FREETYPE PANGO GIF JPEG PNG PNM TIFF