aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-27 20:39:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-27 20:39:48 +0000
commit359ad2f380bea6b69d2d2f18c7a27bf8db545a9b (patch)
tree5ff6b68c06343182f337a6cc83df2819147b41fe /astro
parent6c667474e3496e2eaaca1e10a165cf16fdb2cb98 (diff)
downloadports-359ad2f380bea6b69d2d2f18c7a27bf8db545a9b.tar.gz
ports-359ad2f380bea6b69d2d2f18c7a27bf8db545a9b.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile56
-rw-r--r--astro/boinc-setiathome-enhanced/distinfo3
-rw-r--r--astro/boinc-setiathome-enhanced/pkg-descr10
-rw-r--r--astro/boinc-setiathome-enhanced/pkg-message14
-rw-r--r--astro/boinc-setiathome-enhanced/pkg-plist4
6 files changed, 88 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 66a9d91f4386..233d3016584a 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -6,6 +6,7 @@
SUBDIR += accrete
SUBDIR += boinc-einsteinathome
SUBDIR += boinc-setiathome
+ SUBDIR += boinc-setiathome-enhanced
SUBDIR += boinc-setiathome-naparst
SUBDIR += celestia
SUBDIR += cfitsio
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
new file mode 100644
index 000000000000..bc30a47399c0
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: boinc-setiathome-enhanced
+# Date created: 26 March 2006
+# Whom: Rene Ladan <r.c.ladan@student.tue.nl>
+# $FreeBSD$
+#
+
+PORTNAME= boinc-setiathome-enhanced
+PORTVERSION= 5.05
+CATEGORIES= astro
+MASTER_SITES= http://www.lb.shuttle.de/apastron/boinc/
+DISTNAME= boinc5.2.14seti${PORTVERSION}freebsd-mmx
+
+MAINTAINER= r.c.ladan@student.tue.nl
+COMMENT= Setiathome Enhanced for BOINC
+
+USE_BZIP2= yes
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386 amd64
+.if ${ARCH} == amd64
+#amd64 builds 5.X compat libs as part of lib32 layer
+#amd64 does not run, unless you libmap libpthread.so.1 to libc_r.so.5
+.else
+.if ${OSVERSION} >= 600000
+LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
+#also depends on libm.so.3, libstdc++.so.4, libpthread.so.1
+.endif
+.endif
+
+RUN_DEPENDS+= boinc_client:${PORTSDIR}/net/boinc-client
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
+BOINC_USER?= boinc
+BOINC_GROUP?= nobody
+BOINC_HOME?= /var/db/boinc
+
+SETI_SITE= setiweb.ssl.berkeley.edu_beta
+SETI_BINARY= setiathome-5.5.i386-unknown-freebsd
+
+PLIST_SUB= SETI_BINARY="${SETI_BINARY}" SETI_SITE=${SETI_SITE} \
+ BOINC_HOME=${BOINC_HOME}
+
+do-install:
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${SETI_SITE}
+ ${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/projects/${SETI_SITE}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/projects/${SETI_SITE}/${SETI_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/astro/boinc-setiathome-enhanced/distinfo b/astro/boinc-setiathome-enhanced/distinfo
new file mode 100644
index 000000000000..11926b2ccc03
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/distinfo
@@ -0,0 +1,3 @@
+MD5 (boinc5.2.14seti5.05freebsd-mmx.tar.bz2) = 29b089e2ed1bb8040208b3f7fe8d63fe
+SHA256 (boinc5.2.14seti5.05freebsd-mmx.tar.bz2) = 35fe25d6b4b9adec3c16cef48ee2a87ee7ff6c7a73dbcc0d5a78dffc0f02ba25
+SIZE (boinc5.2.14seti5.05freebsd-mmx.tar.bz2) = 1331836
diff --git a/astro/boinc-setiathome-enhanced/pkg-descr b/astro/boinc-setiathome-enhanced/pkg-descr
new file mode 100644
index 000000000000..f6787f8ac273
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/pkg-descr
@@ -0,0 +1,10 @@
+SETI - Search for Extra-Terrestrial Intelligence -- Enhanced version
+
+Use your unused CPU cycles to aid in computations analyzing radio
+telescope information for possible signs of ET. The Enhanced version
+is still beta, but this is mainly for administrative reasons.
+
+This version is a FreeBSD binary built by Stefan Urbat for Pentium II
+or AMD K6 CPUs and higher (requires MMX instructions).
+
+WWW: http://www.lb.shuttle.de/apastron/boincDown.shtml#freebsd
diff --git a/astro/boinc-setiathome-enhanced/pkg-message b/astro/boinc-setiathome-enhanced/pkg-message
new file mode 100644
index 000000000000..2fa0bc3304b2
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/pkg-message
@@ -0,0 +1,14 @@
+ATTACHING PROJECT
+
+Just run boinc_gui, choose Attach, and follow instructions.
+Project URL is setiweb.ssl.berkeley.edu/beta
+
+MANUAL INSTALLATION
+ *) If this is your first time in any BOINC project, create a new account at
+ http://setiweb.berkeley.edu/beta/create_account_form.php
+
+ *) Or get your account key at http://setiweb.ssl.berkeley.edu/beta/get_passwd.php
+
+ *) Attach to the project:
+ cd /var/db/boinc
+ boinc_cmd --project_attach setiweb.ssl.berkeley.edu/beta <account key>
diff --git a/astro/boinc-setiathome-enhanced/pkg-plist b/astro/boinc-setiathome-enhanced/pkg-plist
new file mode 100644
index 000000000000..3f8820ca3808
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/pkg-plist
@@ -0,0 +1,4 @@
+@cwd %%BOINC_HOME%%
+projects/%%SETI_SITE%%/app_info.xml
+projects/%%SETI_SITE%%/%%SETI_BINARY%%
+@dirrmtry %D/projects/%%SETI_SITE%% 2>/dev/null