aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-30 13:17:57 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-30 13:17:57 +0000
commit3cd04812896def81cd5bec58050c425504477a14 (patch)
tree331731fbda05fc9a9535d298c810ffe070b5d6b6 /astro
parent663534f3913b2a02f7f1fedc1d0b66191cb01553 (diff)
downloadports-3cd04812896def81cd5bec58050c425504477a14.tar.gz
ports-3cd04812896def81cd5bec58050c425504477a14.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/xephem/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 807d5784f6f4..d975742fdbc8 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -25,7 +25,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/GUI/xephem
MAN1= xephem.1
-RESTRICTED= "Personal use only"
+RESTRICTED= Personal use only
# XXX needs to be the same as DISTFILES
XEPHEMSRC= ${PORTNAME}-${PORTVERSION}.tar.gz
@@ -43,7 +43,9 @@ place it in ${DISTDIR} and then run make again.\n
.endfor
post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ -e 's|/usr/X11R6|${X11BASE}' \
+ ${WRKSRC}/Makefile
@${FIND} ${WRKSRC}/../.. -name Makefile -type f | \
${XARGS} ${REINPLACE_CMD} -e 's|CC =|CC?=|g ; \
s|CFLAGS=|CFLAGS+=|g ; \
@@ -58,7 +60,7 @@ pre-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xephem ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xephem.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/xephem.1 ${MANPREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/XEphem.ad ${PREFIX}/lib/X11/app-defaults/XEphem
@${MKDIR} ${PREFIX}/lib/X11/xephem
${TAR} -C ${WRKSRC} -cf - auxil catalogs fifos fits gallery help lo tools \