aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /astro
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/py-RO/Makefile8
-rw-r--r--astro/py-aipy/Makefile8
-rw-r--r--astro/py-astLib/Makefile10
-rw-r--r--astro/py-horoscopegenerator/Makefile2
-rw-r--r--astro/py-pyfits/Makefile6
-rw-r--r--astro/pyephem/Makefile2
6 files changed, 19 insertions, 17 deletions
diff --git a/astro/py-RO/Makefile b/astro/py-RO/Makefile
index 4c82c8cbc41f..fb7ac2537909 100644
--- a/astro/py-RO/Makefile
+++ b/astro/py-RO/Makefile
@@ -12,7 +12,7 @@ COMMENT= Package of Python astronomical utilities
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:math/py-numpy
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:math/py-numpy@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= MATPLOTLIB PYFITS PYGAME
@@ -25,8 +25,8 @@ PYGAME_DESC= Add Support for PyGame
USES= python
USE_PYTHON= autoplist distutils
-MATPLOTLIB_RUN_DEPENDS= ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib
-PYFITS_RUN_DEPENDS= ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits
-PYGAME_RUN_DEPENDS= ${PKGNAMEPREFIX}game>=1.8.1:devel/py-game
+MATPLOTLIB_RUN_DEPENDS= ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
+PYFITS_RUN_DEPENDS= ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits@${FLAVOR}
+PYGAME_RUN_DEPENDS= ${PKGNAMEPREFIX}game>=1.8.1:devel/py-game@${FLAVOR}
.include <bsd.port.mk>
diff --git a/astro/py-aipy/Makefile b/astro/py-aipy/Makefile
index daae1f981390..40e6e22dec3a 100644
--- a/astro/py-aipy/Makefile
+++ b/astro/py-aipy/Makefile
@@ -11,12 +11,12 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= Astronomical Interferometry in PYthon
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_SITELIBDIR}/ephem/__init__.py:astro/pyephem \
- ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits \
- ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib
+ ${PYTHON_SITELIBDIR}/ephem/__init__.py:astro/pyephem@${FLAVOR} \
+ ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits@${FLAVOR} \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= python
+USES= python:2.7
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
index ff33bdd0602b..beaaed8dd727 100644
--- a/astro/py-astLib/Makefile
+++ b/astro/py-astLib/Makefile
@@ -14,15 +14,15 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
- ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy \
- ${PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
- ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits \
- ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib
+ ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${FLAVOR} \
+ ${PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR} \
+ ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits@${FLAVOR} \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
-USES= python
+USES= python:2.7
USE_PYTHON= autoplist distutils
post-install:
diff --git a/astro/py-horoscopegenerator/Makefile b/astro/py-horoscopegenerator/Makefile
index 3c53386e1043..55acd4ee023e 100644
--- a/astro/py-horoscopegenerator/Makefile
+++ b/astro/py-horoscopegenerator/Makefile
@@ -16,6 +16,6 @@ NO_ARCH= yes
USES= python
USE_PYTHON= distutils autoplist
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nltk>0:textproc/py-nltk
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nltk>0:textproc/py-nltk@${FLAVOR}
.include <bsd.port.mk>
diff --git a/astro/py-pyfits/Makefile b/astro/py-pyfits/Makefile
index c8c966b5d7ce..26d266559510 100644
--- a/astro/py-pyfits/Makefile
+++ b/astro/py-pyfits/Makefile
@@ -14,10 +14,10 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}d2to1>=0:devel/py-d2to1 \
- ${PYTHON_PKGNAMEPREFIX}stsci.distutils>=0:devel/py-stsci.distutils
+ ${PYTHON_PKGNAMEPREFIX}d2to1>=0:devel/py-d2to1@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}stsci.distutils>=0:devel/py-stsci.distutils@${FLAVOR}
RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}d2to1>=0:devel/py-d2to1
+ ${PYTHON_PKGNAMEPREFIX}d2to1>=0:devel/py-d2to1@${FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
diff --git a/astro/pyephem/Makefile b/astro/pyephem/Makefile
index 9ce70f1ce819..0cb676e9fec9 100644
--- a/astro/pyephem/Makefile
+++ b/astro/pyephem/Makefile
@@ -6,6 +6,8 @@ PORTVERSION= 3.7.6.0
PORTEPOCH= 1
CATEGORIES= astro math hamradio
MASTER_SITES= CHEESESHOP
+# XXX rename the directory too.
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Scientific-grade astronomical computations for Python