aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-07 15:37:15 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-07 15:37:15 +0000
commit9650053021d53eca2f290cfda817a02a57597c91 (patch)
tree7b76d133b6aed2608c7ec527ccc156fab6dc2c1b /astro
parente64af2885167f341327e4d12dd3f183361a254ae (diff)
downloadports-9650053021d53eca2f290cfda817a02a57597c91.tar.gz
ports-9650053021d53eca2f290cfda817a02a57597c91.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/celestia/Makefile4
-rw-r--r--astro/gpsd/Makefile3
-rw-r--r--astro/openuniverse/Makefile3
-rw-r--r--astro/viking/Makefile4
-rw-r--r--astro/xglobe/Makefile2
-rw-r--r--astro/xglobe/files/patch-Makefile2
6 files changed, 7 insertions, 11 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 414eef1fc591..4fc6b0d632bb 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -24,8 +24,8 @@ USE_LUA= 5.0+ # should be optional, but the build fails without it
WANT_GNOME= yes
CXXFLAGS+= -fsigned-char # fix text rendering (see Gentoo bug 316573)
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
UI_LIST= glut gtk gnome kde
CELESTIA_UI?= glut
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index c8ab8971cb3b..42c4e8dbfc38 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -273,9 +273,6 @@ PLIST_SUB+= CURSES=""
SCONS_ARGS+= profiling=yes
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Qgpsmm.pc.in
-
# generates .py[co] files for installed modules
# if that's not done, ${PYTHON_SITELIBDIR}/gps will be polluted
# with these files when module is imported from root user
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index 399b73e208c7..a77c548933ad 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -25,9 +25,8 @@ USE_GMAKE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
-CONFIGURE_ENV= LIBS="-lcompat" PTHREAD_LIBS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-lcompat"
CPPFLAGS+= -I${LOCALBASE}/include/GL -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lm
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.mk>
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 006c91d21349..f2d232d6ca9e 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -34,8 +34,8 @@ INSTALLS_ICONS= yes
INSTALLS_OMF= yes
MAKE_JOBS_SAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
diff --git a/astro/xglobe/Makefile b/astro/xglobe/Makefile
index 51b4ed09fde2..9fd4df41b322 100644
--- a/astro/xglobe/Makefile
+++ b/astro/xglobe/Makefile
@@ -17,7 +17,7 @@ COMMENT= Displays a view of the Earth (like xearth) with a rendered photo map
USE_QT4= corelib gui qt3support moc_build
USE_GMAKE= yes
-MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} QT_PREFIX=${QT_PREFIX}
+MAKE_ENV= QT_PREFIX=${QT_PREFIX}
do-install:
@${MKDIR} ${DATADIR}
diff --git a/astro/xglobe/files/patch-Makefile b/astro/xglobe/files/patch-Makefile
index b3bca761963c..dd9ce83093a8 100644
--- a/astro/xglobe/files/patch-Makefile
+++ b/astro/xglobe/files/patch-Makefile
@@ -47,7 +47,7 @@
LIB_DIRS = -L$(QT_LIB_DIR) -L$(X11_LIB_DIR)
-LIBS = -lX11 -lqt -lm
-+LIBS = -lX11 -lQt3Support -lQtGui -lm ${PTHREAD_LIBS}
++LIBS = -lX11 -lQt3Support -lQtGui -lm -pthread
# If you want to use the QImageIO lib (to support jpg and png maps) use the
# next two lines and comment the one above
#WITH_QIMGIO = -DWITH_QIMAGEIO