aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2010-07-14 03:53:57 +0000
committerKevin Lo <kevlo@FreeBSD.org>2010-07-14 03:53:57 +0000
commit303cbef057df3f461ead2bb30e6ea8cbbdac6d8f (patch)
tree36355a85556b49ebe055c0948633ef27e38f15db /astro
parentff7186bb14928125c126c355b11bc513dae2850a (diff)
downloadports-303cbef057df3f461ead2bb30e6ea8cbbdac6d8f.tar.gz
ports-303cbef057df3f461ead2bb30e6ea8cbbdac6d8f.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/gmapcatcher/Makefile9
-rw-r--r--astro/gmapcatcher/distinfo6
-rw-r--r--astro/gmapcatcher/files/patch-download.py11
-rw-r--r--astro/gmapcatcher/files/patch-src_mapArgs.py4
-rw-r--r--astro/gmapcatcher/pkg-plist9
5 files changed, 22 insertions, 17 deletions
diff --git a/astro/gmapcatcher/Makefile b/astro/gmapcatcher/Makefile
index 5e22ee913644..caa30e2eef90 100644
--- a/astro/gmapcatcher/Makefile
+++ b/astro/gmapcatcher/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gmapcatcher
-PORTVERSION= 0.7.0.0
+PORTVERSION= 0.7.1.0
CATEGORIES= astro geography
MASTER_SITES= http://gmapcatcher.googlecode.com/files/
DISTNAME= GMapCatcher-${PORTVERSION}
@@ -22,6 +22,12 @@ USE_GNOME= pygtk2
WRKSRC= ${WRKDIR}/${DISTNAME}
+DOWNLOAD_PY= ${WRKSRC}/download.py
+
+pre-patch:
+ @${TR} -d '\r' < ${DOWNLOAD_PY} > ${DOWNLOAD_PY}.tmp
+ @${MV} -f ${DOWNLOAD_PY}.tmp ${DOWNLOAD_PY}
+
post-patch:
@${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} {} \;
@@ -33,6 +39,7 @@ do-install:
@${MKDIR} ${PYTHON_SITELIBDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/*.py* ${PYTHON_SITELIBDIR}/${PORTNAME}
@${CP} -R ${WRKSRC}/src ${PYTHON_SITELIBDIR}/${PORTNAME}
+ @${CP} -R ${WRKSRC}/images ${PYTHON_SITELIBDIR}/${PORTNAME}
${CHMOD} +x ${PYTHON_SITELIBDIR}/${PORTNAME}/maps.py
${CHMOD} +x ${PYTHON_SITELIBDIR}/${PORTNAME}/download.py
${LN} -fs ${PYTHON_SITELIBDIR}/${PORTNAME}/maps.py \
diff --git a/astro/gmapcatcher/distinfo b/astro/gmapcatcher/distinfo
index 1cd4c6b6851e..646c4ef07301 100644
--- a/astro/gmapcatcher/distinfo
+++ b/astro/gmapcatcher/distinfo
@@ -1,3 +1,3 @@
-MD5 (GMapCatcher-0.7.0.0.tar.gz) = fafceab96905924136a1136f89f2b17a
-SHA256 (GMapCatcher-0.7.0.0.tar.gz) = f0bc0c7a68192cee64d7e53d69e3cf5d6f579b7b9b6078ed95c1a9ed6cbefe1e
-SIZE (GMapCatcher-0.7.0.0.tar.gz) = 296807
+MD5 (GMapCatcher-0.7.1.0.tar.gz) = cc6e24c92fbea14dca73c27db88f4355
+SHA256 (GMapCatcher-0.7.1.0.tar.gz) = daacf0edcce085c5c428c6bb5ed7f1c321dde8b48cf8cad6ccedb5431b148e20
+SIZE (GMapCatcher-0.7.1.0.tar.gz) = 671251
diff --git a/astro/gmapcatcher/files/patch-download.py b/astro/gmapcatcher/files/patch-download.py
deleted file mode 100644
index 7cdccd4c7bbd..000000000000
--- a/astro/gmapcatcher/files/patch-download.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- download.py.orig 2010-04-20 10:40:10.000000000 +0800
-+++ download.py 2010-04-20 10:40:21.000000000 +0800
-@@ -12,7 +12,7 @@
- from src.mapDownloader import MapDownloader
-
- mConf = mapConf.MapConf()
--ctx_map = MapServ(conf.init_path, conf.repository_type)
-+ctx_map = MapServ(mConf.init_path, mConf.repository_type)
- downloader = None
-
- def do_nothing(*args, **kwargs):
diff --git a/astro/gmapcatcher/files/patch-src_mapArgs.py b/astro/gmapcatcher/files/patch-src_mapArgs.py
index 264edc9bd95c..88176dd5b291 100644
--- a/astro/gmapcatcher/files/patch-src_mapArgs.py
+++ b/astro/gmapcatcher/files/patch-src_mapArgs.py
@@ -1,5 +1,5 @@
---- src/mapArgs.py.orig 2010-04-20 10:41:04.000000000 +0800
-+++ src/mapArgs.py 2010-04-20 10:42:13.000000000 +0800
+--- src/mapArgs.py.orig 2010-07-14 10:53:32.000000000 +0800
++++ src/mapArgs.py 2010-07-14 10:54:03.000000000 +0800
@@ -38,9 +38,9 @@
print ' very useful to download maps of entire world'
print ' '
diff --git a/astro/gmapcatcher/pkg-plist b/astro/gmapcatcher/pkg-plist
index 3d630dad73ef..17fa4e4d607b 100644
--- a/astro/gmapcatcher/pkg-plist
+++ b/astro/gmapcatcher/pkg-plist
@@ -6,6 +6,14 @@ bin/gmapcatcher-download
%%PYTHON_SITELIBDIR%%/gmapcatcher/maps.py
%%PYTHON_SITELIBDIR%%/gmapcatcher/maps.pyc
%%PYTHON_SITELIBDIR%%/gmapcatcher/maps.pyo
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/cross.png
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/map.svg
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/maps.ico
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/marker.png
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/marker1.png
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/marker_gps.png
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/missing.png
+%%PYTHON_SITELIBDIR%%/gmapcatcher/images/setup.bmp
%%PYTHON_SITELIBDIR%%/gmapcatcher/src/DLWindow.py
%%PYTHON_SITELIBDIR%%/gmapcatcher/src/DLWindow.pyc
%%PYTHON_SITELIBDIR%%/gmapcatcher/src/DLWindow.pyo
@@ -228,4 +236,5 @@ bin/gmapcatcher-download
@dirrm %%PYTHON_SITELIBDIR%%/gmapcatcher/src/pyGPSD
@dirrm %%PYTHON_SITELIBDIR%%/gmapcatcher/src/mapServers
@dirrm %%PYTHON_SITELIBDIR%%/gmapcatcher/src
+@dirrm %%PYTHON_SITELIBDIR%%/gmapcatcher/images
@dirrm %%PYTHON_SITELIBDIR%%/gmapcatcher