aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-11 22:34:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-11 22:34:29 +0000
commit6c3c68ffeae5df4de07df69da8a4478f505f6268 (patch)
treea8a394e11ef0dc4acea7bab9cce1b09fe83db444 /astro
parente12ff08721b15ee5e3fad45fa8fed6ffd23d6059 (diff)
downloadports-6c3c68ffeae5df4de07df69da8a4478f505f6268.tar.gz
ports-6c3c68ffeae5df4de07df69da8a4478f505f6268.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Astro-satpass/Makefile34
-rw-r--r--astro/p5-Astro-satpass/distinfo3
-rw-r--r--astro/p5-Astro-satpass/pkg-descr5
-rw-r--r--astro/p5-Astro-satpass/pkg-plist19
5 files changed, 62 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index b391b47be8ec..a577f5c70224 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -49,6 +49,7 @@
SUBDIR += p5-Astro-SpaceTrack
SUBDIR += p5-Astro-SunTime
SUBDIR += p5-Astro-Sunrise
+ SUBDIR += p5-Astro-satpass
SUBDIR += p5-GPS
SUBDIR += p5-Geo-METAR
SUBDIR += p5-Weather-Underground
diff --git a/astro/p5-Astro-satpass/Makefile b/astro/p5-Astro-satpass/Makefile
new file mode 100644
index 000000000000..883cad0b37f7
--- /dev/null
+++ b/astro/p5-Astro-satpass/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: Astro-satpass
+# Date created: 11 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-satpass
+PORTVERSION= 0.023
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Classes and app to compute satellite visibility
+
+RUN_DEPENDS= p5-Date-Manip>=1.14:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-Params-Util>=0.25:${PORTSDIR}/devel/p5-Params-Util
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= -y
+
+MAN1= satpass.1
+MAN3= Astro::Coord::ECI::Utils.3 \
+ Astro::Coord::ECI::TLE::Iridium.3 \
+ Astro::Coord::ECI::TLE::Set.3 \
+ Astro::Coord::ECI::TLE.3 \
+ Astro::Coord::ECI::Star.3 \
+ Astro::Coord::ECI::Overview.3 \
+ Astro::Coord::ECI::Moon.3 \
+ Astro::Coord::ECI::Sun.3 \
+ Astro::Coord::ECI.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-satpass/distinfo b/astro/p5-Astro-satpass/distinfo
new file mode 100644
index 000000000000..c90a9016e4b4
--- /dev/null
+++ b/astro/p5-Astro-satpass/distinfo
@@ -0,0 +1,3 @@
+MD5 (Astro-satpass-0.023.tar.gz) = 714e9a6f237ed6e44301a741567214bf
+SHA256 (Astro-satpass-0.023.tar.gz) = 1d06d8a17272d6b04cabe3d9eb74c4081406843ea57b030be8caadacf4822d33
+SIZE (Astro-satpass-0.023.tar.gz) = 268780
diff --git a/astro/p5-Astro-satpass/pkg-descr b/astro/p5-Astro-satpass/pkg-descr
new file mode 100644
index 000000000000..0c07c63f8d8a
--- /dev/null
+++ b/astro/p5-Astro-satpass/pkg-descr
@@ -0,0 +1,5 @@
+Astro-satpass contains classes needed to predict satellite
+visibility, and a demonstration application (satpass) that
+makes use of these classes.
+
+WWW: http://search.cpan.org/dist/Astro-satpass/
diff --git a/astro/p5-Astro-satpass/pkg-plist b/astro/p5-Astro-satpass/pkg-plist
new file mode 100644
index 000000000000..460bc8220e0e
--- /dev/null
+++ b/astro/p5-Astro-satpass/pkg-plist
@@ -0,0 +1,19 @@
+bin/satpass
+%%SITE_PERL%%/Astro/Coord/ECI.pm
+%%SITE_PERL%%/Astro/Coord/ECI/Utils.pm
+%%SITE_PERL%%/Astro/Coord/ECI/TLE.pm
+%%SITE_PERL%%/Astro/Coord/ECI/Overview.pod
+%%SITE_PERL%%/Astro/Coord/ECI/Star.pm
+%%SITE_PERL%%/Astro/Coord/ECI/Moon.pm
+%%SITE_PERL%%/Astro/Coord/ECI/Sun.pm
+%%SITE_PERL%%/Astro/Coord/ECI/TLE/Iridium.pm
+%%SITE_PERL%%/Astro/Coord/ECI/TLE/Set.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Coord/ECI/.packlist
+@dirrm %%SITE_PERL%%/Astro/Coord/ECI/TLE
+@dirrm %%SITE_PERL%%/Astro/Coord/ECI
+@dirrm %%SITE_PERL%%/Astro/Coord
+@dirrmtry %%SITE_PERL%%/Astro
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Coord/ECI
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Coord
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro
+@dirrmtry %%SITE_PERL%%/Astro