aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-07-13 10:58:21 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-07-13 10:58:21 +0000
commit7758efbcb285bb5c54405a9f7008fd2364c836ec (patch)
tree37d78d3c853025d91be0cdabbdf16d1e8c6dab9b /astro
parent971e5c9d899de5fc7580d4a69a124d93cbebea72 (diff)
downloadports-7758efbcb285bb5c54405a9f7008fd2364c836ec.tar.gz
ports-7758efbcb285bb5c54405a9f7008fd2364c836ec.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/seti_applet/Makefile21
-rw-r--r--astro/seti_applet/distinfo2
-rw-r--r--astro/seti_applet/files/patch-aa8
-rw-r--r--astro/seti_applet/files/patch-ac13
-rw-r--r--astro/seti_applet/pkg-comment2
-rw-r--r--astro/seti_applet/pkg-descr4
-rw-r--r--astro/seti_applet/pkg-message8
-rw-r--r--astro/seti_applet/pkg-plist12
8 files changed, 42 insertions, 28 deletions
diff --git a/astro/seti_applet/Makefile b/astro/seti_applet/Makefile
index 779b53bd3de7..de0735e999eb 100644
--- a/astro/seti_applet/Makefile
+++ b/astro/seti_applet/Makefile
@@ -6,26 +6,31 @@
#
PORTNAME= seti_applet
-PORTVERSION= 0.2.2
+PORTVERSION= 0.3.0
CATEGORIES= astro gnome
-MASTER_SITES= http://download.sourceforge.net/seti-applet/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
MAINTAINER= th@cis.ibaraki.ac.jp
LIB_DEPENDS= panel_applet.4:${PORTSDIR}/x11/gnomecore \
- gnome.4:${PORTSDIR}/x11/gnomelibs
-RUN_DEPENDS= setiathome:${PORTSDIR}/astro/setiathome
+ gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gtop.1:${PORTSDIR}/devel/libgtop
+RUN_DEPENDS= setiathome:${PORTSDIR}/astro/setiathome \
+ gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
USE_X_PREFIX= yes
+
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-GNU_CONFIGURE= yes
-
+USE_LIBTOOL= yes
CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}"
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
post-install:
- ${CAT} ${PKGMESSAGE}
+ ${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/astro/seti_applet/distinfo b/astro/seti_applet/distinfo
index a4f6b366581c..1f6ac153d96f 100644
--- a/astro/seti_applet/distinfo
+++ b/astro/seti_applet/distinfo
@@ -1 +1 @@
-MD5 (seti_applet-0.2.2.tar.gz) = abb117d1737556eaa00b5eb1f7eda1da
+MD5 (seti_applet-0.3.0.tar.gz) = 2802618a2b37a8b1540c16b0aa0dfbbf
diff --git a/astro/seti_applet/files/patch-aa b/astro/seti_applet/files/patch-aa
index 765bec012659..3f3063bc0f23 100644
--- a/astro/seti_applet/files/patch-aa
+++ b/astro/seti_applet/files/patch-aa
@@ -1,11 +1,11 @@
---- src/seti_applet.c.orig Fri Jun 30 20:00:34 2000
-+++ src/seti_applet.c Fri Jun 30 20:00:45 2000
-@@ -705,7 +705,7 @@
+--- src/seti_applet.c.orig Sat Jul 1 12:48:49 2000
++++ src/seti_applet.c Fri Jul 7 19:40:57 2000
+@@ -1352,7 +1352,7 @@
g_free ( sa.setidir );
}
gnome_config_push_prefix ( path );
- sa.setidir = gnome_config_get_string ( "setiapplet/setidir=/usr/local/seti" );
+ sa.setidir = gnome_config_get_string ( "setiapplet/setidir=/var/db/setiathome" );
- sa.updateinterval = gnome_config_get_int ( "setiapplet/updateinterval=10" );
+ sa.updateinterval = gnome_config_get_int ( "setiapplet/updateinterval=3" );
sa.fileupdateinterval = gnome_config_get_int ( "setiapplet/fileupdateinterval=120" );
sa.showcpu = gnome_config_get_int ( "setiapplet/showcpu=1" );
diff --git a/astro/seti_applet/files/patch-ac b/astro/seti_applet/files/patch-ac
new file mode 100644
index 000000000000..35f25c84f6da
--- /dev/null
+++ b/astro/seti_applet/files/patch-ac
@@ -0,0 +1,13 @@
+--- configure.orig Fri May 12 15:55:34 2000
++++ configure Thu Jul 13 13:35:47 2000
+@@ -4538,8 +4538,8 @@
+ < $srcdir/po/POTFILES.in > po/POTFILES
+
+
+-CFLAGS=`$CFLAGS $GNOME_CONFIG --cflags gnome gtk glib applets`
+-LDFLAGS=`$LDFLAGS $GNOME_CONFIG --libs gnome gtk glib applets`
++CFLAGS="$CFLAGS `$GNOME_CONFIG --cflags gnome gtk glib applets`"
++LDFLAGS="$LDFLAGS `$GNOME_CONFIG --libs gnome gtk glib applets`"
+
+
+
diff --git a/astro/seti_applet/pkg-comment b/astro/seti_applet/pkg-comment
index efe2613306ec..198eeeb61ad0 100644
--- a/astro/seti_applet/pkg-comment
+++ b/astro/seti_applet/pkg-comment
@@ -1 +1 @@
-An applet that displays the current status of a seti@home client
+An applet that displays current status of seti@home client
diff --git a/astro/seti_applet/pkg-descr b/astro/seti_applet/pkg-descr
index 821403a7c5ea..9096b9d15711 100644
--- a/astro/seti_applet/pkg-descr
+++ b/astro/seti_applet/pkg-descr
@@ -1,4 +1,4 @@
-Displays in an applet (in text in this release) the current status of
-any running seti@home client.
+Displays in an applet the current status of
+any seti@home client running.
WWW: http://seti-applet.sourceforge.net/
diff --git a/astro/seti_applet/pkg-message b/astro/seti_applet/pkg-message
index 0e67633f694a..b51dca12b132 100644
--- a/astro/seti_applet/pkg-message
+++ b/astro/seti_applet/pkg-message
@@ -1,14 +1,10 @@
- seti@home client must be installed.
- You can find it in /usr/ports/astro/setiathome
-
To enable start/stop seti@home client,
please run "setiathome" as your login name.
If you installed "setiathome" by ports or package,
- change the line 9 of /usr/local/etc/rc.d/setiathome.sh
+ change the line 9 of %%LOCALBASE%%/etc/rc.d/setiathome.sh
seti_user=nobody
^^^^^^
to your login name before setting up working directory.
If you already done this as nobody, do
- /usr/local/etc/rc.d/setiathome.sh stop
+ %%LOCALBASE%%/etc/rc.d/setiathome.sh stop
chown -R "YOUR LOGIN NAME" /var/db/setiathome
-
diff --git a/astro/seti_applet/pkg-plist b/astro/seti_applet/pkg-plist
index a95a78c43d76..df5d05e068c5 100644
--- a/astro/seti_applet/pkg-plist
+++ b/astro/seti_applet/pkg-plist
@@ -1,16 +1,16 @@
bin/seti_applet
etc/CORBA/servers/seti_applet.gnorba
+share/gnome/pixmaps/seti_applet-logo-green.png
share/gnome/applets/Monitors/seti_applet.desktop
-share/gnome/help/seti_applet/C/configuration.html
-share/gnome/help/seti_applet/C/docbook.css
-share/gnome/help/seti_applet/C/images/adv_prop.gif
-share/gnome/help/seti_applet/C/images/basic_prop.gif
share/gnome/help/seti_applet/C/index.html
+share/gnome/help/seti_applet/C/topic.dat
+share/gnome/help/seti_applet/C/configuration.html
share/gnome/help/seti_applet/C/operation.html
share/gnome/help/seti_applet/C/startingsetiprocess.html
-share/gnome/help/seti_applet/C/topic.dat
share/gnome/help/seti_applet/C/x42.html
-share/gnome/pixmaps/seti_applet-logo-green.png
+share/gnome/help/seti_applet/C/docbook.css
+share/gnome/help/seti_applet/C/images/adv_prop.gif
+share/gnome/help/seti_applet/C/images/basic_prop.gif
@dirrm share/gnome/help/seti_applet/C/images
@dirrm share/gnome/help/seti_applet/C
@dirrm share/gnome/help/seti_applet