aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-17 09:05:39 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-17 09:05:39 +0000
commit9345a3bcf3b5ec825026dd4e5b836266e37c6409 (patch)
treea9b889da704f3cf11fc610223c3b80fe1f7d2699 /astro
parent7b419d28a098b164b8c012a828a99a7d79c0bea5 (diff)
downloadports-9345a3bcf3b5ec825026dd4e5b836266e37c6409.tar.gz
ports-9345a3bcf3b5ec825026dd4e5b836266e37c6409.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Weather-Underground/Makefile32
-rw-r--r--astro/p5-Weather-Underground/distinfo3
-rw-r--r--astro/p5-Weather-Underground/pkg-descr6
-rw-r--r--astro/p5-Weather-Underground/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 9be6917de840..941f162520d0 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -43,6 +43,7 @@
SUBDIR += p5-Astro-Sunrise
SUBDIR += p5-GPS
SUBDIR += p5-Geo-METAR
+ SUBDIR += p5-Weather-Underground
SUBDIR += phoon
SUBDIR += planets
SUBDIR += pp3
diff --git a/astro/p5-Weather-Underground/Makefile b/astro/p5-Weather-Underground/Makefile
new file mode 100644
index 000000000000..380a6b80a24e
--- /dev/null
+++ b/astro/p5-Weather-Underground/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Weather-Underground
+# Date created: 2006-05-16
+# Whom: Simon Olofsson <simon@olofsson.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Weather-Underground
+PORTVERSION= 3.02
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Weather
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Retrieve weather information from wunderground.com
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Weather::Underground.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/astro/p5-Weather-Underground/distinfo b/astro/p5-Weather-Underground/distinfo
new file mode 100644
index 000000000000..6c78ab0e4a74
--- /dev/null
+++ b/astro/p5-Weather-Underground/distinfo
@@ -0,0 +1,3 @@
+MD5 (Weather-Underground-3.02.tar.gz) = e62f2b51de150352ba40fe0dfa7ddb58
+SHA256 (Weather-Underground-3.02.tar.gz) = 16fb1cb0b3eb4792452eac13fcafb84199e5f06bd861e653cb89e72506c1403a
+SIZE (Weather-Underground-3.02.tar.gz) = 9003
diff --git a/astro/p5-Weather-Underground/pkg-descr b/astro/p5-Weather-Underground/pkg-descr
new file mode 100644
index 000000000000..6a66e56d7c71
--- /dev/null
+++ b/astro/p5-Weather-Underground/pkg-descr
@@ -0,0 +1,6 @@
+Weather::Underground is a perl module which provides a simple OO interface to
+retrieving weather data for a geographic location. It does so by querying
+wunderground.com and parsing the returned results.
+
+Author: Mina Naguib <mina.cpan@naguib.ca>
+WWW: http://search.cpan.org/dist/Weather-Underground/
diff --git a/astro/p5-Weather-Underground/pkg-plist b/astro/p5-Weather-Underground/pkg-plist
new file mode 100644
index 000000000000..35f16129b44a
--- /dev/null
+++ b/astro/p5-Weather-Underground/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Weather/Underground/.packlist
+%%SITE_PERL%%/Weather/Underground.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Weather/Underground
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Weather
+@dirrmtry %%SITE_PERL%%/Weather