aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 14:18:02 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 14:18:02 +0000
commitd65c037b00c46aa7b10d1803dee20b9bbb57e36b (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /astro
parent051464267aa4627179b870274906053785cee748 (diff)
downloadports-d65c037b00c46aa7b10d1803dee20b9bbb57e36b.tar.gz
ports-d65c037b00c46aa7b10d1803dee20b9bbb57e36b.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/kstars/Makefile2
-rw-r--r--astro/marble/Makefile3
2 files changed, 3 insertions, 2 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 73651ce98e2a..16fe33c75725 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= xplanet:${PORTSDIR}/astro/xplanet
CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 077619f582a0..bc441595638b 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -13,12 +13,13 @@ COMMENT= Virtual globe and world atlas for KDE
CONFLICTS= kdeedu-4.4.[0-4]
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus declarative gui network \
phonon script sql svg webkit xml \
qmake_build moc_build rcc_build uic_build
USE_XZ= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
CMAKE_ARGS= -DMOBILE:BOOL=FALSE