aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2010-05-12 19:04:03 +0000
committerJuergen Lock <nox@FreeBSD.org>2010-05-12 19:04:03 +0000
commite7a8230d7acc2b3efed92547f8f179c5a19ac786 (patch)
tree61c60cc9704ea2834d4518f8082b72afe7c52a2c /astro
parent01343e96c902984c53f6ca8c7a445a36934fe1aa (diff)
downloadports-e7a8230d7acc2b3efed92547f8f179c5a19ac786.tar.gz
ports-e7a8230d7acc2b3efed92547f8f179c5a19ac786.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/google-earth/Makefile2
-rw-r--r--astro/google-earth/files/patch-stacksize4
2 files changed, 3 insertions, 3 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 66a395850ce0..62c8355201ed 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -53,7 +53,7 @@ do-extract:
@cd ${WRKSRC} && ${TAR} xf googleearth-data.tar && ${RM} -f googleearth-data.tar
@cd ${WRKSRC} && ${TAR} xf googleearth-linux-x86.tar && ${RM} -f googleearth-linux-x86.tar
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f \$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh
diff --git a/astro/google-earth/files/patch-stacksize b/astro/google-earth/files/patch-stacksize
index 1927d545a67e..f30765e88d9c 100644
--- a/astro/google-earth/files/patch-stacksize
+++ b/astro/google-earth/files/patch-stacksize
@@ -1,10 +1,10 @@
Index: bin/googleearth
-@@ -34,6 +34,8 @@
+@@ -34,6 +34,8 @@ FindPath()
dirname $fullpath
}
+ulimit -s 32768 2>/dev/null
+
- GOOGLEEARTH_DATA_PATH=/usr/local/share/google-earth
+ # Set the home if not already set.
if [ "${GOOGLEEARTH_DATA_PATH}" = "" ]; then
GOOGLEEARTH_DATA_PATH="`FindPath $0`"