aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2021-11-04 09:43:11 +0000
committerLarry Rosenman <ler@FreeBSD.org>2021-11-04 09:43:11 +0000
commit116e9eeed21ff88be08d200d5630cc7d9e86b758 (patch)
tree3935d0274325514c75b9a3724c76292cd4cc1179 /astro
parent0cb46dbe44ebfd4e3d228394c60f40c8ad194c60 (diff)
downloadports-116e9eeed21ff88be08d200d5630cc7d9e86b758.tar.gz
ports-116e9eeed21ff88be08d200d5630cc7d9e86b758.zip
astro/boinc-astropulse: removed due to astro/boinc-setiathome removal
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile3
-rw-r--r--astro/boinc-astropulse/Makefile80
-rw-r--r--astro/boinc-astropulse/distinfo2
-rw-r--r--astro/boinc-astropulse/files/patch-Makefile.am11
-rw-r--r--astro/boinc-astropulse/files/patch-ap__client__main.cpp21
-rw-r--r--astro/boinc-astropulse/files/patch-ap__fileio.cpp10
-rw-r--r--astro/boinc-astropulse/files/patch-ap__fold.cpp10
-rw-r--r--astro/boinc-astropulse/files/patch-ap__remove__radar.cpp8
-rw-r--r--astro/boinc-astropulse/files/patch-configure.ac41
-rw-r--r--astro/boinc-astropulse/files/patch-m4_sah__check__boinc.m411
-rw-r--r--astro/boinc-astropulse/files/pkg-deinstall.in24
-rw-r--r--astro/boinc-astropulse/files/pkg-install.in37
-rw-r--r--astro/boinc-astropulse/files/pkg-message.in20
-rw-r--r--astro/boinc-astropulse/pkg-descr10
-rw-r--r--astro/boinc-astropulse/pkg-plist9
15 files changed, 1 insertions, 296 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 3b09a026fd3a..226efe3a164b 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -1,9 +1,8 @@
- COMMENT = Astronomical ports
+ MakefCOMMENT = Astronomical ports
SUBDIR += R-cran-maptools
SUBDIR += accrete
SUBDIR += astrometry
- SUBDIR += boinc-astropulse
SUBDIR += celestia
SUBDIR += celestia-gtk
SUBDIR += cfitsio
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
deleted file mode 100644
index 679643ae7dd8..000000000000
--- a/astro/boinc-astropulse/Makefile
+++ /dev/null
@@ -1,80 +0,0 @@
-# Created by: rene
-
-PORTNAME= boinc-astropulse
-PORTVERSION= 6.01
-PORTREVISION= 14
-CATEGORIES= astro
-MASTER_SITES= LOCAL/rene
-DISTNAME= astropulse-svn-1702 # modified archive, see leftout in top directory
-
-MAINTAINER= ler@FreeBSD.org
-COMMENT= Astropulse for BOINC
-
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BROKEN_armv6= fails to compile: call to abs is ambiguous
-
-BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3 \
- ${NONEXISTENT}:astro/boinc-setiathome:configure
-RUN_DEPENDS= boinc_client:net/boinc-client
-LIB_DEPENDS= libfftw3f.so:math/fftw3-float
-
-USES= autoreconf compiler:c++11-lang gmake libtool pkgconfig tar:xz
-
-GNU_CONFIGURE= yes
-
-WRKSRC_SUBDIR= client
-
-CPPFLAGS+= -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lexecinfo
-
-# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
-BOINC_CLIENT_USER?= boinc
-BOINC_CLIENT_GROUP?= boinc
-BOINC_CLIENT_HOME?= /var/db/boinc
-
-SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome && ${MAKE} -V WRKSRC
-CONFIGURE_ENV= BOINCDIR="${NONEXISTENT}" \
- BOINC_DIR="${NONEXISTENT}" \
- SETI_BOINC_DIR="${SETI_WORK}"
-CONFIGURE_ARGS= --disable-static-client \
- --with-boinc-platform=${ARCH}-portbld-freebsd
-
-SETI_SITE= setiathome.berkeley.edu
-AP_BINARY= astropulse-${PORTVERSION:S/.0/./}.${ARCH}-portbld-freebsd
-
-SUB_FILES= pkg-deinstall pkg-install pkg-message
-SUB_LIST= AP_BINARY=${AP_BINARY} \
- AP_VERSION=${PORTVERSION:S/.//} \
- SETI_SITE=${SETI_SITE} \
- BOINC_CLIENT_HOME=${BOINC_CLIENT_HOME} \
- BOINC_CLIENT_USER=${BOINC_CLIENT_USER} \
- BOINC_CLIENT_GROUP=${BOINC_CLIENT_GROUP}
-PLIST_SUB= AP_BINARY=${AP_BINARY} \
- SETI_SITE=${SETI_SITE} \
- BOINC_CLIENT_HOME=${BOINC_CLIENT_HOME} \
- BOINC_CLIENT_USER=${BOINC_CLIENT_USER} \
- BOINC_CLIENT_GROUP=${BOINC_CLIENT_GROUP}
-
-OPTIONS_DEFINE= X11
-OPTIONS_SUB= yes
-
-X11_DESC= Build screensaver (requires net/boinc-client with X11)
-X11_BUILD_DEPENDS= ${LOCALBASE}/lib/libboinc_graphics2.a:net/boinc-client
-X11_USES= gl jpeg xorg
-X11_USE= GL=gl,glu,glut \
- XORG=ice,sm,x11,xau,xcb,xext,xi,xdamage,xdmcp,xfixes,xmu,xt,xxf86vm
-X11_CONFIGURE_ENABLE= graphics
-X11_BUILD_DEPENDS_OFF= ${LOCALBASE}/include/boinc/std_fixes.h:net/boinc-client
-
-do-install:
- @${MKDIR} ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
- ${INSTALL_PROGRAM} ${WRKSRC}/${AP_BINARY} \
- ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
-
-do-install-X11-on:
- ${INSTALL_PROGRAM} ${WRKSRC}/ap_graphics \
- ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
-
-.include <bsd.port.mk>
diff --git a/astro/boinc-astropulse/distinfo b/astro/boinc-astropulse/distinfo
deleted file mode 100644
index d47706675596..000000000000
--- a/astro/boinc-astropulse/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (astropulse-svn-1702.tar.xz) = cfb307628dc02f0407f7571fed7e91b7824fd385278ecfa2b30ed5fb8c38cd46
-SIZE (astropulse-svn-1702.tar.xz) = 7397348
diff --git a/astro/boinc-astropulse/files/patch-Makefile.am b/astro/boinc-astropulse/files/patch-Makefile.am
deleted file mode 100644
index 9083bb5b2dda..000000000000
--- a/astro/boinc-astropulse/files/patch-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.am.orig 2009-06-11 17:35:16 UTC
-+++ Makefile.am
-@@ -31,7 +31,7 @@ if ENABLE_GUI
- GUI_C_FLAGS = $(CLIENT_C_FLAGS) $(GRAPHICS_CFLAGS)
- GUI_LD_FLAGS = $(CLIENT_LD_FLAGS)
- GUI_LD_ADD = -L$(BOINCDIR)/api -L$(BOINCDIR)/lib $(BOINC_LIBS) $(GRAPHICS_LIBS_RAW) $(APP_LIBS)
-- CLIENT_LD_FLAGS += $(LDSTATIC) -nodefaultlibs
-+ CLIENT_LD_FLAGS += $(LDSTATIC)
- CLIENT_LD_ADD += -L$(BOINCDIR)/api -L$(BOINCDIR)/lib $(BOINC_LIBS) $(AM_LIBS) $(APP_LIBS)
- AP_GRX_SOURCES = ap_gfx_main.cpp
- else
diff --git a/astro/boinc-astropulse/files/patch-ap__client__main.cpp b/astro/boinc-astropulse/files/patch-ap__client__main.cpp
deleted file mode 100644
index f9910dfc1202..000000000000
--- a/astro/boinc-astropulse/files/patch-ap__client__main.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
---- ap_client_main.cpp.orig 2012-08-14 00:07:20 UTC
-+++ ap_client_main.cpp
-@@ -241,7 +241,7 @@ int detect_hit(float *arr, float& total)
- * calls to this function.
- */
- void updatecputime() {
-- int cputicksinterval = abs(clock() - lastcputicks);
-+ int cputicksinterval = abs((long)clock() - (long)lastcputicks);
- lastcputicks = clock();
- maxcputicksinterval = (maxcputicksinterval > cputicksinterval)?maxcputicksinterval:cputicksinterval;
- cputime += ((float)cputicksinterval / (float)CLOCKS_PER_SEC);
---- ap_client_main.cpp.orig 2012-08-14 00:07:20 UTC
-+++ ap_client_main.cpp
-@@ -1288,7 +1288,6 @@ void Science::mainloop() {
- * used to inform the core client GUI of the % complete.
- */
- boinc_fraction_done(state.frac_done);
-- boinc_ops_cumulative(state.frac_done*FLOPS_PER_DM*(state.dm_hi-state.dm_low)*log((float)state.fft_len)/log(32768.0),0);
- debug_loop(5, 2, debug_loop_msg);
-
- /* This is the size of the power array.
diff --git a/astro/boinc-astropulse/files/patch-ap__fileio.cpp b/astro/boinc-astropulse/files/patch-ap__fileio.cpp
deleted file mode 100644
index 649bf4b31e33..000000000000
--- a/astro/boinc-astropulse/files/patch-ap__fileio.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ap_fileio.cpp.orig 2012-02-27 23:01:04 UTC
-+++ ap_fileio.cpp
-@@ -22,6 +22,7 @@
- #include "windows.h"
- #endif
-
-+#include <cmath>
- #include <cstdio>
- #include <cstdlib>
- #include <vector>
diff --git a/astro/boinc-astropulse/files/patch-ap__fold.cpp b/astro/boinc-astropulse/files/patch-ap__fold.cpp
deleted file mode 100644
index 23d13a925dfd..000000000000
--- a/astro/boinc-astropulse/files/patch-ap__fold.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ap_fold.cpp.orig 2009-04-01 00:11:24 UTC
-+++ ap_fold.cpp
-@@ -283,7 +283,6 @@ int Science::ffa(float *data, int num_su
- * used to inform the core client GUI of the % complete.
- */
- boinc_fraction_done(state.frac_done);
-- boinc_ops_cumulative(state.frac_done*FLOPS_PER_DM*(state.dm_hi-state.dm_low)*log((double)state.fft_len)/log(32768.0),0);
-
- freq_count++;
- /* Report to stdout if we have reached a new "milestone" frequency. */
diff --git a/astro/boinc-astropulse/files/patch-ap__remove__radar.cpp b/astro/boinc-astropulse/files/patch-ap__remove__radar.cpp
deleted file mode 100644
index ee531cec87f4..000000000000
--- a/astro/boinc-astropulse/files/patch-ap__remove__radar.cpp
+++ /dev/null
@@ -1,8 +0,0 @@
---- ap_remove_radar.cpp.orig 2012-01-26 06:53:16 UTC
-+++ ap_remove_radar.cpp
-@@ -1,5 +1,4 @@
- #include "astropulse.h"
--#include "ap_graphics.h"
- #include "fftw3.h"
- #include "sbtf.h"
- #include "ap_debug.h"
diff --git a/astro/boinc-astropulse/files/patch-configure.ac b/astro/boinc-astropulse/files/patch-configure.ac
deleted file mode 100644
index f02cac4fe642..000000000000
--- a/astro/boinc-astropulse/files/patch-configure.ac
+++ /dev/null
@@ -1,41 +0,0 @@
---- configure.ac.orig 2012-08-14 00:07:20 UTC
-+++ configure.ac
-@@ -10,17 +10,9 @@ AC_INIT(astropulse, 6.01)
- dnl tell libtool the location of the m4 macros
- AC_CONFIG_MACRO_DIR([m4])
-
--svnrev="`svn info | grep Revision:`"
--
--if test -n "${svnrev}" ; then
-- AC_REVISION("${svnrev}")
-- AC_DEFINE_UNQUOTED(SVN_REV,"${svnrev}",
-- [Define to be the subversion revision number])
--else
-- AC_REVISION([$Revision: 1190 $])
-- AC_DEFINE(SVN_REV,"$Revision: 1190 $",
-+ AC_REVISION([$Revision: 1702 $])
-+ AC_DEFINE(SVN_REV,"$Revision: 1702 $",
- [Define to be the subversion revision number])
--fi
-
-
- echo "--- Configuring Astropulse $AC_PACKAGE_VERSION ---"
-@@ -267,9 +259,7 @@ dnl AC_CHECK_LIB([z], [uncompress])
- dnl AC_CHECK_LIB([stdc++], [main])
- SAH_GRX_LIBS
- AC_LANG(C++)
--SAH_CHECK_BOINC
- SAH_CHECK_SAH
--SAH_FIND_SETILIB
- AC_CACHE_SAVE
-
- if test "${ac_cv_cxx_compiler_gnu}" = "yes" ; then
-@@ -383,7 +373,7 @@ AM_CONDITIONAL(ENABLE_CLIENT, [test "${e
- AM_CONDITIONAL(ENABLE_GUI, [test "${enable_graphics}" = yes])
- AM_CONDITIONAL(LINUX, [test -n "`echo ${target} | grep linux`"])
- AM_CONDITIONAL(I386, [test -n "`echo ${target} | grep i.86`"])
--AM_CONDITIONAL(X86_64, [test -n "`echo ${target} | grep 'x86_64'`"])
-+AM_CONDITIONAL(X86_64, [test -n "`echo ${target} | ${EGREP} 'x86_64|amd64'`"])
- AM_CONDITIONAL(PPC, [test -n "`echo ${target} | grep 'powerpc'`" -o -n "`echo ${target} | grep 'ppc'`" ])
-
-
diff --git a/astro/boinc-astropulse/files/patch-m4_sah__check__boinc.m4 b/astro/boinc-astropulse/files/patch-m4_sah__check__boinc.m4
deleted file mode 100644
index 6cbf7ca91f6f..000000000000
--- a/astro/boinc-astropulse/files/patch-m4_sah__check__boinc.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- m4/sah_check_boinc.m4.orig 2010-03-23 21:00:23 UTC
-+++ m4/sah_check_boinc.m4
-@@ -30,7 +30,7 @@ AC_DEFUN([SAH_CHECK_BOINC],[
- cd $thisdir
- break
- else
-- if $FIND $boinc_dir -name "std_fixes.h" >& /dev/null
-+ if $FIND $boinc_dir -name "std_fixes.h" > /dev/null
- then
- BOINCDIR=`$FIND $boinc_dir -name "std_fixes.h" -print | $HEAD -1 | sed 's/\/std_fixes.h//'`
- cd $BOINCDIR/..
diff --git a/astro/boinc-astropulse/files/pkg-deinstall.in b/astro/boinc-astropulse/files/pkg-deinstall.in
deleted file mode 100644
index a103cd57148a..000000000000
--- a/astro/boinc-astropulse/files/pkg-deinstall.in
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-if [ "$2" != "POST-DEINSTALL" ]; then
- exit 0
-fi
-
-F=%%BOINC_CLIENT_HOME%%/projects/%%SETI_SITE%%/app_info.xml
-echo Removing astropulse_v6 lines from $F
-
-l=`grep -n "<name>astropulse_v6</name>" $F | cut -f 1 -d :`
-if [ $? -ne 0 ]; then
- echo $F is corrupt
- exit 1
-fi
-l1=$(($l-1))
-l2=$(($l+13))
-sed -i.bak "${l1},${l2}d" $F # sed wants the braces
-rm $F.bak
-
-l=`wc -l $F | cut -f 1 -d / | sed 's/ //g'`
-if [ $l -eq 2 ]; then
- echo Removing empty $F
- rm $F
-fi
diff --git a/astro/boinc-astropulse/files/pkg-install.in b/astro/boinc-astropulse/files/pkg-install.in
deleted file mode 100644
index a000ee65b682..000000000000
--- a/astro/boinc-astropulse/files/pkg-install.in
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-
-if [ "$2" != "POST-INSTALL" ]; then
- exit 0
-fi
-
-F=%%BOINC_CLIENT_HOME%%/projects/%%SETI_SITE%%/app_info.xml
-
-if [ ! -f $F ]; then
- echo Creating new $F
- echo "<app_info>" > $F
- echo "</app_info>" >> $F
- chown %%BOINC_CLIENT_USER%%:%%BOINC_CLIENT_GROUP%% $F
-fi
-
-echo Adding astropulse_v6 lines to $F
-ed - $F <<EOF
-1a
-<app>
-<name>astropulse_v6</name>
-</app>
-<file_info>
-<name>%%AP_BINARY%%</name>
-<executable/>
-</file_info>
-<app_version>
-<app_name>astropulse_v6</app_name>
-<version_num>%%AP_VERSION%%</version_num>
-<file_ref>
-<file_name>%%AP_BINARY%%</file_name>
-<main_program/>
-</file_ref>
-</app_version>
-.
-w
-q
-EOF
diff --git a/astro/boinc-astropulse/files/pkg-message.in b/astro/boinc-astropulse/files/pkg-message.in
deleted file mode 100644
index 1e5268e2b458..000000000000
--- a/astro/boinc-astropulse/files/pkg-message.in
+++ /dev/null
@@ -1,20 +0,0 @@
-[
-{ type: install
- message: <<EOM
-ATTACHING PROJECT
-
-Just run boinc_gui (if installed), choose Attach, and follow instructions.
-Project URL is %%SETI_SITE%%
-
-MANUAL INSTALLATION
- *) If this is your first time in any BOINC project, create a new account at
- http://%%SETI_SITE%%/create_account_form.php
-
- *) Or get your account key at http://%%SETI_SITE%%/get_passwd.php
-
- *) Attach to the project:
- cd %%BOINC_CLIENT_HOME%%
- boinccmd --project_attach %%SETI_SITE%% <account key>
-EOM
-}
-]
diff --git a/astro/boinc-astropulse/pkg-descr b/astro/boinc-astropulse/pkg-descr
deleted file mode 100644
index 18531ad5594d..000000000000
--- a/astro/boinc-astropulse/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-SETI - Search for Extra-Terrestrial Intelligence -- AstroPulse
-
-The project listens for broad-band, short-time pulses that might represent
-extraterrestial intelligence, or other phenomena such as rapidly rotating
-pulsars or exploding primordial black holes.
-
-The port automatically optimizes for the host CPU using the CPUTYPE
-variable in /etc/make.conf
-
-WWW: http://setiathome.berkeley.edu/
diff --git a/astro/boinc-astropulse/pkg-plist b/astro/boinc-astropulse/pkg-plist
deleted file mode 100644
index 044f9fe84956..000000000000
--- a/astro/boinc-astropulse/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-@owner %%BOINC_CLIENT_USER%%
-@group %%BOINC_CLIENT_GROUP%%
-@dir %%BOINC_CLIENT_HOME%%
-@dir %%BOINC_CLIENT_HOME%%/projects/
-@dir %%BOINC_CLIENT_HOME%%/projects/%%SETI_SITE%%
-%%BOINC_CLIENT_HOME%%/projects/%%SETI_SITE%%/%%AP_BINARY%%
-%%X11%%%%BOINC_CLIENT_HOME%%/projects/%%SETI_SITE%%/ap_graphics
-@owner root
-@group wheel