aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 06:26:31 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 06:26:31 +0000
commit6ee4f3c0edb78d03dd3593708882d63a840d5fbd (patch)
treedd2960674890c75b92567e09d64953d38bf531fd /astro
parentc03bfbe46d862034379cd278fe40e74125bfd355 (diff)
downloadports-6ee4f3c0edb78d03dd3593708882d63a840d5fbd.tar.gz
ports-6ee4f3c0edb78d03dd3593708882d63a840d5fbd.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-astropulse/Makefile2
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile2
-rw-r--r--astro/cfitsio/Makefile4
-rw-r--r--astro/gpsd/Makefile3
4 files changed, 5 insertions, 6 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index a1c76fd87141..c511d6341120 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -19,11 +19,11 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
+USES= pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
WRKSRC= ${WRKDIR}/${DISTNAME}/client
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index 690ad3a9e5d1..b58bd4a916bb 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -18,11 +18,11 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
+USES= pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_GCC= any
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 4a03a8aaee60..5cc746526437 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -25,8 +25,8 @@ CONFIGURE_ARGS= ac_cv_prog_FC="f2c"
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
-WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= pkgconfig
+RKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index 400d23884ae4..3d968d3726a2 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -13,8 +13,7 @@ COMMENT= Daemon that monitors one or more GPSes attached to a host computer
BUILD_DEPENDS= docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
xsltproc:${PORTSDIR}/textproc/libxslt
-USES= pathfix
-USE_PKGCONFIG= build
+USES= pathfix pkgconfig
USE_SCONS= yes
USE_RC_SUBR= gpsd
USE_PYTHON= yes