aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-22 14:35:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-22 14:35:32 +0000
commit74cc837141144dd018d0ed84bb5207fe83efc970 (patch)
tree79d445d6971d1859d038d7672aa1ffd834fed0ff /astro
parent90d8c77fba1d7a636edfc82879d63649cce7853f (diff)
downloadports-74cc837141144dd018d0ed84bb5207fe83efc970.tar.gz
ports-74cc837141144dd018d0ed84bb5207fe83efc970.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/sunclock/Makefile8
-rw-r--r--astro/sunclock/distinfo2
-rw-r--r--astro/sunclock/files/patch-aa62
-rw-r--r--astro/sunclock/pkg-plist7
4 files changed, 49 insertions, 30 deletions
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index a0dbb31cbfaf..74ab9d09c2cc 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -1,3 +1,4 @@
+# ex:ts=8
# New ports collection makefile for: sunclock
# Date created: 15 September 1996
# Whom: torstenb
@@ -6,18 +7,17 @@
#
PORTNAME= sunclock
-PORTVERSION= 3.27
+PORTVERSION= 3.38
CATEGORIES= astro x11-clocks
MASTER_SITES= ftp://ftp.ac-grenoble.fr/ge/geosciences/
EXTRACT_SUFX= .tgz
MAINTAINER= torstenb@FreeBSD.org
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
USE_IMAKE= YES
MAN1= sunclock.1
-post-patch:
- @${PERL} -pi -e "s|%%X11BASE%%|${X11BASE}|g" ${WRKSRC}/Imakefile
-
.include <bsd.port.mk>
diff --git a/astro/sunclock/distinfo b/astro/sunclock/distinfo
index 897ae1ac2da8..a39f33b3facc 100644
--- a/astro/sunclock/distinfo
+++ b/astro/sunclock/distinfo
@@ -1 +1 @@
-MD5 (sunclock-3.27.tgz) = fccba948f48a65a3c481a8411f41de98
+MD5 (sunclock-3.38.tgz) = faf0bef785866799a181024ab8823f85
diff --git a/astro/sunclock/files/patch-aa b/astro/sunclock/files/patch-aa
index 147dbfb7f52c..1d7ba4f609d2 100644
--- a/astro/sunclock/files/patch-aa
+++ b/astro/sunclock/files/patch-aa
@@ -1,31 +1,45 @@
---- Imakefile.orig Sat Dec 30 15:24:02 2000
-+++ Imakefile Sat Dec 30 15:38:55 2000
-@@ -8,7 +8,7 @@
- XCOMM Pick -O or -g
- XCOMM
+--- Imakefile.orig Sun Apr 22 22:27:53 2001
++++ Imakefile Sun Apr 22 22:30:04 2001
+@@ -1,15 +1,17 @@
+ XCOMM Should install to /usr or /usr/local ??
+-DESTDIR=/usr
++DESTDIR=${PREFIX}
+
+ XCOMM Name of man subdirectory of DESTDIR:
+-MANDIR=/X11R6/man/man1
++MANDIR=/man/man1
--SHAREDIR=/usr/share/sunclock
-+SHAREDIR=%%X11BASE%%/share/sunclock
+ XCOMM Name of bin subdirectory of DESTDIR: /X11R6/bin or maybe just /bin
+-BINDIR=/X11R6/bin
++BINDIR=/bin
- #ifdef HPArchitecture
- CCOPTIONS = -Ae -DBIGFONT=\"6x13\" -DSMALLFONT=\"6x10\" -DAPPDEF=\"$(DESTDIR)$(XAPPLOADDIR)\" -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
-@@ -16,16 +16,16 @@
- # SunOS
- #CCOPTIONS=-DBIGFONT=\"6x13\" -DSMALLFONT=\"6x10\" -O -DNEW_CTIME -DAPPDEF=\"$(DESTDIR)$(XAPPLOADDIR)\" -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
+ XCOMM Name of share subdirectory of DESTDIR:
+ SHAREDIR=/share/sunclock
+
++DOCHTMLDIR=/lib/X11/doc/html
++
+ XCOMM
+ XCOMM Compile options:
+ XCOMM
+@@ -38,17 +40,17 @@
# Solaris, Linux
--CCOPTIONS=-DBIGFONT=\"6x13\" -DSMALLFONT=\"6x10\" -O -DAPPDEF=\"$(DESTDIR)$(XAPPLOADDIR)\" -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
-+CCOPTIONS=-DBIGFONT=\"6x13\" -DSMALLFONT=\"6x10\" -O -DAPPDEF=\"$(DESTDIR)$(XAPPLOADDIR)\" -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\" -DNEW_CTIME
+ #XPMLIB=-L/usr/X11R6/lib
+ #XPMINC=-I/usr/X11R6/include/X11
+-#JLIB=-L/usr/lib
+-#JINC=-I/usr/include
++JLIB=-L${LOCALBASE}/lib
++JINC=-I${LOCALBASE}/include
+
+-CCOPTIONS=-O -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
++CCOPTIONS=-O -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\" -DNEW_CTIME -I${LOCALBASE}/include
#endif
- SRCS=sunclock.c astro.c tildepath.c mapdata.c dirlist.c
- OBJS=sunclock.o astro.o tildepath.o mapdata.o dirlist.o
--LOCAL_LIBRARIES=$(XLIB) -lXpm -lm
-+LOCAL_LIBRARIES=$(XLIB) -lXpm -lm -lcompat
+ SRCS=sunclock.c astro.c widgets.c tildepath.c dirlist.c \
+ readvmf.c readxpm.c readjpeg.c
+ OBJS=sunclock.o astro.o widgets.o tildepath.o dirlist.o \
+ readvmf.o readxpm.o readjpeg.o
+-LOCAL_LIBRARIES=$(XLIB) $(XPMLIB) -lXpm $(JLIB) -ljpeg -lm
++LOCAL_LIBRARIES=$(XLIB) $(XPMLIB) -lXpm $(JLIB) -ljpeg -lm -lcompat
DEPLIBS= # I don't know what I'm doing, and I hate imake!
- genmap:: mapdata.o
-- gcc -c mapgen.c -o mapgen.o
-+ gcc -I%%X11BASE%%/include -c mapgen.c -o mapgen.o
- gcc -o mapgen -O mapgen.o mapdata.o -lm
-
- maps:: genmap
+ ComplexProgramTarget(sunclock)
diff --git a/astro/sunclock/pkg-plist b/astro/sunclock/pkg-plist
index 82d2c899714a..da69fef59170 100644
--- a/astro/sunclock/pkg-plist
+++ b/astro/sunclock/pkg-plist
@@ -1,9 +1,14 @@
bin/sunclock
-lib/X11/app-defaults/Sunclock
+share/sunclock/Sunclockrc
+share/sunclock/earthmaps/vmf/standard.vmf
+@dirrm share/sunclock/earthmaps/vmf
+@dirrm share/sunclock/earthmaps
share/sunclock/i18n/Sunclock.de
share/sunclock/i18n/Sunclock.en
share/sunclock/i18n/Sunclock.es
share/sunclock/i18n/Sunclock.fr
share/sunclock/i18n/Sunclock.it
+share/sunclock/i18n/Sunclock.nl
+share/sunclock/i18n/Sunclock.no
share/sunclock/i18n/Sunclock.se
@dirrm share/sunclock/i18n