aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-06 17:51:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-06 17:51:38 +0000
commit5d44581a5b26b1abe4e764d76248e45c2a887062 (patch)
tree38f4781a51845e83feef9d148ff859c51e2e3659 /astro
parent4db8d1b0fb6e763ec686a152ff60b8c0cac078fa (diff)
downloadports-5d44581a5b26b1abe4e764d76248e45c2a887062.tar.gz
ports-5d44581a5b26b1abe4e764d76248e45c2a887062.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/cfitsio/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 2bacb7d68eec..d40374b913b3 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -15,8 +15,6 @@ DISTNAME= ${PORTNAME}${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library for reading and writing files in FITS data format
-LICENSE= MIT
-
LIB_DEPENDS= libf2c.so:${PORTSDIR}/lang/f2c
OPTIONS_DEFINE= DOCS
@@ -36,7 +34,7 @@ PLIST_SUB= SHLIB_MAJOR_VER=${SHLIB_MAJOR_VER} \
PORTDOCS= *
SHLIB_MAJOR_VER=2
-SHLIB_MINOR_VER=${PORTVERSION:S/0$//}
+SHLIB_MINOR_VER=${PORTVERSION:S|0$||}
do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${STAGEDIR}${PREFIX}/include/
@@ -45,6 +43,8 @@ do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} cfitsio.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
${LN} -fs libcfitsio.so.${SHLIB_MAJOR_VER}.${SHLIB_MINOR_VER} ${STAGEDIR}${PREFIX}/lib/libcfitsio.so.${SHLIB_MAJOR_VER}
${LN} -fs libcfitsio.so.${SHLIB_MAJOR_VER} ${STAGEDIR}${PREFIX}/lib/libcfitsio.so
+
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/docs/*.doc ${STAGEDIR}${DOCSDIR}/