aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2010-03-25 08:06:12 +0000
committerKevin Lo <kevlo@FreeBSD.org>2010-03-25 08:06:12 +0000
commit92c47d8d02068bc503d486af636f98ad0362d224 (patch)
treeb702717da8b11bef6047378d850393e5ce1878e3 /astro
parent5832e3c6bf466590ba8fff3313d550d198c23c20 (diff)
downloadports-92c47d8d02068bc503d486af636f98ad0362d224.tar.gz
ports-92c47d8d02068bc503d486af636f98ad0362d224.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/gmapcatcher/Makefile6
-rw-r--r--astro/gmapcatcher/files/patch-src_mapArgs.py15
2 files changed, 21 insertions, 0 deletions
diff --git a/astro/gmapcatcher/Makefile b/astro/gmapcatcher/Makefile
index 0030804b25fb..a7b8d840cc3e 100644
--- a/astro/gmapcatcher/Makefile
+++ b/astro/gmapcatcher/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmapcatcher
PORTVERSION= 0.6.3.0
+PORTREVISION= 1
CATEGORIES= astro geography
MASTER_SITES= http://gmapcatcher.googlecode.com/files/
DISTNAME= GMapCatcher-${PORTVERSION}
@@ -14,11 +15,16 @@ DISTNAME= GMapCatcher-${PORTVERSION}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= An offline map viewer
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+
USE_PYTHON= yes
USE_GNOME= pygtk2
WRKSRC= ${WRKDIR}/${DISTNAME}
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} {} \;
+
do-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
diff --git a/astro/gmapcatcher/files/patch-src_mapArgs.py b/astro/gmapcatcher/files/patch-src_mapArgs.py
new file mode 100644
index 000000000000..3981b8a5de37
--- /dev/null
+++ b/astro/gmapcatcher/files/patch-src_mapArgs.py
@@ -0,0 +1,15 @@
+--- src/mapArgs.py.orig 2010-03-25 15:48:48.000000000 +0800
++++ src/mapArgs.py 2010-03-25 15:49:26.000000000 +0800
+@@ -38,9 +38,9 @@
+ print ' very useful to download maps of entire world'
+ print ' '
+ print 'SAMPLE USAGE'
+- print ' download.py --location="Paris, France"'
+- print ' download.py --min-zoom=13 --full-range'
+- print ' download.py --latitude=37.979180 --longitude=23.716647'
++ print ' gmapcatcher-download --location="Paris, France"'
++ print ' gmapcatcher-download --min-zoom=13 --full-range'
++ print ' gmapcatcher-download --latitude=37.979180 --longitude=23.716647'
+
+ def __init__(self, arrArgs=()):
+ if len(arrArgs) > 1: