aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-04 20:36:47 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-04 20:36:47 +0000
commit3febe31ec588e7957ef6054194685debcc4aaf4c (patch)
tree5fa6aa25ee7f38cf5d348b33f657b5c0a8e0b2a9 /astro
parent1679adb20541fcf339789c36dbfb859dd734b955 (diff)
downloadports-3febe31ec588e7957ef6054194685debcc4aaf4c.tar.gz
ports-3febe31ec588e7957ef6054194685debcc4aaf4c.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/gpscorrelate/Makefile24
-rw-r--r--astro/merkaartor/Makefile4
2 files changed, 13 insertions, 15 deletions
diff --git a/astro/gpscorrelate/Makefile b/astro/gpscorrelate/Makefile
index 4e7225584a5b..11ff864772ae 100644
--- a/astro/gpscorrelate/Makefile
+++ b/astro/gpscorrelate/Makefile
@@ -1,9 +1,9 @@
-# Created by: Lukas Maly
+# Created by: Lukas Maly <Iam@LukasMaly.NET>
# $FreeBSD$
PORTNAME= gpscorrelate
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro geography
MASTER_SITES= GH
DIST_SUBDIR= repacked
@@ -16,20 +16,18 @@ LICENSE= GPLv2
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
-OPTIONS_DEFINE= DOCS
+USES= gmake pkgconfig
+USE_GNOME= libxml2
USE_GITHUB= yes
GH_ACCOUNT= freefoote
GH_COMMIT= a36646b
-USES= gmake pkgconfig
-USE_GNOME= libxml2
-
-PORTDOCS= *
PLIST_FILES= bin/gpscorrelate bin/gpscorrelate-gui \
man/man1/gpscorrelate.1.gz man/man1/gpscorrelate-gui.1.gz
+PORTDOCS= *
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e \
@@ -42,20 +40,20 @@ post-patch:
s|g++ $$(OFLAGS)|$$(CXX) $$(OFLAGS)| ; \
s|g++ $$(CFLAGS)|$$(CXX) $$(CXXFLAGS) $$(IFLAGS)| ; \
s|gcc $$(CFLAGS)|$$(CC) $$(CFLAGS) $$(IFLAGS)|' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate-gui ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/gpscorrelate.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${LN} -sf gpscorrelate.1 ${STAGEDIR}${MANPREFIX}/man/man1/gpscorrelate-gui.1
-.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL_MAN} ${FILESDIR}/gpscorrelate.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${LN} -sf gpscorrelate.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1/gpscorrelate-gui.1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/RELEASES ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/doc/*.png ${STAGEDIR}${DOCSDIR}/html
-.endif
.include <bsd.port.mk>
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index ae5f3f166939..abe83ae6811b 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -1,9 +1,9 @@
-# Created by: slaven@rezic.de
+# Created by: Slaven Rezic <slaven@rezic.de>
# $FreeBSD$
PORTNAME= merkaartor
PORTVERSION= 0.18.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= http://merkaartor.be/attachments/download/301/ \
https://secure.ohos.nl/downloads/