aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-17 17:44:51 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-17 17:44:51 +0000
commit84460ddec91bb7dfcbcc9e2f08c534572a8a5128 (patch)
tree91ad001fec7648c5446664c88b057be1d201f723 /astro
parent2ff1d320d76e08d57df48ac55a6dc0c0d6d3715a (diff)
downloadports-84460ddec91bb7dfcbcc9e2f08c534572a8a5128.tar.gz
ports-84460ddec91bb7dfcbcc9e2f08c534572a8a5128.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/merkaartor/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 08652be5cffa..ae5f3f166939 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -11,42 +11,48 @@ MASTER_SITES= http://merkaartor.be/attachments/download/301/ \
MAINTAINER= dev2@heesakkers.info
COMMENT= Openstreetmap mapping program
-BROKEN= Does not build
-
LICENSE= GPLv2
LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
libproj.so:${PORTSDIR}/graphics/proj
-USE_BZIP2= yes
+USES= qmake tar:bzip2
USE_LDCONFIG= yes
USE_QT4= uic_build moc_build rcc_build \
gui network svg webkit xml imageformats script scripttools
-OPTIONS_DEFINE= GEOIMAGE ZBAR DEBUG NLS
+OPTIONS_DEFINE= DEBUG GEOIMAGE NLS ZBAR
OPTIONS_DEFAULT= GEOIMAGE
GEOIMAGE_DESC= Enable geotagged images (needs exiv2)
GEOIMAGE_QMAKE_ON= GEOIMAGE=1
GEOIMAGE_LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
-ZBAR_DESC= Read barcodes from walking papers
+ZBAR_DESC= Read barcodes from walking papers (BROKEN)
ZBAR_QMAKE_ON= ZBAR=1
ZBAR_LIB_DEPENDS= libzbar.so:${PORTSDIR}/graphics/zbar
DEBUG_QMAKE_OFF= NODEBUG=1 RELEASE=1
+OPTIONS_SUB= yes
+
.include <bsd.port.options.mk>
-.if empty(PORT_OPTIONS:MNLS)
-PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
+.if ${PORT_OPTIONS:MZBAR}
+BROKEN= Does not build with option ZBAR selected
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
USE_QT4+= linguist_build
pre-build:
@cd ${WRKSRC}/translations && ${LRELEASE} ../src/src.pro
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/translations
+ @(cd ${WRKSRC}/translations && ${COPYTREE_SHARE} "merkaartor_*.qm" \
+ ${STAGEDIR}${DATADIR}/translations)
.endif
.include <bsd.port.mk>