aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 04:53:11 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 04:53:11 +0000
commit6751ed7d7017b0178a79f87e243543c718def2c1 (patch)
treeea773e62822f3267810fb171c2d3325fda54f64a /astro
parent2c549745ae7bcac47d93a333fe5859bda0d5f80a (diff)
downloadports-6751ed7d7017b0178a79f87e243543c718def2c1.tar.gz
ports-6751ed7d7017b0178a79f87e243543c718def2c1.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/spacechart/Makefile3
-rw-r--r--astro/starplot/Makefile5
2 files changed, 5 insertions, 3 deletions
diff --git a/astro/spacechart/Makefile b/astro/spacechart/Makefile
index 540fbb467fa2..0180c5048c62 100644
--- a/astro/spacechart/Makefile
+++ b/astro/spacechart/Makefile
@@ -18,13 +18,14 @@ COMMENT= SpaceChart is a star chart viewer for GNOME
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomelibs
CONFIGURE_ARGS= --without-included-gettext --datadir=${PREFIX}/share
# trick it into using ports installed gettext
post-patch:
- @${PERL} -pi -ne "s|(INTLLIBS =).*$$|\1-I${LOCALBASE}/lib -lintl|" \
+ @${REINPLACE_CMD} -e 's|\(INTLLIBS =\).*$$|\1-I${LOCALBASE}/lib -lintl|' \
${WRKSRC}/src/Makefile.in
pre-build:
diff --git a/astro/starplot/Makefile b/astro/starplot/Makefile
index aa4d23eeb15b..7147e4a436e2 100644
--- a/astro/starplot/Makefile
+++ b/astro/starplot/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= pat@FreeBSD.org
COMMENT= 3-dimensional viewer for star charts
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
USE_XPM= yes
@@ -23,10 +24,10 @@ MAKE_ENV= DATADIR="${DATADIR}" \
MAN1= starplot.1 starconvert.1
pre-patch:
- @${PERL} -pi.orig -e 's|DATADIR|${DATADIR}|; s|DOCDIR|${DOCSDIR}|; \
+ @${REINPLACE_CMD} -e 's|DATADIR|${DATADIR}|; s|DOCDIR|${DOCSDIR}|; \
s|BINARYNAME|${PORTNAME}|; s|CONVERTNAME|starconvert|' \
${WRKSRC}/doc/man/*
- @${PERL} -pi.orig -e 's|/usr/local/share/starplot|${DATADIR}|; \
+ @${REINPLACE_CMD} -e 's|/usr/local/share/starplot|${DATADIR}|; \
s|/usr/local/share/doc/starplot|${DOCSDIR}|' \
${WRKSRC}/gui/starplot.h