aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:03:57 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:03:57 +0000
commitd7a03dce78c9c54215763e9b5a68f04fca68bd21 (patch)
treed1e681d20cef8dec6f50120be296841a3ee27d88 /astro
parent0a0f66e4af5526771ba714077758f66c0cfd001d (diff)
downloadports-d7a03dce78c9c54215763e9b5a68f04fca68bd21.tar.gz
ports-d7a03dce78c9c54215763e9b5a68f04fca68bd21.zip
Diffstat (limited to 'astro')
-rw-r--r--astro/oskar/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/astro/oskar/Makefile b/astro/oskar/Makefile
index 3ee914634f9b..2dd172789014 100644
--- a/astro/oskar/Makefile
+++ b/astro/oskar/Makefile
@@ -18,8 +18,12 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libhdf5.so:science/hdf5 \
libsz.so:science/libaec
-USES= cmake compiler:c++11-lang localbase:ldflags python qt:5 \
- shebangfix
+USES= cmake localbase:ldflags python qt:5 shebangfix
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
USE_QT= core gui network widgets buildtools:build qmake:build
USE_LDCONFIG= yes