aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-02-17 03:26:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-02-17 03:26:42 +0000
commitfd869679891863fe55dc692e4083361aaf77f0cd (patch)
treeb0aad05b2d5a7829c961eb54d0c8747233bd56d4 /astro
parent2e7511cffbbb8be28f7f6b4167f78c185f3c25cf (diff)
downloadports-fd869679891863fe55dc692e4083361aaf77f0cd.tar.gz
ports-fd869679891863fe55dc692e4083361aaf77f0cd.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/geographiclib/Makefile12
-rw-r--r--astro/geographiclib/distinfo8
-rw-r--r--astro/geographiclib/files/patch-CMakeLists.txt4
-rw-r--r--astro/geographiclib/pkg-descr8
-rw-r--r--astro/geographiclib/pkg-help43
-rw-r--r--astro/geographiclib/pkg-plist4
6 files changed, 62 insertions, 17 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 5f3bada03f0e..0f7ecf2b1bc5 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= geographiclib
-DISTVERSION= 1.50
+DISTVERSION= 1.50.1
CATEGORIES= astro
MASTER_SITES= SF/geographiclib/distrib\
SF/geographiclib/distrib/archive\
SF/geographiclib:geoids,gravity,magnetic
-DISTNAME= GeographicLib-${DISTVERSION}${DISTVERSIONSUFFIX}
+DISTNAME= GeographicLib-${DISTVERSIONFULL}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} #
DIST_SUBDIR= GeographicLib
@@ -18,7 +18,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= cmake compiler:c++14-lang python:env
-WRKSRC= ${WRKDIR}/GeographicLib-${DISTVERSION}
PORTDOCS= *
USE_LDCONFIG= yes
CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q}\
@@ -29,10 +28,11 @@ CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q}\
OPTIONS_DEFINE= DOCS DOXYGEN PERL
OPTIONS_DEFAULT= DOXYGEN PERL\
GEOID_EGM96_5 GRAVITY_EGM96 GRAVITY_WGS84\
- MAGNETIC_WMM2015V2 MAGNETIC_IGRF12
+ MAGNETIC_WMM2020 MAGNETIC_IGRF12
PERL_DESC= Build documentation with pod2man and pod2html
OPTIONS_GROUP= DATASETS
OPTIONS_SUB= yes
+DATASETS_DESC= geoid datasets, gravity models and magnetic field models
DOXYGEN_CMAKE_BOOL= GEOGRAPHICLIB_DOCUMENTATION
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen\
sphinx-build:textproc/py-sphinx
@@ -44,7 +44,8 @@ PERL_BUILD_DEPENDS= nroff:textproc/groff
GEOID_NAMES= egm84-30 egm84-15 egm96-15 egm96-5\
egm2008-5 egm2008-2_5 egm2008-1
GRAVITY_NAMES= egm84 egm96 egm2008 wgs84 grs80
-MAGNETIC_NAMES= wmm2010 wmm2015 wmm2015v2 igrf11 igrf12\
+MAGNETIC_NAMES= wmm2010 wmm2015 wmm2015v2 wmm2020\
+ igrf11 igrf12\
emm2010 emm2015 emm2017
DEPRECATED_NAMES= wmm2015
@@ -70,7 +71,6 @@ MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= magnetic-distrib/${n}.tar.bz2:ma
MAKESUM_OPTIONS_DEFAULT+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.endfor
-# Memorandum: use "make fetch makesum" to makesum all distfiles.
.ifmake makesum || distclean
OPTIONS_DEFAULT= ${MAKESUM_OPTIONS_DEFAULT}
.endif
diff --git a/astro/geographiclib/distinfo b/astro/geographiclib/distinfo
index 26af510a22ff..0327f4374542 100644
--- a/astro/geographiclib/distinfo
+++ b/astro/geographiclib/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1569492000
-SHA256 (GeographicLib/GeographicLib-1.50.tar.gz) = 2ac8888094d21ba48adb433c4bb569937497b39733e96c080b5ce278e2587622
-SIZE (GeographicLib/GeographicLib-1.50.tar.gz) = 2463958
+TIMESTAMP = 1581822000
+SHA256 (GeographicLib/GeographicLib-1.50.1.tar.gz) = d1765009e068b8cc5e76957e5d6be45ce6cff08c4aad8e5995e84a28354385f1
+SIZE (GeographicLib/GeographicLib-1.50.1.tar.gz) = 2463854
SHA256 (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = bdb382d0be7ece9142450eacc24b7b7f0889ee3e0ba4f535b04ec383f94c0fb5
SIZE (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = 162388303
SHA256 (GeographicLib/geoids-distrib/egm2008-2_5.tar.bz2) = d602e13446a4a4a23f39aecfe6a2a0760a1bc6c1b497482c2ebc9f7d513be699
@@ -41,3 +41,5 @@ SHA256 (GeographicLib/magnetic-distrib/wmm2015.tar.bz2) = 4c3fddb09955bbb556a955
SIZE (GeographicLib/magnetic-distrib/wmm2015.tar.bz2) = 1425
SHA256 (GeographicLib/magnetic-distrib/wmm2015v2.tar.bz2) = fda5e84ee803644c8695637f66ca2b278657633de6f83573eb988713d643a419
SIZE (GeographicLib/magnetic-distrib/wmm2015v2.tar.bz2) = 1448
+SHA256 (GeographicLib/magnetic-distrib/wmm2020.tar.bz2) = 0a33e726b88f9aac390d5a64ba2b4e5aa4533dd98699955bc9f23278df3b5a52
+SIZE (GeographicLib/magnetic-distrib/wmm2020.tar.bz2) = 1434
diff --git a/astro/geographiclib/files/patch-CMakeLists.txt b/astro/geographiclib/files/patch-CMakeLists.txt
index 724d7726eeb0..37180d92a20e 100644
--- a/astro/geographiclib/files/patch-CMakeLists.txt
+++ b/astro/geographiclib/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2019-09-24 12:55:55 UTC
+--- CMakeLists.txt.orig 2019-12-12 10:51:35 UTC
+++ CMakeLists.txt
@@ -183,6 +183,11 @@ option (APPLE_MULTIPLE_ARCHITECTURES
# directory is present you get this behavior regardless.
@@ -12,7 +12,7 @@
set (LIBNAME Geographic)
if (MSVC OR CMAKE_CONFIGURATION_TYPES)
# For multi-config systems and for Visual Studio, the debug version of
-@@ -475,7 +480,7 @@ endif ()
+@@ -464,7 +469,7 @@ endif ()
# documentation files into the source tree. Skip Apple here because
# man/makeusage.sh uses "head --lines -4" to drop the last 4 lines of a
# file and there's no simple equivalent for MacOSX
diff --git a/astro/geographiclib/pkg-descr b/astro/geographiclib/pkg-descr
index 0e6aa5579d34..b6580011840e 100644
--- a/astro/geographiclib/pkg-descr
+++ b/astro/geographiclib/pkg-descr
@@ -1,10 +1,8 @@
GeographicLib is a small set of C++ classes for performing conversions
between geographic, UTM, UPS, MGRS, geocentric, and local cartesian
coordinates, for gravity (e.g., EGM2008), geoid height, and geomagnetic
-field (e.g., WMM2010) calculations, and for solving geodesic problems.
+field (e.g., WMM2020) calculations, and for solving geodesic problems.
-The library may be used from .NET applications using the NETGeographicLib
-wrapper library. It is a suitable replacement for the core functionality
-provided by geotrans.
+It is a suitable replacement for the core functionality provided by geotrans.
-WWW: http://geographiclib.sourceforge.net/
+WWW: https://geographiclib.sourceforge.io/
diff --git a/astro/geographiclib/pkg-help b/astro/geographiclib/pkg-help
new file mode 100644
index 000000000000..cc52c49c89f1
--- /dev/null
+++ b/astro/geographiclib/pkg-help
@@ -0,0 +1,43 @@
+Geoid datasets used by the GeographicLib::Geoid class and the GeoidEval
+tool to compute geoid heights.
+
+ Available geoid data files
+ size (MB)
+ name geoid grid tar.bz2 disk
+ egm84-30 EGM84 30' 0.5 0.6
+ egm84-15 EGM84 15' 1.5 2.1
+ egm96-15 EGM96 15' 1.5 2.1
+ egm96-5 EGM96 5' 11 19
+ egm2008-5 EGM2008 5' 11 19
+ egm2008-2_5 EGM2008 2.5' 35 75
+ egm2008-1 EGM2008 1' 170 470
+
+Gravity models used by the GeographicLib::GravityModel class and the
+Gravity tool to compute gravity fields.
+
+ Available gravity models
+ size (kB)
+ name degree tar.bz2 disk
+ egm84 18 27 26
+ egm96 360 2100 2100
+ egm2008 2190 76000 75000
+ wgs84 20 1 1
+ grs80 20 1 1
+
+Magnetic models used by the GeographicLib::MagneticModel class and the
+MagneticField tool to compute magnetic fields.
+
+ Available magnetic models
+ size (kB)
+ name degree years tar.bz2 disk
+ wmm2010 12 2010-2015 2 3
+ wmm2015 12 2015-2020 2 3 *deprecated*
+ wmm2015v2 12 2015-2020 2 3
+ wmm2020 12 2020-2025 2 3
+ igrf11 13 1900-2015 7 25
+ igrf12 13 1900-2020 7 26
+ emm2010 739 2010-2015 3700 4400
+ emm2015 729 2000-2020 660 4300
+ emm2017 790 2000-2022 1740 5050
+
+The size columns give the download and installed sizes of the datasets.
diff --git a/astro/geographiclib/pkg-plist b/astro/geographiclib/pkg-plist
index f3b81d1f3e68..e758216b6f43 100644
--- a/astro/geographiclib/pkg-plist
+++ b/astro/geographiclib/pkg-plist
@@ -61,7 +61,7 @@ lib/cmake/GeographicLib/geographiclib-targets.cmake
lib/libGeographic.a
lib/libGeographic.so
lib/libGeographic.so.19
-lib/libGeographic.so.19.0.0
+lib/libGeographic.so.19.0.1
lib/node_modules/geographiclib/LICENSE.txt
lib/node_modules/geographiclib/README.md
lib/node_modules/geographiclib/geographiclib.js
@@ -148,6 +148,8 @@ sbin/geographiclib-get-magnetic
%%MAGNETIC_WMM2015%%%%DATADIR%%/magnetic/wmm2015.wmm.cof
%%MAGNETIC_WMM2015V2%%%%DATADIR%%/magnetic/wmm2015v2.wmm
%%MAGNETIC_WMM2015V2%%%%DATADIR%%/magnetic/wmm2015v2.wmm.cof
+%%MAGNETIC_WMM2020%%%%DATADIR%%/magnetic/wmm2020.wmm
+%%MAGNETIC_WMM2020%%%%DATADIR%%/magnetic/wmm2020.wmm.cof
share/matlab/geographiclib-legacy/Contents.m
share/matlab/geographiclib-legacy/geocentricforward.m
share/matlab/geographiclib-legacy/geocentricreverse.m