aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-05-20 01:01:17 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-05-20 01:01:17 +0000
commit9c9850897ab8c606cdfba3dd4abab247da4518e1 (patch)
tree1576f4ce200ad23bf557008075442ebb5a8e441a /astro
parenteff8393c6c8996e87ccf0de7b4e94fc72e59e936 (diff)
downloadports-9c9850897ab8c606cdfba3dd4abab247da4518e1.tar.gz
ports-9c9850897ab8c606cdfba3dd4abab247da4518e1.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/gpsdrive/Makefile32
-rw-r--r--astro/gpsdrive/distinfo1
-rw-r--r--astro/gpsdrive/files/patch-ltmain.sh35
-rw-r--r--astro/gpsdrive/files/patch-src::Makefile.in31
-rw-r--r--astro/gpsdrive/pkg-comment1
-rw-r--r--astro/gpsdrive/pkg-descr12
-rw-r--r--astro/gpsdrive/pkg-plist31
8 files changed, 144 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index b6918db79713..4b1e094836fd 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -10,6 +10,7 @@
SUBDIR += gkrellmoon
SUBDIR += gkrellmseti
SUBDIR += glunarclock
+ SUBDIR += gpsdrive
SUBDIR += gpsman
SUBDIR += jday
SUBDIR += ksetispy
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
new file mode 100644
index 000000000000..14d566417c14
--- /dev/null
+++ b/astro/gpsdrive/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gpsdrive
+# Date Created: 16 April 2002
+# Whom: Marco Molteni <molter@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpsdrive
+PORTVERSION= 1.20.r1
+CATEGORIES= astro
+MASTER_SITES= http://www.kraftvoll.at/software/ \
+ http://ganter.quant-x.at/software/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/pre/}
+
+MAINTAINER= molter@gufi.org
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+USE_GLIB= yes
+USE_GMAKE= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
+
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+INSTALLS_SHLIB= yes
+
+MAN1= gpsdrive.1
+MANLANG= "" de es
+
+.include <bsd.port.mk>
diff --git a/astro/gpsdrive/distinfo b/astro/gpsdrive/distinfo
new file mode 100644
index 000000000000..7129910abd36
--- /dev/null
+++ b/astro/gpsdrive/distinfo
@@ -0,0 +1 @@
+MD5 (gpsdrive-1.20pre1.tar.gz) = a66ff1b6b12dd534ad91bb7ccb2b1316
diff --git a/astro/gpsdrive/files/patch-ltmain.sh b/astro/gpsdrive/files/patch-ltmain.sh
new file mode 100644
index 000000000000..7d378834222d
--- /dev/null
+++ b/astro/gpsdrive/files/patch-ltmain.sh
@@ -0,0 +1,35 @@
+$FreeBSD$
+
+--- ltmain.sh.orig Wed Sep 26 23:26:27 2001
++++ ltmain.sh Sat Nov 17 08:35:28 2001
+@@ -1043,7 +1043,7 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ test "X$arg" = "X-lc" && continue
+ ;;
+@@ -2441,7 +2441,7 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
+ *)
+@@ -4210,10 +4210,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/astro/gpsdrive/files/patch-src::Makefile.in b/astro/gpsdrive/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..617d3ddde6de
--- /dev/null
+++ b/astro/gpsdrive/files/patch-src::Makefile.in
@@ -0,0 +1,31 @@
+$FreeBSD$
+
+--- src/Makefile.in.orig Mon Apr 29 15:47:49 2002
++++ src/Makefile.in Tue Apr 30 17:23:55 2002
+@@ -120,7 +120,7 @@
+ bin_PROGRAMS = $(PRG1) gpsdrive gpsd friendsd
+
+ # gpsdrive_LDADD= $(GLIB_LIBS) $(GTK_LIBS) $(PIXLIBS)
+-gpsdrive_LDADD = @LIBS@
++gpsdrive_LDADD = @LIBS@ -lgnugetopt
+ # gpsdrive_CFLAGS=@CFLAGS@
+ # libgpsd_a_CFLAGS=@CFLAGS@
+ # CFLAGS=
+@@ -172,7 +172,7 @@
+
+ am_friendsd_OBJECTS = friendsd.$(OBJEXT)
+ friendsd_OBJECTS = $(am_friendsd_OBJECTS)
+-friendsd_LDADD = $(LDADD)
++friendsd_LDADD = $(LDADD) -lintl
+ friendsd_DEPENDENCIES =
+ friendsd_LDFLAGS =
+ @DISABLEGARMIN_TRUE@am_garble_OBJECTS =
+@@ -182,7 +182,7 @@
+ @DISABLEGARMIN_FALSE@ garmin_link.$(OBJEXT) \
+ @DISABLEGARMIN_FALSE@ garmin_util.$(OBJEXT)
+ garble_OBJECTS = $(am_garble_OBJECTS)
+-garble_LDADD = $(LDADD)
++garble_LDADD = $(LDADD) -lgnugetopt
+ garble_DEPENDENCIES =
+ garble_LDFLAGS =
+ am_gpsd_OBJECTS = gpsd.$(OBJEXT)
diff --git a/astro/gpsdrive/pkg-comment b/astro/gpsdrive/pkg-comment
new file mode 100644
index 000000000000..e456dd7c0118
--- /dev/null
+++ b/astro/gpsdrive/pkg-comment
@@ -0,0 +1 @@
+A GPS navigation system
diff --git a/astro/gpsdrive/pkg-descr b/astro/gpsdrive/pkg-descr
new file mode 100644
index 000000000000..539ae6cc59ae
--- /dev/null
+++ b/astro/gpsdrive/pkg-descr
@@ -0,0 +1,12 @@
+GpsDrive is a car (bike, ship, plane) navigation system.
+
+GpsDrive displays the position provided from a Garmin or NMEA-capable GPS
+receiver on a zoomable map. The map file is autoselected depending on
+the position and prefered scale. Speech output is supported if the "festival"
+software is running. GpsDrive is written in C with use of the GTK+ graphic
+toolkit.
+
+WWW: http://ganter.quant-x.at/software/
+
+- Marco
+molter@gufi.org
diff --git a/astro/gpsdrive/pkg-plist b/astro/gpsdrive/pkg-plist
new file mode 100644
index 000000000000..12b7e8f3fe5b
--- /dev/null
+++ b/astro/gpsdrive/pkg-plist
@@ -0,0 +1,31 @@
+bin/friendsd
+bin/garble
+bin/gpsd
+bin/gpsdrive
+bin/gpsfetchmap
+bin/wpcvt
+bin/wpget
+lib/libfly.a
+lib/libfly.so
+lib/libfly.so.1
+share/gpsdrive/friendsicon.png
+share/gpsdrive/gpsdrive/AUTHORS
+share/gpsdrive/gpsdrive/GPS-receivers
+share/gpsdrive/gpsdrive/LEEME
+share/gpsdrive/gpsdrive/README
+share/gpsdrive/gpsdrive/TODO
+share/gpsdrive/gpsdrivesplash.png
+share/locale/da/LC_MESSAGES/gpsdrive.mo
+share/locale/de/LC_MESSAGES/gpsdrive.mo
+share/locale/de_AT/LC_MESSAGES/gpsdrive.mo
+share/locale/es/LC_MESSAGES/gpsdrive.mo
+share/locale/fr/LC_MESSAGES/gpsdrive.mo
+share/locale/hu/LC_MESSAGES/gpsdrive.mo
+share/locale/it/LC_MESSAGES/gpsdrive.mo
+share/locale/nl/LC_MESSAGES/gpsdrive.mo
+share/locale/pt/LC_MESSAGES/gpsdrive.mo
+share/locale/ru/LC_MESSAGES/gpsdrive.mo
+share/locale/tr/LC_MESSAGES/gpsdrive.mo
+share/locale/xx/LC_MESSAGES/gpsdrive.mo
+@dirrm share/gpsdrive/gpsdrive
+@dirrm share/gpsdrive