aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-15 11:50:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-15 11:50:11 +0000
commit128fed465e8d3695967ab04aeef3e5f1628d96cf (patch)
tree26c9ce9b673f71281ebebd44733c23203a942f5e /astro
parent1c420caa1be75c72809b5ba9ce30335b6e560d97 (diff)
downloadports-128fed465e8d3695967ab04aeef3e5f1628d96cf.tar.gz
ports-128fed465e8d3695967ab04aeef3e5f1628d96cf.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/boinc-einsteinathome/Makefile55
-rw-r--r--astro/boinc-einsteinathome/distinfo3
-rw-r--r--astro/boinc-einsteinathome/pkg-descr19
-rw-r--r--astro/boinc-einsteinathome/pkg-message14
-rw-r--r--astro/boinc-einsteinathome/pkg-plist4
6 files changed, 96 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 40f6dd224d06..5b4d9c20e59e 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -4,6 +4,7 @@
COMMENT = Astronomical ports
SUBDIR += accrete
+ SUBDIR += boinc-einsteinathome
SUBDIR += boinc-setiathome
SUBDIR += celestia
SUBDIR += cfitsio
diff --git a/astro/boinc-einsteinathome/Makefile b/astro/boinc-einsteinathome/Makefile
new file mode 100644
index 000000000000..8d52cabff1d0
--- /dev/null
+++ b/astro/boinc-einsteinathome/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: boinc-einsteinathome
+# Date created: 20 February 2006
+# Whom: Rene Ladan <r.c.ladan@student.tue.nl>
+# $FreeBSD$
+#
+
+PORTNAME= boinc-einsteinathome
+PORTVERSION= 0.40
+CATEGORIES= astro
+MASTER_SITES= http://einstein.phys.uwm.edu/app_test/FreeBSD/
+DISTNAME= albert_${PORTVERSION}_i386-unknown-freebsd
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= r.c.ladan@student.tue.nl
+COMMENT= Einstein@Home for BOINC
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386 amd64
+# Binary is built on 4.9 :
+.if ${OSVERSION} >= 500000
+.if ${ARCH} == "amd64"
+RUN_DEPENDS+= compat4x-i386>0:${PORTSDIR}/misc/compat4x
+.else
+LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
+.endif
+# also depends on libm.so.2
+.endif
+
+RUN_DEPENDS+= boinc_client:${PORTSDIR}/net/boinc-client
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
+BOINC_USER?= boinc
+BOINC_GROUP?= nobody
+BOINC_HOME?= /var/db/boinc
+
+EINSTEIN_SITE= einstein.phys.uwm.edu
+EINSTEIN_BINARY=${DISTNAME}
+
+PLIST_SUB= EINSTEIN_BINARY="${EINSTEIN_BINARY}" EINSTEIN_SITE=${EINSTEIN_SITE} \
+ BOINC_HOME=${BOINC_HOME}
+
+do-install:
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${EINSTEIN_SITE}
+ ${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/projects/${EINSTEIN_SITE}/app_info.xml ${BOINC_HOME}/projects/${EINSTEIN_SITE}
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKSRC}/projects/${EINSTEIN_SITE}/${EINSTEIN_BINARY} ${BOINC_HOME}/projects/${EINSTEIN_SITE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/astro/boinc-einsteinathome/distinfo b/astro/boinc-einsteinathome/distinfo
new file mode 100644
index 000000000000..43b397f441f5
--- /dev/null
+++ b/astro/boinc-einsteinathome/distinfo
@@ -0,0 +1,3 @@
+MD5 (albert_0.40_i386-unknown-freebsd.tgz) = ba2e87d5c3a4c3c04c2f3df4cf4ad84a
+SHA256 (albert_0.40_i386-unknown-freebsd.tgz) = 5f910c5e41ab8eac23e808ee627ed26d63e6672c34a5979dbd3edb7c6ce464ed
+SIZE (albert_0.40_i386-unknown-freebsd.tgz) = 446520
diff --git a/astro/boinc-einsteinathome/pkg-descr b/astro/boinc-einsteinathome/pkg-descr
new file mode 100644
index 000000000000..b0667502203e
--- /dev/null
+++ b/astro/boinc-einsteinathome/pkg-descr
@@ -0,0 +1,19 @@
+Einstein@Home - Search for gravitational waves
+
+Use your unused CPU cycles to aid in computations analyzing telescope
+information for possible gravitational waves emitted by pulsars as
+predicted by Albert Einstein.
+
+Einstein@home is based on BOINC (Berkeley Open Infrastructure for
+Network Computing). Several other projects besides Einstein@home are
+using BOINC. BOINC lets you participate in more than one project,
+and it lets you specify what fraction of your computer time should go
+to each project.
+
+Be sure to join the "FreeBSD" team on the Einstein website once you're
+up and running.
+
+The FreeBSD version of this client is currently in its beta-testing
+phase.
+
+WWW: http://einstein.phys.uwm.edu/
diff --git a/astro/boinc-einsteinathome/pkg-message b/astro/boinc-einsteinathome/pkg-message
new file mode 100644
index 000000000000..0d5e7fc396f9
--- /dev/null
+++ b/astro/boinc-einsteinathome/pkg-message
@@ -0,0 +1,14 @@
+ATTACHING PROJECT
+
+Just run boinc_gui, choose Attach, and follow instructions.
+Project URL is einstein.phys.uwm.edu
+
+MANUAL INSTALLATION
+ *) If this is your first time in any BOINC project, create a new account at
+ http://einstein.phys.uwm.edu/create_account_form.php
+
+ *) Or get your account key at http://einstein.phys.uwm.edu/get_passwd.php
+
+ *) Attach to the project:
+ cd /var/db/boinc
+ boinc_cmd --project_attach einstein.phys.uwm.edu <account key>
diff --git a/astro/boinc-einsteinathome/pkg-plist b/astro/boinc-einsteinathome/pkg-plist
new file mode 100644
index 000000000000..96588102ea5c
--- /dev/null
+++ b/astro/boinc-einsteinathome/pkg-plist
@@ -0,0 +1,4 @@
+@cwd %%BOINC_HOME%%
+projects/%%EINSTEIN_SITE%%/app_info.xml
+projects/%%EINSTEIN_SITE%%/%%EINSTEIN_BINARY%%
+@unexec rmdir %D/projects/%%EINSTEIN_SITE%% 2>/dev/null || true