aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-06-03 09:24:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-06-03 09:24:44 +0000
commitc95b8160a979735548f245eb5e2652771d90ea1a (patch)
tree38199bb1b6e575f614d8c42a29ef27803620849d /astro
parent2b8b912ab37d9aa79e310815dbc36c48ecf1ff9b (diff)
downloadports-c95b8160a979735548f245eb5e2652771d90ea1a.tar.gz
ports-c95b8160a979735548f245eb5e2652771d90ea1a.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/foxtrotgps/Makefile9
-rw-r--r--astro/foxtrotgps/distinfo4
-rw-r--r--astro/foxtrotgps/files/patch-src-gps_functions.c94
-rw-r--r--astro/foxtrotgps/pkg-plist1
4 files changed, 9 insertions, 99 deletions
diff --git a/astro/foxtrotgps/Makefile b/astro/foxtrotgps/Makefile
index db8a9eebfdbb..0600f5208f01 100644
--- a/astro/foxtrotgps/Makefile
+++ b/astro/foxtrotgps/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: foxtrotgps
# Date created: 15 January 2011
-# Whom: crwhipp
+# Whom: crwhipp@gmail.com
#
# $FreeBSD$
#
PORTNAME= foxtrotgps
-PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTVERSION= 1.0.1
CATEGORIES= astro geography
MASTER_SITES= http://www.foxtrotgps.org/releases/
@@ -31,4 +30,8 @@ INSTALLS_ICONS= yes
MAN1= foxtrotgps.1 convert2gpx.1 convert2osm.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/contrib/convert2gpx ${WRKSRC}/contrib/convert2osm
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${LOCALBASE}/bin/python|' ${WRKSRC}/contrib/georss2foxtrotgps-poi
+
.include <bsd.port.mk>
diff --git a/astro/foxtrotgps/distinfo b/astro/foxtrotgps/distinfo
index 8df7f9060f9d..0334d7cf3c6e 100644
--- a/astro/foxtrotgps/distinfo
+++ b/astro/foxtrotgps/distinfo
@@ -1,2 +1,2 @@
-SHA256 (foxtrotgps-1.0.0.tar.gz) = 24f789294ae4f4251adccdb5f0c677b3fd6dea9bce2b6a17497f87a0dc3d056a
-SIZE (foxtrotgps-1.0.0.tar.gz) = 521774
+SHA256 (foxtrotgps-1.0.1.tar.gz) = 059158fd8e61137e2e6d6e01685add7fb85cce8483faa99efb01187f2ba50841
+SIZE (foxtrotgps-1.0.1.tar.gz) = 489427
diff --git a/astro/foxtrotgps/files/patch-src-gps_functions.c b/astro/foxtrotgps/files/patch-src-gps_functions.c
deleted file mode 100644
index 8af3e957381c..000000000000
--- a/astro/foxtrotgps/files/patch-src-gps_functions.c
+++ /dev/null
@@ -1,94 +0,0 @@
---- src/gps_functions.c.orig 2011-03-22 21:11:33.000000000 +0300
-+++ src/gps_functions.c 2011-03-22 21:58:20.000000000 +0300
-@@ -31,7 +31,8 @@
-
-
- static GIOChannel *gpsd_io_channel =NULL;
--static struct gps_data_t *libgps_gpsdata = NULL;
-+static struct gps_data_t libgps_gpsdata;
-+static int libgps_initialized = 0;
-
- static guint sid1, sid3;
- guint watchdog;
-@@ -699,9 +700,7 @@
- gpsdata = NULL;
- g_source_remove(sid1);
- g_source_remove(sid3);
-- gps_close(libgps_gpsdata);
-- libgps_gpsdata = NULL;
--
-+ gps_close(&libgps_gpsdata);
-
- return FALSE;
- }
-@@ -713,28 +712,28 @@
- {
- int ret;
-
-- if (libgps_gpsdata == NULL)
-+ if (libgps_initialized == 0)
- return FALSE;
-
-- ret = gps_poll(libgps_gpsdata);
-- if (ret == 0)
-+ ret = gps_read(&libgps_gpsdata);
-+ if (ret > 0)
- {
-- gpsdata->satellites_used = libgps_gpsdata->satellites_used;
-- gpsdata->hdop = libgps_gpsdata->dop.hdop;
-- gpsdata->fix.time = libgps_gpsdata->fix.time;
-+ gpsdata->satellites_used = libgps_gpsdata.satellites_used;
-+ gpsdata->hdop = libgps_gpsdata.dop.hdop;
-+ gpsdata->fix.time = libgps_gpsdata.fix.time;
- if (isnan(gpsdata->fix.time))
- {
- gpsdata->fix.time = (time_t) 0;
- }
-- gpsdata->valid = (libgps_gpsdata->status != STATUS_NO_FIX);
-+ gpsdata->valid = (libgps_gpsdata.status != STATUS_NO_FIX);
- if (gpsdata->valid)
- {
- gpsdata->seen_vaild = TRUE;
-- gpsdata->fix.latitude = libgps_gpsdata->fix.latitude;
-- gpsdata->fix.longitude = libgps_gpsdata->fix.longitude;
-- gpsdata->fix.speed = libgps_gpsdata->fix.speed;
-- gpsdata->fix.heading = libgps_gpsdata->fix.track;
-- gpsdata->fix.altitude = libgps_gpsdata->fix.altitude;
-+ gpsdata->fix.latitude = libgps_gpsdata.fix.latitude;
-+ gpsdata->fix.longitude = libgps_gpsdata.fix.longitude;
-+ gpsdata->fix.speed = libgps_gpsdata.fix.speed;
-+ gpsdata->fix.heading = libgps_gpsdata.fix.track;
-+ gpsdata->fix.altitude = libgps_gpsdata.fix.altitude;
- }
-
- g_source_remove(watchdog);
-@@ -758,11 +757,11 @@
- void *
- get_gps_thread(void *ptr)
- {
-- libgps_gpsdata = gps_open(global_server, global_port);
-- if (libgps_gpsdata)
-+ if (gps_open(global_server, global_port, &libgps_gpsdata) == 0)
- {
- fprintf(stderr, "connection to gpsd SUCCEEDED \n");
--
-+
-+ libgps_initialized = 1;
- global_reconnect_gpsd = FALSE;
-
- if(!gpsdata)
-@@ -771,12 +770,12 @@
- }
-
-
-- gps_stream(libgps_gpsdata, WATCH_ENABLE | POLL_NONBLOCK, NULL);
-+ gps_stream(&libgps_gpsdata, WATCH_ENABLE, NULL);
-
- watchdog = g_timeout_add_seconds_full(G_PRIORITY_DEFAULT_IDLE,60,reset_gpsd_io,NULL,NULL);
-
-
-- gpsd_io_channel = g_io_channel_unix_new(libgps_gpsdata->gps_fd);
-+ gpsd_io_channel = g_io_channel_unix_new(libgps_gpsdata.gps_fd);
- g_io_channel_set_flags(gpsd_io_channel, G_IO_FLAG_NONBLOCK, NULL);
-
-
diff --git a/astro/foxtrotgps/pkg-plist b/astro/foxtrotgps/pkg-plist
index fc32fbdb81c8..262169bdf4c8 100644
--- a/astro/foxtrotgps/pkg-plist
+++ b/astro/foxtrotgps/pkg-plist
@@ -16,6 +16,7 @@ share/applications/foxtrotgps.desktop
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/HACKING
%%DOCSDIR%%/INSTALL
%%DOCSDIR%%/NEWS
%%DOCSDIR%%/README