aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-26 14:14:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-26 14:14:15 +0000
commitf2da1aef09d2c938817d0c708bed1d93d65262f6 (patch)
tree6a82e6ef3c971c50b5b96344b45ddfd5dc89a103 /astro
parente0dcc02b642bb43a3d8cb847cfc9469684367338 (diff)
downloadports-f2da1aef09d2c938817d0c708bed1d93d65262f6.tar.gz
ports-f2da1aef09d2c938817d0c708bed1d93d65262f6.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-astLib/Makefile31
-rw-r--r--astro/py-astLib/distinfo3
-rw-r--r--astro/py-astLib/pkg-descr8
-rw-r--r--astro/py-astLib/pkg-plist39
5 files changed, 82 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 9dbeff7f88a3..b391b47be8ec 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -58,6 +58,7 @@
SUBDIR += pp3
SUBDIR += ptiger
SUBDIR += py-aipy
+ SUBDIR += py-astLib
SUBDIR += py-metar
SUBDIR += py-pyfits
SUBDIR += pyephem
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
new file mode 100644
index 000000000000..8d175395863e
--- /dev/null
+++ b/astro/py-astLib/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-astLib
+# Date created: 23 March, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= astLib
+PORTVERSION= 0.3.0
+CATEGORIES= astro python
+MASTER_SITES= SF
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A set of python astonomy modules
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PKGNAMEPREFIX}scipy>=0.7.0:${PORTSDIR}/science/py-scipy \
+ ${PKGNAMEPREFIX}imaging>=1.1.6:${PORTSDIR}/graphics/py-imaging \
+ ${PKGNAMEPREFIX}pyfits>=1.1:${PORTSDIR}/astro/py-pyfits \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PKGNAMEPREFIX}scipy>=0.7.0:${PORTSDIR}/science/py-scipy \
+ ${PKGNAMEPREFIX}imaging>=1.1.6:${PORTSDIR}/graphics/py-imaging \
+ ${PKGNAMEPREFIX}pyfits>=1.1:${PORTSDIR}/astro/py-pyfits \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/astro/py-astLib/distinfo b/astro/py-astLib/distinfo
new file mode 100644
index 000000000000..2294fd2f894f
--- /dev/null
+++ b/astro/py-astLib/distinfo
@@ -0,0 +1,3 @@
+MD5 (astLib-0.3.0.tar.gz) = 216b7c4d2ba9be8d2ee5338a3dd6132f
+SHA256 (astLib-0.3.0.tar.gz) = 749b998a69321dfb4c57ab774c42cf4150a771869f8580aca3e11b2606b1d56d
+SIZE (astLib-0.3.0.tar.gz) = 943386
diff --git a/astro/py-astLib/pkg-descr b/astro/py-astLib/pkg-descr
new file mode 100644
index 000000000000..51028fd112c4
--- /dev/null
+++ b/astro/py-astLib/pkg-descr
@@ -0,0 +1,8 @@
+astLib is a set of Python modules that provides some tools for research
+astronomers. It can be used for astronomical plots, some statistics,
+common calculations, coordinate conversions, and manipulating FITS images
+with World Coordinate System (WCS) information through PyWCSTools - a
+simple wrapping of WCSTools by Doug Mink. PyWCSTools is distributed (and
+developed) as part of astLib.
+
+WWW: http://astlib.sourceforge.net
diff --git a/astro/py-astLib/pkg-plist b/astro/py-astLib/pkg-plist
new file mode 100644
index 000000000000..db8ae780b8c0
--- /dev/null
+++ b/astro/py-astLib/pkg-plist
@@ -0,0 +1,39 @@
+%%PYTHON_SITELIBDIR%%/astLib/__init__.py
+%%PYTHON_SITELIBDIR%%/astLib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/astLib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/astLib/astCalc.py
+%%PYTHON_SITELIBDIR%%/astLib/astCalc.pyc
+%%PYTHON_SITELIBDIR%%/astLib/astCalc.pyo
+%%PYTHON_SITELIBDIR%%/astLib/astCoords.py
+%%PYTHON_SITELIBDIR%%/astLib/astCoords.pyc
+%%PYTHON_SITELIBDIR%%/astLib/astCoords.pyo
+%%PYTHON_SITELIBDIR%%/astLib/astImages.py
+%%PYTHON_SITELIBDIR%%/astLib/astImages.pyc
+%%PYTHON_SITELIBDIR%%/astLib/astImages.pyo
+%%PYTHON_SITELIBDIR%%/astLib/astPlots.py
+%%PYTHON_SITELIBDIR%%/astLib/astPlots.pyc
+%%PYTHON_SITELIBDIR%%/astLib/astPlots.pyo
+%%PYTHON_SITELIBDIR%%/astLib/astSED.py
+%%PYTHON_SITELIBDIR%%/astLib/astSED.pyc
+%%PYTHON_SITELIBDIR%%/astLib/astSED.pyo
+%%PYTHON_SITELIBDIR%%/astLib/astStats.py
+%%PYTHON_SITELIBDIR%%/astLib/astStats.pyc
+%%PYTHON_SITELIBDIR%%/astLib/astStats.pyo
+%%PYTHON_SITELIBDIR%%/astLib/astWCS.py
+%%PYTHON_SITELIBDIR%%/astLib/astWCS.pyc
+%%PYTHON_SITELIBDIR%%/astLib/astWCS.pyo
+%%PYTHON_SITELIBDIR%%/astLib/data/bohlin2006_Vega.sed
+%%PYTHON_SITELIBDIR%%/PyWCSTools/__init__.py
+%%PYTHON_SITELIBDIR%%/PyWCSTools/__init__.pyc
+%%PYTHON_SITELIBDIR%%/PyWCSTools/__init__.pyo
+%%PYTHON_SITELIBDIR%%/PyWCSTools/wcscon.py
+%%PYTHON_SITELIBDIR%%/PyWCSTools/wcscon.pyc
+%%PYTHON_SITELIBDIR%%/PyWCSTools/wcscon.pyo
+%%PYTHON_SITELIBDIR%%/PyWCSTools/wcs.py
+%%PYTHON_SITELIBDIR%%/PyWCSTools/wcs.pyc
+%%PYTHON_SITELIBDIR%%/PyWCSTools/wcs.pyo
+%%PYTHON_SITELIBDIR%%/PyWCSTools/_wcscon.so
+%%PYTHON_SITELIBDIR%%/PyWCSTools/_wcs.so
+@dirrm %%PYTHON_SITELIBDIR%%/astLib/data
+@dirrm %%PYTHON_SITELIBDIR%%/astLib
+@dirrm %%PYTHON_SITELIBDIR%%/PyWCSTools