aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-05-27 09:37:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-05-27 09:37:18 +0000
commit4d712deef8d607a3f85b580b222f21c6b7d6dc94 (patch)
tree7a16e20949cc94baeee42b9e4f02c07e342ab72f /astro
parent4df4d851fa2b8f181c42f44a6335f7b96cf34b65 (diff)
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/weather/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index 536bbaf340b6..0a97a9ae2055 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -17,6 +17,8 @@ USES= python shebangfix tar:xz
PLIST_FILES= bin/${PORTNAME} \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.py \
+ %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyc \
+ %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyo \
man/man1/${PORTNAME}.1.gz \
man/man5/${PORTNAME}rc.5.gz
PORTDATA= airports places stations zctas zones
@@ -35,9 +37,6 @@ PYCACHE_DIR= __pycache__/
PYCACHE_FILE= ${PORTNAME}.cpython-${PYTHON_SUFFIX}
.endif
-PLIST_FILES+= %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyc \
- %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyo
-
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}/${PORTNAME}.py
@${PYTHON_CMD} -O -m compileall ${WRKSRC}/${PORTNAME}.py