aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-01-14 10:15:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-01-14 10:15:06 +0000
commit7c87e398999f29e2494c9854bc559efdf5b1458c (patch)
tree0f05ae42fa079d2fe4e4a9825d007bfe919aec01 /astro
parent537ebf43d0a7c0156b624cde253af0ca4aaf2017 (diff)
downloadports-7c87e398999f29e2494c9854bc559efdf5b1458c.tar.gz
ports-7c87e398999f29e2494c9854bc559efdf5b1458c.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/stellarium-qt4/Makefile4
-rw-r--r--astro/stellarium/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/astro/stellarium-qt4/Makefile b/astro/stellarium-qt4/Makefile
index 78492c92b9c8..9a080ae0dcd7 100644
--- a/astro/stellarium-qt4/Makefile
+++ b/astro/stellarium-qt4/Makefile
@@ -84,8 +84,8 @@ post-install:
existing=`${STAT} -qf '%z' \
${STAGEDIR}${DATADIR}/textures/$$f || \
${ECHO_CMD} 0` ; \
- ${TEST} $$new -gt $$existing && \
- ${ECHO_CMD} "-- Replacing texture: $$f\
+ ${TEST} $$new -gt $$existing || continue ; \
+ ${ECHO_CMD} "-- Replacing texture: $$f\
(has larger file size or missing)" ; \
${INSTALL_DATA} $$f ${STAGEDIR}${DATADIR}/textures ; \
done)
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index 4147c50787d5..158bd2d29546 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -64,8 +64,8 @@ post-install:
new=`${STAT} -f '%z' $$f` ; \
existing=`${STAT} -f '%z' \
${STAGEDIR}${DATADIR}/textures/$$f` ; \
- ${TEST} $$new -gt $$existing && \
- ${ECHO_CMD} "-- Replacing texture: $$f\
+ ${TEST} $$new -gt $$existing || continue ; \
+ ${ECHO_CMD} "-- Replacing texture: $$f\
(has larger file size)" ; \
${INSTALL_DATA} $$f ${STAGEDIR}${DATADIR}/textures ; \
done)