aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-18 03:20:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-18 03:20:55 +0000
commitb9e4fc9f4a2c1e7b7d1ff0c2f659017147996264 (patch)
tree1d1e33b2d1e4ce650a295d05d1ad841d47ab2936 /astro
parentea367d63953ae410db95f96fd30195c19149abac (diff)
downloadports-b9e4fc9f4a2c1e7b7d1ff0c2f659017147996264.tar.gz
ports-b9e4fc9f4a2c1e7b7d1ff0c2f659017147996264.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/mkgmap/Makefile37
-rw-r--r--astro/mkgmap/distinfo3
-rw-r--r--astro/mkgmap/pkg-descr5
4 files changed, 46 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index f4a9a711a1b9..2ea8057aa30e 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -37,6 +37,7 @@
SUBDIR += luna
SUBDIR += match
SUBDIR += merkaartor
+ SUBDIR += mkgmap
SUBDIR += mymoon
SUBDIR += nightfall
SUBDIR += nova
diff --git a/astro/mkgmap/Makefile b/astro/mkgmap/Makefile
new file mode 100644
index 000000000000..3b7ee05f1205
--- /dev/null
+++ b/astro/mkgmap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mkgmap
+# Date created: 17 May 2010
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mkgmap
+PORTVERSION= r1625
+CATEGORIES= astro java
+MASTER_SITES= http://www.mkgmap.org.uk/snapshots/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Convert OpenStreetMap data into a Garmin format
+
+NO_BUILD= yes
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+
+SUB_FILES= ${PORTNAME}.sh
+
+PLIST_FILES= bin/${PORTNAME} ${JAVAJARDIR:C,${PREFIX}/?,,}/${PORTNAME}.jar
+PORTDOCS= *
+
+do-install:
+ ${MKDIR} ${JAVAJARDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${JAVAJARDIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/mkgmap/distinfo b/astro/mkgmap/distinfo
new file mode 100644
index 000000000000..cdcad5ed1bf6
--- /dev/null
+++ b/astro/mkgmap/distinfo
@@ -0,0 +1,3 @@
+MD5 (mkgmap-r1625.tar.gz) = e09ddf4861f68bd335bd11fce54cbf48
+SHA256 (mkgmap-r1625.tar.gz) = c94ce2b789343f4e39df30021e26fec8976887ef1b549f86bf1d589488005640
+SIZE (mkgmap-r1625.tar.gz) = 2025810
diff --git a/astro/mkgmap/pkg-descr b/astro/mkgmap/pkg-descr
new file mode 100644
index 000000000000..7c682e7ac1ab
--- /dev/null
+++ b/astro/mkgmap/pkg-descr
@@ -0,0 +1,5 @@
+This program converts OpenStreetMap data into a map that can be
+loaded onto a Garmin GPS device. It does the conversion in one step
+without depending on any other program.
+
+WWW: http://wiki.openstreetmap.org/wiki/Mkgmap