aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-03-17 23:08:20 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-03-17 23:08:20 +0000
commit22801fbea2fc311159529a4e62d69a119068f5f9 (patch)
treef0b19fba28f63023321f29d487bba228cff480d6 /astro
parent309e12cc7f5758bfe36dc5e378b8da6df298a7c7 (diff)
downloadports-22801fbea2fc311159529a4e62d69a119068f5f9.tar.gz
ports-22801fbea2fc311159529a4e62d69a119068f5f9.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/celestia/Makefile67
-rw-r--r--astro/celestia/distinfo3
-rw-r--r--astro/celestia/files/patch-src::buildstardb.cpp29
-rw-r--r--astro/celestia/files/patch-src::celengine::starbrowser.h11
-rw-r--r--astro/celestia/files/patch-src::celestia::celestiacore.cpp39
-rw-r--r--astro/celestia/files/patch-src::celestia::celestiacore.h13
-rw-r--r--astro/celestia/files/patch-src_celestia_glutmain.cpp10
-rw-r--r--astro/celestia/files/patch-src_celestia_gtkmain.cpp36
8 files changed, 44 insertions, 164 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 181d6382495f..3e4e9c604d0c 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= celestia
-PORTVERSION= 1.2.4
-PORTREVISION= 1
+PORTVERSION= 1.3.1
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= celestia
@@ -17,28 +16,36 @@ COMMENT= Scriptable space flight simulator for X
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
+ png.5:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
+OPTIONS= KDE "KDE support" off
+OPTIONS+= LUA "Lua support" off
PLIST= ${WRKDIR}/pkg-plist
USE_REINPLACE= yes
USE_GMAKE= yes
USE_MESA= yes
USE_X_PREFIX= yes
-.if !defined(WITHOUT_GNOME)
-USE_GNOME= gnomelibs
-.endif
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --includedir="${LOCALBASE}/include" \
- --libdir="${LOCALBASE}/lib"
+# GTK+ support is deprecated and broken
+CONFIGURE_ARGS= --without-gtk
+
CONFIGURE_ENV= \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}" \
- CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/GL -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+ CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+
+.if defined(WITH_KDE)
+USE_KDELIBS_VER= 3
+CONFIGURE_ARGS+= --with-kde
+.else
+CONFIGURE_ARGS+= --without-kde
+.endif
-.if defined(WITHOUT_GNOME)
-CONFIGURE_ARGS+= --without-gtk
+.if defined(WITH_LUA)
+LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua
+CONFIGURE_ARGS+= --with-lua
+.else
+CONFIGURE_ARGS+= --without-lua
.endif
.include <bsd.port.pre.mk>
@@ -48,40 +55,40 @@ BROKEN= "Does not compile on !i386"
.endif
pre-patch:
- ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e \
's:-O2::g; s:-Wall::g; s:-ffast-math::g; s:-fexpensive-optimizations::g; s:! /bin/sh:! ${LOCALBASE}/bin/bash:g' \
${WRKSRC}/configure
pre-install:
- ${ECHO_CMD} bin/celestia > ${PLIST}
- ${FIND} ${WRKSRC}/data/ -name '*.???' | \
+ @${ECHO_CMD} bin/celestia > ${PLIST}
+ @${FIND} ${WRKSRC}/data/ -name '*.???' | \
${SED} -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
- ${FIND} ${WRKSRC}/extras/ -name '*.ssc' | \
+ @${FIND} ${WRKSRC}/extras/ -name '*.ssc' | \
${SED} -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
- ${FIND} ${WRKSRC}/fonts/ -name '*.txf' | \
+ @${FIND} ${WRKSRC}/fonts/ -name '*.txf' | \
${SED} -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
.for ii in celestia.cfg demo.cel guide.cel start.cel
- ${ECHO_CMD} share/celestia/${ii} >> ${PLIST}
+ @${ECHO_CMD} share/celestia/${ii} >> ${PLIST}
.endfor
.if !defined(NOPORTDOCS)
-.for ii in AUTHORS COPYING ChangeLog INSTALL README TODO controls.txt
- ${ECHO_CMD} share/doc/celestia/${ii} >> ${PLIST}
+.for ii in AUTHORS ChangeLog COPYING README TODO controls.txt
+ @${ECHO_CMD} share/doc/celestia/${ii} >> ${PLIST}
.endfor
- ${FIND} ${WRKSRC}/manual/ -name '*.???*' | \
+ @${FIND} ${WRKSRC}/manual/ -name '*.???*' | \
${SED} -e "s:^${WRKSRC}/:share/doc/celestia/:g" >> ${PLIST}
.for ii in celestia/manual celestia
- ${ECHO_CMD} @dirrm share/doc/${ii} >> ${PLIST}
+ @${ECHO_CMD} @dirrm share/doc/${ii} >> ${PLIST}
.endfor
.endif
- ${FIND} ${WRKSRC}/models/ -name '*.???' | \
+ @${FIND} ${WRKSRC}/models/ -name '*.???' | \
${SED} -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
- ${FIND} ${WRKSRC}/shaders/ -name '*.vp' | \
+ @${FIND} ${WRKSRC}/shaders/ -name '*.vp' | \
${SED} -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
- ${FIND} ${WRKSRC}/textures/ -name '*.jpg' -o -name '*.png'| \
+ @${FIND} ${WRKSRC}/textures/ -name '*.jpg' -o -name '*.png'| \
${SED} -e "s:^${WRKSRC}/:share/celestia/:g" >> ${PLIST}
.for ii in /data /extras /textures/lores /textures/medres /textures /models \
/shaders /fonts /
- ${ECHO_CMD} @dirrm share/celestia${ii} >> ${PLIST}
+ @${ECHO_CMD} @dirrm share/celestia${ii} >> ${PLIST}
.endfor
do-install:
@@ -98,15 +105,15 @@ do-install:
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/manual
-.for ii in AUTHORS COPYING ChangeLog INSTALL README TODO controls.txt
+.for ii in AUTHORS ChangeLog README TODO controls.txt
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}/
.endfor
${INSTALL_DATA} ${WRKSRC}/manual/*.???* ${DOCSDIR}/manual/
.endif
${INSTALL_DATA} ${WRKSRC}/models/*.??? ${DATADIR}/models/
${INSTALL_DATA} ${WRKSRC}/shaders/*.vp ${DATADIR}/shaders/
- ${INSTALL_DATA} ${WRKSRC}/textures/flare.jpg \
- ${WRKSRC}/textures/logo.png ${DATADIR}/textures/
+ ${INSTALL_DATA} ${WRKSRC}/textures/*.jpg \
+ ${WRKSRC}/textures/*.png ${DATADIR}/textures/
${INSTALL_DATA} ${WRKSRC}/textures/lores/*.??? \
${DATADIR}/textures/lores/
${INSTALL_DATA} ${WRKSRC}/textures/medres/*.??? \
diff --git a/astro/celestia/distinfo b/astro/celestia/distinfo
index 6578a9f89eee..ec9658220ba9 100644
--- a/astro/celestia/distinfo
+++ b/astro/celestia/distinfo
@@ -1,3 +1,2 @@
-$FreeBSD$
-MD5 (celestia-1.2.4.tar.gz) = 0378cd4507ebf4691c86a59c0825221b
+MD5 (celestia-1.3.1.tar.gz) = 6b5fd597e497b951228c83d4e756a340
SIZE (celestia-1.2.4.tar.gz) = 10280646
diff --git a/astro/celestia/files/patch-src::buildstardb.cpp b/astro/celestia/files/patch-src::buildstardb.cpp
deleted file mode 100644
index e775e24e2b3c..000000000000
--- a/astro/celestia/files/patch-src::buildstardb.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/buildstardb.cpp.orig Sat Aug 30 21:33:27 2003
-+++ src/buildstardb.cpp Sat Aug 30 21:34:05 2003
-@@ -921,7 +921,7 @@
- {
- MultistarSystem* multiSystem = new MultistarSystem();
- multiSystem->nStars = 1;
-- multiSystem->stars[0] = iter;
-+ multiSystem->stars[0] = &(*iter);
- starSystems.insert(MultistarSystemCatalog::value_type(iter->CCDMIdentifier, multiSystem));
- }
- else
-@@ -933,7 +933,7 @@
- }
- else
- {
-- multiSystem->stars[multiSystem->nStars] = iter;
-+ multiSystem->stars[multiSystem->nStars] = &(*iter);
- multiSystem->nStars++;
- }
- }
-@@ -1162,7 +1162,7 @@
- for (vector<HipparcosStar>::iterator iter = stars.begin();
- iter != stars.end(); iter++)
- {
-- starIndex.insert(starIndex.end(), iter);
-+ starIndex.insert(starIndex.end(), &(*iter));
- }
-
- HIPCatalogComparePredicate pred;
diff --git a/astro/celestia/files/patch-src::celengine::starbrowser.h b/astro/celestia/files/patch-src::celengine::starbrowser.h
deleted file mode 100644
index 2e89a544f187..000000000000
--- a/astro/celestia/files/patch-src::celengine::starbrowser.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/celengine/starbrowser.h.orig Sat Aug 30 20:38:54 2003
-+++ src/celengine/starbrowser.h Sat Aug 30 20:39:08 2003
-@@ -12,6 +12,8 @@
- #ifndef _CELENGINE_STARBROWSER_H_
- #define _CELENGINE_STARBROWSER_H_
-
-+using namespace std;
-+
- #include "star.h"
- #include "stardb.h"
- #include "simulation.h"
diff --git a/astro/celestia/files/patch-src::celestia::celestiacore.cpp b/astro/celestia/files/patch-src::celestia::celestiacore.cpp
deleted file mode 100644
index e001e090a83e..000000000000
--- a/astro/celestia/files/patch-src::celestia::celestiacore.cpp
+++ /dev/null
@@ -1,39 +0,0 @@
---- src/celestia/celestiacore.cpp.orig Thu May 2 10:53:49 2002
-+++ src/celestia/celestiacore.cpp Sat Aug 30 21:32:21 2003
-@@ -38,7 +38,6 @@
- #include "celestiacore.h"
- #include <celutil/debug.h>
-
--
- using namespace std;
-
- static const int DragThreshold = 3;
-@@ -194,7 +193,7 @@
- sim->setFrame(fav.coordSys, sim->getSelection());
- }
-
--void CelestiaCore::addFavorite(string name, string parentFolder, FavoritesList::const_iterator* iter)
-+void CelestiaCore::addFavorite(std::string name, std::string parentFolder, FavoritesList::iterator* iter)
- {
- FavoritesList::iterator pos;
- if(!iter)
-@@ -214,7 +213,7 @@
- favorites->insert(pos, fav);
- }
-
--void CelestiaCore::addFavoriteFolder(string name, FavoritesList::const_iterator* iter)
-+void CelestiaCore::addFavoriteFolder(std::string name, FavoritesList::iterator* iter)
- {
- FavoritesList::iterator pos;
- if(!iter)
-@@ -1138,8 +1137,8 @@
- {
- double distFromSun = body.getHeliocentricPosition(t).distanceFromOrigin();
- float planetTemp = sun->getTemperature() *
-- (float) (pow(1 - body.getAlbedo(), 0.25) *
-- sqrt(sun->getRadius() / (2 * distFromSun)));
-+ (float) (pow((float)(1 - body.getAlbedo()),(float)(( 0.25) *
-+ sqrt(sun->getRadius() / (2 * distFromSun)))));
- overlay << setprecision(0);
- overlay << "Temperature: " << planetTemp << " K\n";
- overlay << setprecision(3);
diff --git a/astro/celestia/files/patch-src::celestia::celestiacore.h b/astro/celestia/files/patch-src::celestia::celestiacore.h
deleted file mode 100644
index 1b2db493f15a..000000000000
--- a/astro/celestia/files/patch-src::celestia::celestiacore.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/celestia/celestiacore.h.orig Sat Aug 30 21:30:15 2003
-+++ src/celestia/celestiacore.h Sat Aug 30 21:30:40 2003
-@@ -126,8 +126,8 @@
- void readFavoritesFile();
- void writeFavoritesFile();
- void activateFavorite(FavoritesEntry&);
-- void addFavorite(std::string, std::string, FavoritesList::const_iterator* iter=NULL);
-- void addFavoriteFolder(std::string, FavoritesList::const_iterator* iter=NULL);
-+ void addFavorite(std::string, std::string, FavoritesList::iterator* iter=NULL);
-+ void addFavoriteFolder(std::string, FavoritesList::iterator* iter=NULL);
- const FavoritesList* getFavorites();
-
- const DestinationList* getDestinations();
diff --git a/astro/celestia/files/patch-src_celestia_glutmain.cpp b/astro/celestia/files/patch-src_celestia_glutmain.cpp
index 0df8dc68bc34..fa8ce5866360 100644
--- a/astro/celestia/files/patch-src_celestia_glutmain.cpp
+++ b/astro/celestia/files/patch-src_celestia_glutmain.cpp
@@ -1,13 +1,15 @@
$FreeBSD$
---- src/celestia/glutmain.cpp.orig Tue Apr 30 10:36:11 2002
-+++ src/celestia/glutmain.cpp Sat May 18 16:16:21 2002
-@@ -509,7 +509,7 @@
+--- src/celestia/glutmain.cpp.orig Sat Nov 2 23:20:19 2002
++++ src/celestia/glutmain.cpp Tue Mar 16 12:47:46 2004
+@@ -511,8 +511,8 @@
// Set the simulation starting time to the current system time
time_t curtime=time(NULL);
appCore->start((double) curtime / 86400.0 + (double) astro::Date(1970, 1, 1));
- #ifdef MACOSX
+- /* localtime in Darwin is is reentrant only
+ #if defined(MACOSX) || defined(__FreeBSD__)
- /* localtime in Darwin is is reentrant only
++ /* localtime in Darwin is reentrant only
equiv to Linux localtime_r()
should probably port !MACOSX code to use this too, available since
+ libc 5.2.5 according to manpage */
diff --git a/astro/celestia/files/patch-src_celestia_gtkmain.cpp b/astro/celestia/files/patch-src_celestia_gtkmain.cpp
deleted file mode 100644
index ede78b615f60..000000000000
--- a/astro/celestia/files/patch-src_celestia_gtkmain.cpp
+++ /dev/null
@@ -1,36 +0,0 @@
-$FreeBSD$
-
---- src/celestia/gtkmain.cpp.orig Thu May 2 11:02:50 2002
-+++ src/celestia/gtkmain.cpp Tue May 21 03:55:01 2002
-@@ -270,17 +270,8 @@
-
- static gint menuShowLocTime(GtkWidget* w, gpointer data)
- {
-- bool on = (appCore->getTimeZoneBias()==0);
-- if (on)
-- {
-- appCore->setTimeZoneBias(-timezone);
-- appCore->setTimeZoneName(tzname[daylight?0:1]);
-- }
-- else
-- {
-- appCore->setTimeZoneBias(0);
-- appCore->setTimeZoneName("UTC");
-- }
-+ appCore->setTimeZoneBias(0);
-+ appCore->setTimeZoneName("UTC");
- return TRUE;
- }
-
-@@ -2058,9 +2049,8 @@
- appCore->start((double) curtime / 86400.0 + (double) astro::Date(1970, 1, 1));
- localtime(&curtime); /* Only doing this to set timezone as a side
- effect*/
-- appCore->setTimeZoneBias(-timezone);
-- appCore->setTimeZoneName(tzname[daylight?0:1]);
-- timeOptions[1]=tzname[daylight?0:1];
-+ appCore->setTimeZoneBias(localtime(&curtime)->tm_gmtoff);
-+ appCore->setTimeZoneName(localtime(&curtime)->tm_zone);
- }
-
- return TRUE;