aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorTatsuki Makino <tatsuki_makino@hotmail.com>2021-09-01 06:44:32 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-09-01 08:00:30 +0000
commit24157ac4123f41a696c5f4511709e932f3afe06d (patch)
tree69408bfb9b66c6d80007a8b442c3078414775fa9 /astro
parentae8096986b45b6c8cb80e2d39462dc07e56c404d (diff)
downloadports-24157ac4123f41a696c5f4511709e932f3afe06d.tar.gz
ports-24157ac4123f41a696c5f4511709e932f3afe06d.zip
astro/geographiclib: Update to 1.52
Diffstat (limited to 'astro')
-rw-r--r--astro/geographiclib/Makefile50
-rw-r--r--astro/geographiclib/distinfo6
-rw-r--r--astro/geographiclib/files/patch-CMakeLists.txt2
-rw-r--r--astro/geographiclib/files/patch-cmake_CMakeLists.txt4
-rw-r--r--astro/geographiclib/pkg-plist7
5 files changed, 36 insertions, 33 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index a4e96f93f5d9..c38d1aacf12e 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -1,10 +1,10 @@
# Created by: Tatsuki Makino <tatsuki_makino@hotmail.com>
PORTNAME= geographiclib
-DISTVERSION= 1.51
+DISTVERSION= 1.52
CATEGORIES= astro
-MASTER_SITES= SF/geographiclib/distrib\
- SF/geographiclib/distrib/archive\
+MASTER_SITES= SF/geographiclib/distrib \
+ SF/geographiclib/distrib/archive \
SF/geographiclib:geoids,gravity,magnetic
DISTNAME= GeographicLib-${DISTVERSIONFULL}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} #
@@ -17,16 +17,20 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= cmake compiler:c++14-lang localbase python:env
-PORTDOCS= *
USE_LDCONFIG= yes
-CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q}\
- -DGEOGRAPHICLIB_LIB_TYPE:STRING=BOTH\
- -DINSTALL_PYTHON_DIR:STRING=${PYTHON_SITELIBDIR:Q}\
- -DINSTALL_DOC_DIR:STRING=${DOCSDIR:Q}
USE_PYTHON= optsuffix
+CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q} \
+ -DGEOGRAPHICLIB_LIB_TYPE:STRING=BOTH \
+ -DINSTALL_PYTHON_DIR:STRING=${PYTHON_SITELIBDIR:Q} \
+ -DINSTALL_DOC_DIR:STRING=${DOCSDIR:Q}
+PORTDOCS= *
OPTIONS_DEFINE= DOCS DOXYGEN PERL
OPTIONS_DEFAULT= DOXYGEN PERL PREC2
+OPTIONS_GROUP= DATASETS
+OPTIONS_SINGLE= PRECISION
+OPTIONS_SINGLE_PRECISION= PREC1 PREC2 PREC3 PREC4 PREC5
+OPTIONS_SUB= yes
DATASETS_DESC= geoid datasets, gravity models and magnetic field models
PERL_DESC= Build documentation with pod2man and pod2html
PREC1_DESC= 1 = float
@@ -35,32 +39,28 @@ PREC3_DESC= 3 = extended
PREC4_DESC= 4 = quadruple
PREC5_DESC= 5 = variable
PRECISION_DESC= default "real" precision
-OPTIONS_SINGLE= PRECISION
-OPTIONS_GROUP= DATASETS
-OPTIONS_SINGLE_PRECISION= PREC1 PREC2 PREC3 PREC4 PREC5
-OPTIONS_SUB= yes
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
DOXYGEN_CMAKE_BOOL= GEOGRAPHICLIB_DOCUMENTATION
-DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen\
- sphinx-build:textproc/py-sphinx
-PERL_CMAKE_BOOL_OFF= GEOGRAPHICLIB_NO_PERL
-PERL_USE= PERL5=build
-PERL_USES= perl5
PERL_BUILD_DEPENDS= nroff:textproc/groff
+PERL_USES= perl5
+PERL_USE= PERL5=build
+PERL_CMAKE_BOOL_OFF= GEOGRAPHICLIB_NO_PERL
PREC1_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=1
PREC2_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=2
PREC3_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=3
-PREC4_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=4
-PREC4_USE= GCC=yes
PREC4_BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
PREC4_RUN_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
-PREC5_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=5
-PREC5_USE= GCC=yes
+PREC4_USE= GCC=yes
+PREC4_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=4
PREC5_BROKEN= error: call of overloaded 'max' is ambiguous\
error: '*' was not declared in this scope
PREC5_BUILD_DEPENDS= ${LOCALBASE}/include/mpreal.h:math/mpfrc++
-PREC5_LIB_DEPENDS= libgmp.so:math/gmp\
- libmpfr.so:math/mpfr
+PREC5_LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
PREC5_RUN_DEPENDS= ${LOCALBASE}/include/mpreal.h:math/mpfrc++
+PREC5_USE= GCC=yes
+PREC5_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=5
GEOID_NAMES= egm84-30 egm84-15 egm96-15 egm96-5\
egm2008-5 egm2008-2_5 egm2008-1
@@ -104,9 +104,11 @@ DEF_DATASETS_OPTIONS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
. endif
.endfor
+# list of targets that require all distfiles
.ifmake makesum || makeplist || distclean
OPTIONS_DEFAULT+= ${ALL_DATASETS_OPTIONS}
-_OPTIONS_OK= yes # to prevent recursive execution
+# _OPTIONS_OK=yes to prevent recursive execution
+_OPTIONS_OK= yes
.else
OPTIONS_DEFAULT+= ${DEF_DATASETS_OPTIONS}
.endif
diff --git a/astro/geographiclib/distinfo b/astro/geographiclib/distinfo
index f6b2381a9e78..c75857ec3d14 100644
--- a/astro/geographiclib/distinfo
+++ b/astro/geographiclib/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1607396400
-SHA256 (GeographicLib/GeographicLib-1.51.tar.gz) = 34370949617df5105bd6961e0b91581aef758dc455fe8629eb5858516022d310
-SIZE (GeographicLib/GeographicLib-1.51.tar.gz) = 2470362
+TIMESTAMP = 1624849200
+SHA256 (GeographicLib/GeographicLib-1.52.tar.gz) = 5d4145cd16ebf51a2ff97c9244330a340787d131165cfd150e4b2840c0e8ac2b
+SIZE (GeographicLib/GeographicLib-1.52.tar.gz) = 2432658
SHA256 (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = bdb382d0be7ece9142450eacc24b7b7f0889ee3e0ba4f535b04ec383f94c0fb5
SIZE (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = 162388303
SHA256 (GeographicLib/geoids-distrib/egm2008-2_5.tar.bz2) = d602e13446a4a4a23f39aecfe6a2a0760a1bc6c1b497482c2ebc9f7d513be699
diff --git a/astro/geographiclib/files/patch-CMakeLists.txt b/astro/geographiclib/files/patch-CMakeLists.txt
index d3ea09d23a71..142eff9ee0d8 100644
--- a/astro/geographiclib/files/patch-CMakeLists.txt
+++ b/astro/geographiclib/files/patch-CMakeLists.txt
@@ -4,7 +4,7 @@
# directory is present you get this behavior regardless.
option (CONVERT_WARNINGS_TO_ERRORS "Convert warnings into errors?" OFF)
-+# (12) Allow perl usage to be explicitly disabled. It might exist on the
++# (+) Allow perl usage to be explicitly disabled. It might exist on the
+# system, but the user may not necessarily want it to be used for one reason
+# or another.
+option (GEOGRAPHICLIB_NO_PERL "Disable usage of pod2man and pod2html" OFF)
diff --git a/astro/geographiclib/files/patch-cmake_CMakeLists.txt b/astro/geographiclib/files/patch-cmake_CMakeLists.txt
index 6da1ced07c2b..1cdb14bb28f5 100644
--- a/astro/geographiclib/files/patch-cmake_CMakeLists.txt
+++ b/astro/geographiclib/files/patch-cmake_CMakeLists.txt
@@ -1,6 +1,6 @@
---- cmake/CMakeLists.txt.orig 2020-11-22 14:00:22 UTC
+--- cmake/CMakeLists.txt.orig 2021-06-21 21:30:33 UTC
+++ cmake/CMakeLists.txt
-@@ -100,4 +100,4 @@ set (PACKAGE_VERSION "${PROJECT_VERSION}")
+@@ -112,4 +112,4 @@ set (PACKAGE_VERSION "${PROJECT_VERSION}")
configure_file (project.pc.in geographiclib.pc @ONLY)
install (FILES
"${CMAKE_CURRENT_BINARY_DIR}/geographiclib.pc"
diff --git a/astro/geographiclib/pkg-plist b/astro/geographiclib/pkg-plist
index 1805de51f2b2..d6c33ea34912 100644
--- a/astro/geographiclib/pkg-plist
+++ b/astro/geographiclib/pkg-plist
@@ -54,14 +54,14 @@ include/GeographicLib/UTMUPS.hpp
include/GeographicLib/Utility.hpp
lib/cmake/GeographicLib/geographiclib-config-version.cmake
lib/cmake/GeographicLib/geographiclib-config.cmake
-lib/cmake/GeographicLib/geographiclib-namespace-targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/GeographicLib/geographiclib-namespace-targets.cmake
+lib/cmake/GeographicLib/geographiclib-legacy-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/GeographicLib/geographiclib-legacy-targets.cmake
lib/cmake/GeographicLib/geographiclib-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/GeographicLib/geographiclib-targets.cmake
lib/libGeographic.a
lib/libGeographic.so
lib/libGeographic.so.19
-lib/libGeographic.so.19.1.0
+lib/libGeographic.so.19.2.0
lib/node_modules/geographiclib/LICENSE.txt
lib/node_modules/geographiclib/README.md
lib/node_modules/geographiclib/geographiclib.js
@@ -73,6 +73,7 @@ lib/node_modules/geographiclib/src/GeodesicLine.js
lib/node_modules/geographiclib/src/Math.js
lib/node_modules/geographiclib/src/PolygonArea.js
lib/node_modules/geographiclib/test/geodesictest.js
+lib/node_modules/geographiclib/types/geographiclib.d.ts
%%PYTHON_SITELIBDIR%%/geographiclib/__init__.py
%%PYTHON_SITELIBDIR%%/geographiclib/accumulator.py
%%PYTHON_SITELIBDIR%%/geographiclib/constants.py