aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-25 11:33:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-25 11:33:17 +0000
commit8938416596703264ee230a74558e43c227e442e0 (patch)
tree1a2dfebe5ac9b862ab05f56a21c2f00850b56538 /astro
parent123917f35fbe3b26d56936d2a0194c7c3d9d6752 (diff)
downloadports-8938416596703264ee230a74558e43c227e442e0.tar.gz
ports-8938416596703264ee230a74558e43c227e442e0.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/cfitsio/Makefile4
-rw-r--r--astro/cfitsio/distinfo4
-rw-r--r--astro/cfitsio/files/patch-Makefile.in18
3 files changed, 13 insertions, 13 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 5b101541b136..8e11f85df520 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cfitsio
-PORTVERSION= 3.330
+PORTVERSION= 3.350
CATEGORIES= astro
MASTER_SITES= http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/ \
http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/oldvers/ \
@@ -16,7 +16,7 @@ COMMENT= Library for reading and writing files in FITS data format
LICENSE= MIT
-LIB_DEPENDS= f2c:${PORTSDIR}/lang/f2c
+LIB_DEPENDS= libf2c.so:${PORTSDIR}/lang/f2c
OPTIONS_DEFINE= DOCS
diff --git a/astro/cfitsio/distinfo b/astro/cfitsio/distinfo
index 8078afa9e655..a06611e045f5 100644
--- a/astro/cfitsio/distinfo
+++ b/astro/cfitsio/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cfitsio3330.tar.gz) = ed686cc776641d4352f8670d3dd9a4750bdb54f2fe04c8d81fb8eeb79c1d2b25
-SIZE (cfitsio3330.tar.gz) = 4481323
+SHA256 (cfitsio3350.tar.gz) = eb195f227a21cb5c1334c14ec5de3cc1cfbea6255c772f62e3fb5111b078af0e
+SIZE (cfitsio3350.tar.gz) = 4655732
diff --git a/astro/cfitsio/files/patch-Makefile.in b/astro/cfitsio/files/patch-Makefile.in
index e885e5fe53da..3e7891a9000b 100644
--- a/astro/cfitsio/files/patch-Makefile.in
+++ b/astro/cfitsio/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2012-07-18 05:38:34.000000000 +0900
-+++ Makefile.in 2012-08-10 01:18:07.000000000 +0900
-@@ -52,9 +52,7 @@
+--- Makefile.in.orig 2013-07-09 00:43:01.000000000 +0800
++++ Makefile.in 2013-11-25 05:28:16.512550644 +0800
+@@ -60,9 +60,7 @@
putcolj.c putcolk.c putcoluk.c putcoll.c putcols.c putcolsb.c \
putcolu.c putcolui.c putcoluj.c putkey.c region.c scalnull.c \
swapproc.c wcssub.c wcsutil.c imcompress.c quantize.c ricecomp.c \
@@ -11,12 +11,12 @@
SOURCES = ${CORE_SOURCES} @F77_WRAPPERS@
-@@ -87,7 +85,7 @@
+@@ -95,7 +93,7 @@
shared: libcfitsio${SHLIB_SUFFIX}
libcfitsio${SHLIB_SUFFIX}: ${OBJECTS}
-- ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lm ${LIBS}
-+ ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lm -lz ${LIBS}
-
- install: libcfitsio.a $(INSTALL_DIRS)
- @if [ -f libcfitsio.a ]; then \
+- ${SHLIB_LD} ${LDFLAGS} -o ${CFITSIO_SHLIB} ${OBJECTS} -lm ${LIBS}
++ ${SHLIB_LD} ${LDFLAGS} -o ${CFITSIO_SHLIB} ${OBJECTS} -lm -lz ${LIBS}
+ @if [ "x${CFITSIO_SHLIB_SONAME}" != x ]; then \
+ ln -sf ${CFITSIO_SHLIB} ${CFITSIO_SHLIB_SONAME}; \
+ ln -sf ${CFITSIO_SHLIB_SONAME} $@; \