aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-05-27 16:47:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-05-27 16:47:39 +0000
commit92244e74fd113476db33e4cd4262f52e60f2194b (patch)
treed544bf10f1dac053bed3533eacdabc35edfbb740 /astro
parent060047221e81c8e50c9e9be8fc66fd98cd284a01 (diff)
downloadports-92244e74fd113476db33e4cd4262f52e60f2194b.tar.gz
ports-92244e74fd113476db33e4cd4262f52e60f2194b.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/osmium/Makefile73
-rw-r--r--astro/osmium/distinfo2
-rw-r--r--astro/osmium/files/patch-test-run_tests.sh15
-rw-r--r--astro/osmium/pkg-descr5
-rw-r--r--astro/osmium/pkg-plist94
6 files changed, 190 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index d4e110a35eb5..a83e9cc8533f 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -51,6 +51,7 @@
SUBDIR += openmap
SUBDIR += openuniverse
SUBDIR += orsa
+ SUBDIR += osmium
SUBDIR += osmosis
SUBDIR += p5-Astro
SUBDIR += p5-Astro-ADS
diff --git a/astro/osmium/Makefile b/astro/osmium/Makefile
new file mode 100644
index 000000000000..5447a8c40bbc
--- /dev/null
+++ b/astro/osmium/Makefile
@@ -0,0 +1,73 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= osmium
+PORTVERSION= git20130522
+CATEGORIES= astro geography devel
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= C++/Javascript framework for working with OSM files
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+
+LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal \
+ boost_regex:${PORTSDIR}/devel/boost-libs \
+ sqlite3:${PORTSDIR}/databases/sqlite3 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ geos:${PORTSDIR}/graphics/geos \
+ protobuf:${PORTSDIR}/devel/protobuf
+BUILD_DEPENDS= google-sparsehash>=2.0.2:${PORTSDIR}/devel/google-sparsehash
+RUN_DEPENDS= google-sparsehash>=2.0.2:${PORTSDIR}/devel/google-sparsehash
+
+USE_GITHUB= yes
+GH_ACCOUNT= joto
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 1a5bb26
+
+CXXFLAGS+= -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= JAVASCRIPT DOXYGEN DOCS
+OPTIONS_DEFAULT=JAVASCRIPT DOCS
+JAVASCRIPT_DESC=Enable javascript support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MJAVASCRIPT}
+LIB_DEPENDS+= v8:${PORTSDIR}/lang/v8 \
+ shp:${PORTSDIR}/devel/shapelib \
+ icuuc:${PORTSDIR}/devel/icu
+.endif
+
+.if ${PORT_OPTIONS:MDOXYGEN} && ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+.endif
+
+do-build:
+.if ${PORT_OPTIONS:MDOXYGEN} && ${PORT_OPTIONS:MDOCS}
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKR_ARGS} doc
+.else
+ ${DO_NADA}
+.endif
+
+regression-test:
+ cd ${WRKSRC}/test && ${SETENV} ${MAKE_ENV} ${SH} run_tests.sh
+
+do-install:
+ cd ${WRKSRC}/include && ${COPYTREE_SHARE} '${PORTNAME} ${PORTNAME}.hpp' \
+ ${PREFIX}/include/
+.if ${PORT_OPTIONS:MDOCS}
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOXYGEN}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${DOCSDIR}/
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/THANKS \
+ ${WRKSRC}/NOTES_FOR_DEVELOPERS ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/osmium/distinfo b/astro/osmium/distinfo
new file mode 100644
index 000000000000..90736e576591
--- /dev/null
+++ b/astro/osmium/distinfo
@@ -0,0 +1,2 @@
+SHA256 (osmium-git20130522.tar.gz) = 4d2b79245297091cb25c2d6f57c5c32d455f65afb1285d7a120bae7c4ee4aabf
+SIZE (osmium-git20130522.tar.gz) = 149382
diff --git a/astro/osmium/files/patch-test-run_tests.sh b/astro/osmium/files/patch-test-run_tests.sh
new file mode 100644
index 000000000000..8a7f46bcdd1d
--- /dev/null
+++ b/astro/osmium/files/patch-test-run_tests.sh
@@ -0,0 +1,15 @@
+--- test/run_tests.sh.orig 2013-05-09 19:20:50.000000000 +0400
++++ test/run_tests.sh 2013-05-23 00:01:42.140354335 +0400
+@@ -10,8 +10,10 @@
+
+ set -e
+
+-CXX="g++"
+-CXXFLAGS="-g -Wall -Wextra -Wredundant-decls -Wdisabled-optimization -pedantic -Wctor-dtor-privacy -Wnon-virtual-dtor -Woverloaded-virtual -Wsign-promo -Wno-long-long"
++if [ -z "$CXX" ]; then
++ CXX="g++"
++fi
++CXXFLAGS="$CXXFLAGS -g -Wall -Wextra -Wredundant-decls -Wdisabled-optimization -pedantic -Wctor-dtor-privacy -Wnon-virtual-dtor -Woverloaded-virtual -Wsign-promo -Wno-long-long"
+ COMPILE="$CXX -I../include -I. $CXXFLAGS -o tests"
+
+ if [ "x$1" = "x-v" ]; then
diff --git a/astro/osmium/pkg-descr b/astro/osmium/pkg-descr
new file mode 100644
index 000000000000..66c7f5d1d710
--- /dev/null
+++ b/astro/osmium/pkg-descr
@@ -0,0 +1,5 @@
+Osmium is a C++ framework for working with OSM data files. Osmium
+can read OSM data in XML or binary format (PBF) and can call different
+handlers for each OSM object.
+
+WWW: http://wiki.openstreetmap.org/wiki/Osmium
diff --git a/astro/osmium/pkg-plist b/astro/osmium/pkg-plist
new file mode 100644
index 000000000000..90d09b262c20
--- /dev/null
+++ b/astro/osmium/pkg-plist
@@ -0,0 +1,94 @@
+include/osmium.hpp
+include/osmium/debug.hpp
+include/osmium/export.hpp
+include/osmium/export/csv.hpp
+include/osmium/export/shapefile.hpp
+include/osmium/geometry.hpp
+include/osmium/geometry/from_way.hpp
+include/osmium/geometry/geos.hpp
+include/osmium/geometry/haversine.hpp
+include/osmium/geometry/linestring.hpp
+include/osmium/geometry/multipolygon.hpp
+include/osmium/geometry/null.hpp
+include/osmium/geometry/ogr.hpp
+include/osmium/geometry/ogr_multipolygon.hpp
+include/osmium/geometry/point.hpp
+include/osmium/geometry/polygon.hpp
+include/osmium/geometry/shplib.hpp
+include/osmium/handler.hpp
+include/osmium/handler/coordinates_for_ways.hpp
+include/osmium/handler/debug.hpp
+include/osmium/handler/endtime.hpp
+include/osmium/handler/find_bbox.hpp
+include/osmium/handler/progress.hpp
+include/osmium/handler/range_from_history.hpp
+include/osmium/input.hpp
+include/osmium/input/pbf.hpp
+include/osmium/input/xml.hpp
+include/osmium/javascript.hpp
+include/osmium/javascript/handler.hpp
+include/osmium/javascript/template.hpp
+include/osmium/javascript/unicode.hpp
+include/osmium/javascript/wrapper/export_csv.hpp
+include/osmium/javascript/wrapper/export_shapefile.hpp
+include/osmium/javascript/wrapper/geometry.hpp
+include/osmium/javascript/wrapper/osm.hpp
+include/osmium/javascript/wrapper/position.hpp
+include/osmium/multipolygon/assembler.hpp
+include/osmium/multipolygon/builder.hpp
+include/osmium/osm.hpp
+include/osmium/osm/area.hpp
+include/osmium/osm/bounds.hpp
+include/osmium/osm/meta.hpp
+include/osmium/osm/node.hpp
+include/osmium/osm/object.hpp
+include/osmium/osm/position.hpp
+include/osmium/osm/relation.hpp
+include/osmium/osm/relation_member.hpp
+include/osmium/osm/relation_member_list.hpp
+include/osmium/osm/segment.hpp
+include/osmium/osm/tag.hpp
+include/osmium/osm/tag_list.hpp
+include/osmium/osm/tag_ostream.hpp
+include/osmium/osm/types.hpp
+include/osmium/osm/undirected_segment.hpp
+include/osmium/osm/way.hpp
+include/osmium/osm/way_node.hpp
+include/osmium/osm/way_node_list.hpp
+include/osmium/osmfile.hpp
+include/osmium/output.hpp
+include/osmium/output/pbf.hpp
+include/osmium/output/xml.hpp
+include/osmium/relations/assembler.hpp
+include/osmium/relations/relation_info.hpp
+include/osmium/smart_ptr.hpp
+include/osmium/storage/byid.hpp
+include/osmium/storage/byid/fixed_array.hpp
+include/osmium/storage/byid/mmap_anon.hpp
+include/osmium/storage/byid/mmap_file.hpp
+include/osmium/storage/byid/sparse_table.hpp
+include/osmium/storage/byid/vector.hpp
+include/osmium/storage/objectstore.hpp
+include/osmium/tags/key_filter.hpp
+include/osmium/tags/key_value_filter.hpp
+include/osmium/tags/regex_filter.hpp
+include/osmium/tags/to_string.hpp
+include/osmium/utils/delta.hpp
+include/osmium/utils/filter_and_accumulate.hpp
+include/osmium/utils/stringtable.hpp
+include/osmium/utils/timestamp.hpp
+@dirrm include/osmium/utils
+@dirrm include/osmium/tags
+@dirrm include/osmium/storage/byid
+@dirrm include/osmium/storage
+@dirrm include/osmium/relations
+@dirrm include/osmium/output
+@dirrm include/osmium/osm
+@dirrm include/osmium/multipolygon
+@dirrm include/osmium/javascript/wrapper
+@dirrm include/osmium/javascript
+@dirrm include/osmium/input
+@dirrm include/osmium/handler
+@dirrm include/osmium/geometry
+@dirrm include/osmium/export
+@dirrm include/osmium