aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-03-18 09:28:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-03-18 09:28:59 +0000
commitbb0eee0de264de4ac24adb1aa88f5ce2a3d8b77d (patch)
tree1b1d759d5437131b005ba2549f9997baabb4463a /astro
parent76f90b5cf445244379911dad2a0b19cf96b4d2d1 (diff)
downloadports-bb0eee0de264de4ac24adb1aa88f5ce2a3d8b77d.tar.gz
ports-bb0eee0de264de4ac24adb1aa88f5ce2a3d8b77d.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/celestia/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 67c5ca9449b7..addd2c007936 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -15,6 +15,8 @@ PKGNAMESUFFIX= -${CELESTIA_UI}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Scriptable space flight simulator for X
+LICENSE= GPLv2
+
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png
@@ -83,12 +85,8 @@ PLIST_SUB+= KDE="@comment "
PORTDOCS= AUTHORS ChangeLog README
-DESKTOP_ENTRIES="Celestia" \
- "Explore space" \
- "celestia.png" \
- "celestia" \
- "Application;Astronomy;Education;Science;" \
- ${STARTUP_NOTIFY}
+DESKTOP_ENTRIES="Celestia" "Explore space" "celestia.png" "celestia" \
+ "Application;Astronomy;Education;Science;" ${STARTUP_NOTIFY}
# Lua support should be optional, but the build fails without it
USE_LUA= 5.0+
@@ -99,8 +97,8 @@ pre-patch:
.for o in O2 ffast-math fexpensive-optimizations fomit-frame-pointer
@${REINPLACE_CMD} -e 's|-${o}||g' ${WRKSRC}/configure
.endfor
-# Inhibit installation of copies of GPL (lots of them!) and remove bogus
-# argument from mv(1)
+# Inhibit installation of copies of GPL (lots of them; use LICENSE framework
+# instead) and remove bogus argument from mv(1)
@${REINPLACE_CMD} -e 's|COPYING||g ; s| -b|| ' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|=.*COPYING_\*)|=| ; \
/KDE_DIST/s|COPYING_[^ ]* ||g' ${WRKSRC}/locale/Makefile.in