aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
commitc5aeb93cd5e4998728da54611bdf63c686a2fdfd (patch)
treef418d7aa01e7bae10fc4d0734eec45cd9e925529 /astro
parentf4c5a682e5c43c1c1477307463458409ae3b3de5 (diff)
downloadports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.tar.gz
ports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/celestia/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 18f8c76151e2..7dd2e7b31608 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -26,9 +26,9 @@ WANT_GNOME= yes
USE_X_PREFIX= yes
CONFIGURE_ARGS= --program-prefix=""
-CONFIGURE_ENV= \
- LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}" \
- CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut
@@ -77,8 +77,10 @@ IGNORE= does not compile on FreeBSD 4.x
.endif
.if defined(WITH_LUA)
-LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua50
+USE_LUA= 5.0
CONFIGURE_ARGS+= --with-lua
+CPPFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
.endif
pre-patch: