aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-11-08 18:57:00 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-11-08 18:57:00 +0000
commit2bf27373327c9fb50709f0c6c445f95cf0a2a65f (patch)
tree7b54f84e1011da7f5ce9fbc0d12231a107ad2355 /astro
parentc80f3d4c0678c9cadfe180608d5bd096dd712b7d (diff)
downloadports-2bf27373327c9fb50709f0c6c445f95cf0a2a65f.tar.gz
ports-2bf27373327c9fb50709f0c6c445f95cf0a2a65f.zip
archivers/quazip: update to 1.1
- fix / modify find calls and include directories in dependent ports
Notes
Notes: svn path=/head/; revision=554642
Diffstat (limited to 'astro')
-rw-r--r--astro/marble/Makefile3
-rw-r--r--astro/merkaartor/Makefile4
-rw-r--r--astro/merkaartor/files/patch-src_src.pro5
-rw-r--r--astro/qmapshack/Makefile3
-rw-r--r--astro/qmapshack/files/patch-CMakeLists.txt10
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt20
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp11
7 files changed, 44 insertions, 12 deletions
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index a89726420db4..f84380824d04 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -2,6 +2,7 @@
PORTNAME= marble
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= astro kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ COMMENT= Virtual globe and world atlas for KDE
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libquazip5.so:archivers/quazip
+LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip
USES= cmake compiler:c++11-lang desktop-file-utils gettext \
kde:5 qt:5 shared-mime-info tar:xz
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 50587c98f35f..cd93813c8773 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= merkaartor
PORTVERSION= 0.18.2
-PORTREVISION= 25
+PORTREVISION= 26
CATEGORIES= astro
MAINTAINER= dev2@heesakkers.info
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip5.so:archivers/quazip
+ libquazip1-qt5.so:archivers/quazip
USES= compiler:c++11-lang gnome pkgconfig qmake qt:5 sqlite:3
USE_GITHUB= yes
diff --git a/astro/merkaartor/files/patch-src_src.pro b/astro/merkaartor/files/patch-src_src.pro
index 0319e85e7eb6..801f74ca620b 100644
--- a/astro/merkaartor/files/patch-src_src.pro
+++ b/astro/merkaartor/files/patch-src_src.pro
@@ -1,12 +1,13 @@
Link against the right library name for archivers/quazip-qt5.
--- src/src.pro.orig 2015-07-19 14:50:09 UTC
+++ src/src.pro
-@@ -15,7 +15,7 @@ isEmpty(SYSTEM_QUAZIP) {
+@@ -15,7 +15,8 @@ isEmpty(SYSTEM_QUAZIP) {
DEFINES += QUAZIP_STATIC
include(../3rdparty/quazip-0.7/quazip.pri)
} else {
- LIBS += -lquazip
-+ LIBS += -lquazip5
++ CONFIG += link_pkgconfig
++ PKGCONFIG += quazip1-qt5
}
#Qt Version
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 547268176cd8..b457be42c01b 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -4,6 +4,7 @@
PORTNAME= qmapshack
PORTVERSION= 1.15.0
DISTVERSIONPREFIX= V_
+PORTREVISION= 1
CATEGORIES= astro
MAINTAINER= bofh@FreeBSD.org
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip5.so:archivers/quazip \
+ libquazip1-qt5.so:archivers/quazip \
libroutino.so:astro/routino
RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
diff --git a/astro/qmapshack/files/patch-CMakeLists.txt b/astro/qmapshack/files/patch-CMakeLists.txt
index 1872b290793c..f281d11e1dbb 100644
--- a/astro/qmapshack/files/patch-CMakeLists.txt
+++ b/astro/qmapshack/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+--- CMakeLists.txt.orig 2020-06-14 10:22:49 UTC
+++ CMakeLists.txt
@@ -65,6 +65,7 @@ include(TranslateDesktop)
include(DefineCMakeDefaults)
@@ -8,7 +8,7 @@
include(CPackConfig.cmake)
include(ConfigureChecks.cmake)
-@@ -167,7 +168,10 @@ find_package(Qt5WebEngineWidgets REQUIRED)
+@@ -167,10 +168,13 @@ find_package(Qt5WebEngineWidgets REQUIRED)
find_package(Qt5Qml REQUIRED)
find_package(Qt5Help REQUIRED)
find_package(GDAL REQUIRED)
@@ -19,4 +19,8 @@
+endif()
find_package(JPEG REQUIRED)
find_package(ROUTINO REQUIRED)
- find_package(QuaZip5 REQUIRED)
+-find_package(QuaZip5 REQUIRED)
++find_package(QuaZip-Qt5 REQUIRED)
+ find_package(ALGLIB ) # optional as we can use our local version
+
+
diff --git a/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
index 305ebbe7f15f..d4d35b223ec6 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
@@ -1,11 +1,25 @@
---- src/qmapshack/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+--- src/qmapshack/CMakeLists.txt.orig 2020-06-14 10:22:49 UTC
+++ src/qmapshack/CMakeLists.txt
-@@ -920,7 +920,7 @@ target_link_libraries(${APPLICATION_NAME}
+@@ -897,7 +897,6 @@ include_directories(
+ ${PROJ4_INCLUDE_DIRS}
+ ${ROUTINO_INCLUDE_DIRS}
+ ${ALGLIB_INCLUDE_DIRS}
+- ${QUAZIP_INCLUDE_DIRS}
+ )
+
+ if(APPLE)
+@@ -941,12 +940,12 @@ target_link_libraries(${APPLICATION_NAME}
+ Qt5::Qml
+ Qt5::Positioning
Qt5::Help
++ QuaZip::QuaZip
${DBUS_LIB}
${GDAL_LIBRARIES}
- ${PROJ4_LIBRARIES}
+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
${ROUTINO_LIBRARIES}
${ALGLIB_LIBRARIES}
- ${QUAZIP_LIBRARIES}
+- ${QUAZIP_LIBRARIES}
+ )
+
+ if(APPLE)
diff --git a/astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp b/astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp
new file mode 100644
index 000000000000..46b6910b8604
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp
@@ -0,0 +1,11 @@
+--- src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp.orig 2020-11-08 17:59:37 UTC
++++ src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp
+@@ -22,7 +22,7 @@
+ #include "gis/rte/router/brouter/CRouterBRouterSetupWizard.h"
+ #include "helpers/CWebPage.h"
+ #include "setup/IAppSetup.h"
+-#include <JlCompress.h>
++#include <quazip/JlCompress.h>
+ #include <proj_api.h>
+ #include <QFileDialog>
+ #include <QMessageBox>