aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-10-22 17:54:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-10-22 17:54:41 +0000
commit65be4328fbb31e84543c8b2440920f1b8d021fdf (patch)
tree603e3ce35aa45768fc9639fb48dc40f17f90b674 /astro
parentd02ea931666343435a35a5407eac6e2f75aed975 (diff)
downloadports-65be4328fbb31e84543c8b2440920f1b8d021fdf.tar.gz
ports-65be4328fbb31e84543c8b2440920f1b8d021fdf.zip
Add ASYNC option
- Bump PORTREVISION for dependency change
Notes
Notes: svn path=/head/; revision=553031
Diffstat (limited to 'astro')
-rw-r--r--astro/py-spacetrack/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/astro/py-spacetrack/Makefile b/astro/py-spacetrack/Makefile
index d5517a5450da..869fa2b235b8 100644
--- a/astro/py-spacetrack/Makefile
+++ b/astro/py-spacetrack/Makefile
@@ -25,4 +25,10 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= ASYNC
+OPTIONS_DEFAULT=ASYNC
+ASYNC_DESC= Asynchronous support
+
+ASYNC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.6:www/py-aiohttp@${PY_FLAVOR}
+
.include <bsd.port.mk>