aboutsummaryrefslogtreecommitdiff
path: root/audio/aacplusenc/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-29 15:51:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-29 15:51:08 +0000
commitba2fddf97c223d474d6cdffbca67749629897318 (patch)
tree575e36d2eb1c86c61c51475bc7bed979460173c9 /audio/aacplusenc/Makefile
parent7d537f3450bb8a334618fcee7f9706bf26b57aef (diff)
downloadports-ba2fddf97c223d474d6cdffbca67749629897318.tar.gz
ports-ba2fddf97c223d474d6cdffbca67749629897318.zip
Notes
Diffstat (limited to 'audio/aacplusenc/Makefile')
-rw-r--r--audio/aacplusenc/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/aacplusenc/Makefile b/audio/aacplusenc/Makefile
new file mode 100644
index 000000000000..3477cc36dad8
--- /dev/null
+++ b/audio/aacplusenc/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: aacplusenc
+# Date created: 28 July 2007
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aacplusenc
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://teknoraver.campuslife.it/software/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= aacPlus v2 command-line encoder
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS_REASON= Produces badly sounding files on amd64
+RESTRICTED= unclear legal status, probably need licenses from 3GPP, Via Licensing and Coding Technologies
+
+PLIST_FILES= bin/aacplusenc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3 -ftree-vectorize|${CFLAGS}|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>