aboutsummaryrefslogtreecommitdiff
path: root/audio/acoustid-fingerprinter/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 14:54:12 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 14:54:12 +0000
commit124e223954269972eba1ec49ad38f7cd10b65703 (patch)
treed8cb81652914684ff7185d8630f9e4fd52442dec /audio/acoustid-fingerprinter/Makefile
parent86c8eb06e3788652e3b3400819dd67ed22680aea (diff)
Notes
Diffstat (limited to 'audio/acoustid-fingerprinter/Makefile')
-rw-r--r--audio/acoustid-fingerprinter/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/acoustid-fingerprinter/Makefile b/audio/acoustid-fingerprinter/Makefile
index 74487cf181e6..d880dcba646b 100644
--- a/audio/acoustid-fingerprinter/Makefile
+++ b/audio/acoustid-fingerprinter/Makefile
@@ -2,7 +2,7 @@
PORTNAME= acoustid-fingerprinter
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://bitbucket.org/acoustid/${PORTNAME}/downloads/ \
http://cloud.github.com/downloads/lalinsky/${PORTNAME}/
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libchromaprint.so:${PORTSDIR}/audio/chromaprint \
libtag.so:${PORTSDIR}/audio/taglib \
- libavcodec${FFMPEG_SUFFIX}.so:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX}
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
USES= cmake
USE_QT4= gui network \
@@ -22,12 +22,12 @@ USE_QT4= gui network \
INSTALLS_ICONS= yes
FETCH_ARGS= -Fpr
-CMAKE_ARGS= -DFFMPEG_SUFFIX:STRING=${FFMPEG_SUFFIX}
-FFMPEG_SUFFIX?= 1
post-patch:
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/cmake/modules/*.cmake
+ @${REINPLACE_CMD} -e 's,CodecID,AVCodecID,g' \
+ ${WRKSRC}/ffmpeg/audioconvert.h
post-install:
.for i in 16 24 32 48 128 256