aboutsummaryrefslogtreecommitdiff
path: root/audio/akode-plugins-pulseaudio
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-27 05:56:16 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-27 05:56:16 +0000
commita57d45076c54ffb96420ab8f9f6affa5b30ce368 (patch)
treeb3e3b5163edf3ad885ee2d5577a43d97b83ea694 /audio/akode-plugins-pulseaudio
parent7f248d93012cd0c70e44534af2d02aced1ce3cdf (diff)
downloadports-a57d45076c54ffb96420ab8f9f6affa5b30ce368.tar.gz
ports-a57d45076c54ffb96420ab8f9f6affa5b30ce368.zip
Notes
Diffstat (limited to 'audio/akode-plugins-pulseaudio')
-rw-r--r--audio/akode-plugins-pulseaudio/Makefile53
-rw-r--r--audio/akode-plugins-pulseaudio/distinfo3
-rw-r--r--audio/akode-plugins-pulseaudio/files/patch-akode_Makefile.in11
-rw-r--r--audio/akode-plugins-pulseaudio/files/patch-akode__polyp_sink__polyp_sink.cpp20
-rw-r--r--audio/akode-plugins-pulseaudio/files/patch-akode_plugins-Makefile.in15
-rw-r--r--audio/akode-plugins-pulseaudio/files/patch-configure21
-rw-r--r--audio/akode-plugins-pulseaudio/pkg-descr3
7 files changed, 126 insertions, 0 deletions
diff --git a/audio/akode-plugins-pulseaudio/Makefile b/audio/akode-plugins-pulseaudio/Makefile
new file mode 100644
index 000000000000..df7cf476ab73
--- /dev/null
+++ b/audio/akode-plugins-pulseaudio/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: akode-plugins-pulseaudio
+# Date created: March 03 2008
+# Whom: Scot W. Hetzel <swhetzel@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= akode-plugins-${PORTNAMESUFX}
+PORTVERSION= 2.0.1
+CATEGORIES= audio kde
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR=distfiles
+DISTNAME= 30375-akode-${PORTVERSION}.tar.bz2
+EXTRACT_SUFX= # none
+
+MAINTAINER= swhetzel@gmail.com
+COMMENT= Pulseaudio output plugin for akode
+
+LIB_DEPENDS= pulse-simple:${PORTSDIR}/audio/pulseaudio
+
+CONFLICTS= kdemultimedia-3.[1-3]* akode-plugins-polypaudio-[0-9]*
+
+PLUGIN= polyp_sink
+PORTNAMESUFX= pulseaudio
+
+USE_AUTOTOOLS= libltdl
+USE_AUTOTOOLS= libtool:15
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/akode-${PORTVERSION}
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/libakode_polyp_sink.a lib/libakode_polyp_sink.la \
+ lib/libakode_polyp_sink.so
+
+CONFIGURE_ENV+= LDFLAGS=-L${WRKSRC}/akode/lib/.libs
+CONFIGURE_ARGS+=--with-extra-libs=${LOCALBASE}/lib \
+ --with-extra-includes=${LOCALBASE}/include
+
+post-patch:
+ @${SETENV} TZ=UTC \
+ ${TOUCH} -t 200607222217.01 ${WRKSRC}/akode/lib/akode_export.h.in
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's@%%SUBDIRS%%@${PLUGIN}@g' ${WRKSRC}/akode/plugins/Makefile.in
+
+do-build:
+ cd ${WRKSRC}/akode && ${GMAKE}
+
+do-install:
+ cd ${WRKSRC}/akode/plugins/${PLUGIN} && ${GMAKE} install
+
+.include <bsd.port.mk>
diff --git a/audio/akode-plugins-pulseaudio/distinfo b/audio/akode-plugins-pulseaudio/distinfo
new file mode 100644
index 000000000000..2dd6d912909d
--- /dev/null
+++ b/audio/akode-plugins-pulseaudio/distinfo
@@ -0,0 +1,3 @@
+MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
+SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
+SIZE (30375-akode-2.0.1.tar.bz2) = 460964
diff --git a/audio/akode-plugins-pulseaudio/files/patch-akode_Makefile.in b/audio/akode-plugins-pulseaudio/files/patch-akode_Makefile.in
new file mode 100644
index 000000000000..2b2f77e6972a
--- /dev/null
+++ b/audio/akode-plugins-pulseaudio/files/patch-akode_Makefile.in
@@ -0,0 +1,11 @@
+--- akode/Makefile.in.orig Tue Nov 29 17:51:19 2005
++++ akode/Makefile.in Tue Nov 29 17:51:05 2005
+@@ -247,7 +247,7 @@
+ unsermake_enable_pch_FALSE = @unsermake_enable_pch_FALSE@
+ unsermake_enable_pch_TRUE = @unsermake_enable_pch_TRUE@
+ bin_SCRIPTS = akode-config
+-SUBDIRS = lib plugins akodeplay
++SUBDIRS = lib plugins
+ #>- all: all-recursive
+ #>+ 1
+ all: docs-am all-recursive
diff --git a/audio/akode-plugins-pulseaudio/files/patch-akode__polyp_sink__polyp_sink.cpp b/audio/akode-plugins-pulseaudio/files/patch-akode__polyp_sink__polyp_sink.cpp
new file mode 100644
index 000000000000..a693dcf1807c
--- /dev/null
+++ b/audio/akode-plugins-pulseaudio/files/patch-akode__polyp_sink__polyp_sink.cpp
@@ -0,0 +1,20 @@
+--- akode/plugins/polyp_sink/polyp_sink.cpp.orig Sun Jun 10 13:23:03 2007
++++ akode/plugins/polyp_sink/polyp_sink.cpp Sun Jun 10 13:24:13 2007
+@@ -25,7 +25,7 @@
+ #elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+ #endif
+-#include <polyp/polyplib-simple.h>
++#include <pulse/simple.h>
+
+ #include "audioframe.h"
+ #include "audiobuffer.h"
+@@ -59,7 +59,7 @@
+
+ bool PolypSink::open() {
+ int error = 0;
+- m_data->server = pa_simple_new(0, "akode-client", PA_STREAM_PLAYBACK, 0, "", &m_data->sample_spec, 0, 255, &error );
++ m_data->server = pa_simple_new(0, "akode-client", PA_STREAM_PLAYBACK, 0, "", &m_data->sample_spec, 0, 0, &error );
+ if (!m_data->server || error != 0) {
+ m_data->error = true;
+ close();
diff --git a/audio/akode-plugins-pulseaudio/files/patch-akode_plugins-Makefile.in b/audio/akode-plugins-pulseaudio/files/patch-akode_plugins-Makefile.in
new file mode 100644
index 000000000000..c43387754ff0
--- /dev/null
+++ b/audio/akode-plugins-pulseaudio/files/patch-akode_plugins-Makefile.in
@@ -0,0 +1,15 @@
+--- akode/plugins/Makefile.in.orig Tue Nov 29 18:10:20 2005
++++ akode/plugins/Makefile.in Tue Nov 29 18:10:45 2005
+@@ -252,11 +252,7 @@
+ @include_sun_sink_TRUE@AKODE_SUN_SINK = sun_sink
+ @include_jack_sink_TRUE@AKODE_JACK_SINK = jack_sink
+ @include_polyp_sink_TRUE@AKODE_POLYP_SINK = polyp_sink
+-SUBDIRS = $(AKODE_MPC_DECODER) $(AKODE_XIPH_DECODER) \
+- $(AKODE_MPEG_DECODER) $(AKODE_FFMPEG_DECODER) \
+- $(AKODE_ALSA_SINK) $(AKODE_OSS_SINK) $(AKODE_SUN_SINK) \
+- $(AKODE_JACK_SINK) $(AKODE_POLYP_SINK) \
+- $(AKODE_SRC_RESAMPLER)
++SUBDIRS = %%SUBDIRS%%
+
+ #>- all: all-recursive
+ #>+ 1
diff --git a/audio/akode-plugins-pulseaudio/files/patch-configure b/audio/akode-plugins-pulseaudio/files/patch-configure
new file mode 100644
index 000000000000..8289d3865f5f
--- /dev/null
+++ b/audio/akode-plugins-pulseaudio/files/patch-configure
@@ -0,0 +1,21 @@
+--- configure.orig Sun Jun 10 13:15:44 2007
++++ configure Sun Jun 10 13:18:48 2007
+@@ -23036,12 +23036,12 @@
+ fi;
+
+ if test "x$polypaudio_test" = "xyes" ; then
+-echo "$as_me:$LINENO: checking for Polypaudio 0.7 or later" >&5
+-echo $ECHO_N "checking for Polypaudio 0.7 or later... $ECHO_C" >&6
+-if $PKG_CONFIG --atleast-version 0.7 polyplib-simple >/dev/null 2>&1 ; then
+- POLYP_CFLAGS="`$PKG_CONFIG --cflags polyplib-simple`"
+- POLYP_LIBADD="`$PKG_CONFIG --libs-only-l polyplib-simple`"
+- POLYP_LDFLAGS="`$PKG_CONFIG --libs-only-L polyplib-simple`"
++echo "$as_me:$LINENO: checking for Pulseaudio 0.9.2 or later" >&5
++echo $ECHO_N "checking for Pulseaudio 0.9.2 or later... $ECHO_C" >&6
++if $PKG_CONFIG --atleast-version 0.9.2 libpulse-simple >/dev/null 2>&1 ; then
++ POLYP_CFLAGS="`$PKG_CONFIG --cflags libpulse-simple`"
++ POLYP_LIBADD="`$PKG_CONFIG --libs-only-l libpulse-simple`"
++ POLYP_LDFLAGS="`$PKG_CONFIG --libs-only-L libpulse-simple`"
+ have_polyp=yes
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
diff --git a/audio/akode-plugins-pulseaudio/pkg-descr b/audio/akode-plugins-pulseaudio/pkg-descr
new file mode 100644
index 000000000000..0f03fbfab8c0
--- /dev/null
+++ b/audio/akode-plugins-pulseaudio/pkg-descr
@@ -0,0 +1,3 @@
+aKode is a simple audio-decoding frame-work that provides a uniform interface
+to decode the most common audio-formats. It also has a direct playback option
+for a number of audio-outputs.