aboutsummaryrefslogtreecommitdiff
path: root/audio/alac/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-02-26 11:38:45 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-02-26 11:38:45 +0000
commit019f6534b07208d007ad3028a99445e83260cced (patch)
tree6dc6868911c2dcb89dce1e0cd3f4bc2464b14a9f /audio/alac/Makefile
parent8a150cc9114666b4e062a1bc8d57acf560fd2134 (diff)
Notes
Diffstat (limited to 'audio/alac/Makefile')
-rw-r--r--audio/alac/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/alac/Makefile b/audio/alac/Makefile
new file mode 100644
index 000000000000..038033c2ef58
--- /dev/null
+++ b/audio/alac/Makefile
@@ -0,0 +1,33 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= alac
+PORTVERSION= 0.0.7
+PORTEPOCH= 1
+CATEGORIES= audio
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Apple Lossless Audio Codec
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= autoreconf libtool pathfix
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+OPTIONS_SUB= yes
+
+GH_ACCOUNT= mikebrady
+
+OPTIONS_DEFINE= CONVERTER
+OPTIONS_DEFINE= CONVERTER
+CONVERTER_DESC= Build with command-line utility to read and write audio data
+OPTIONS_DEFAULT=CONVERTER
+
+CONVERTER_CONFIGURE_ON= --enable-example
+CONVERTER_EXTRA_PATCHES=${FILESDIR}/extrapatch-convert-utility_Makefile.am
+
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>